Garuda Installation Failed

Boost.Python error in "bootloader"

Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force' returned non-zero exit status 1.
Installing for x86_64-efi partition.
Could not prepare Boot variable: No space left on device

I've previously used Garuda KDE Plasma Dragonized Gaming Edition but thought of going for the non-gaming edition now. I removed the Garuda folder from the EFI folder as well as set the EFI partiton size to 1GB, but that only seemed to make it take longer to show the error.

I'm installing using the proprietary drivers option, if that also helps...
Can someone help me out?

The message tells you, 'space is not available' - did you format/wipe the space (s) thoroughly, before installing?

And - welcome to the forum dr0hith :wave:

1 Like

Thanks! Glad to be here!
And wdym by thoroughly?

Is this fine? I've also mounted the EFI partition and removed Garuda from that.

If not a dual boot, I wiped the whole thing and used Calamares installer, accepting defaults and had no problems.

As I say - if not dual boot. Calamares works really well.

1 Like

Hmm... I plan to dual boot in the future, but I'll consider this too! How do you use the calamares installer? Also, if this has a solution, I'd like to use that for now.

I have so many questions... If we wipe the whole disk, then what about the EFI partition? Isn't that where the UEFI is?

You need to choose dual-boot or not now, IMHO.

If Garuda only - wipe the lot and use the default install, just follow the prompts - works great!

Dual-boot, follow - Dual boot with Windows - ArchWiki

1 Like

Coolio. So I should just select the entire disk for the installation process?

I shall do that after dinner. Thanks!

Say, can I dual boot other linux distros after this though?

Yep - that simple.

Your system = your responsibility...yes, you can, but research first.

2 Likes

Always backup your important data before adding another OS.

3 Likes

Yup! It's all in my other hard disk.

1 Like

Are you sure you are installing on a GPT disk or an MBR partition scheme?
The message implies you are using Legacy/MBR type of installation and there is not enough space for grub to be written in MBR.

The 1st partition on a MBR partitioned disk (legacy system) has to be start at about 1-2MBs.


Edited: I apologize for the mistake. I corrected it. I hope it did no harm... :shushing_face:

2 Likes

I have no idea. How do I check?

I tried to do what @Stroke_Finger suggested and used the "Erase the disk" option while installing Garuda and I'm still getting the same error.

EDIT: The first partition is now 2 MB after the failed install.

In your BIOS settings. My mistake, in not checking @petsam is quite right - apologies to you both

1 Like

The disk appears to be gpt partitioned. My bios doesn't seem to tell anything useless. I've been reinstalling countless times to no avail.

What should I do now? What information is needed?

You need to patiently go through the BIOS settings and find a choice between UEFI/GPT + Legacy and select UEFI.

We aren't there and don't know your system.

You need to do some serious reading my friend. Garuda is a 'rolling distro' and it it not if it has problems, but when it has them, due to updates - you need to know how to deal with these issues.

1 Like

Ok. Coolio. This is the first time I had to do stuff like this, rip. I'll look around for that.
Here's some other info that I found.

╰─λ inxi -Fxxxz
System:    Kernel: 5.11.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.21.1 
tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X580GD_N580GD v: 1.0 serial: <filter> 
Mobo: ASUSTeK model: X580GD v: 1.0 serial: <filter> UEFI: American Megatrends v: X580GD.308 
date: 07/26/2018 
Battery:   ID-1: BAT0 charge: 39.3 Wh condition: 39.3/48.1 Wh (82%) volts: 11.6/11.6 
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging 
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake note: check 
rev: A L2 cache: 9 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52799 
Speed: 4022 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4022 2: 4000 3: 4000 4: 4006 
5: 4000 6: 3969 7: 4000 8: 4000 9: 4000 10: 4003 11: 4001 12: 4002 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
chip ID: 8086:3e9b class ID: 0300 
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK driver: nvidia v: 460.39 
bus ID: 01:00.0 chip ID: 10de:1c8d class ID: 0302 
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-6:3 
chip ID: 13d3:56a2 class ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel,nvidia 
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa resolution: 1920x1080~60Hz s-dpi: 96 
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel 
bus ID: 00:1f.3 chip ID: 8086:a348 class ID: 0403 
Sound Server: ALSA v: k5.11.1-zen1-1-zen 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 
bus ID: 00:14.3 chip ID: 8086:a370 class ID: 0280 
IF: wlo1 state: up mac: <filter> 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 
v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168 class ID: 0200 
IF: eno2 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 
bus ID: 1-14:6 chip ID: 8087:0aaa class ID: e001 
Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 2.76 TiB used: 1.81 GiB (0.1%)
ID-1: /dev/nvme0n1 vendor: A-Data model: SX6000LNP size: 953.87 GiB speed: 31.6 Gb/s lanes: 4
rotation: SSD serial: <filter> rev: V9001c00 temp: 29.9 C scheme: GPT
ID-2: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB speed: 6.0 Gb/s
rotation: 5400 rpm serial: <filter> rev: EB01 scheme: GPT
ID-3: /dev/sdb type: USB model: USB Flash Memory size: 14.45 GiB rotation: SSD serial: <filter>
rev: 1.00 scheme: MBR
Partition: ID-1: / size: 23.41 GiB used: 1.81 GiB (7.7%) fs: overlay source: ERR-102
Swap:      ID-1: swap-1 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
ID-9: swap-9 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram8
ID-10: swap-10 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram9
ID-11: swap-11 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram10
ID-12: swap-12 type: zram size: 2.6 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram11
Sensors:   System Temperatures: cpu: 83.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3700
Info:      Processes: 294 Uptime: 10m wakeups: 1 Memory: 31.21 GiB used: 5.4 GiB (17.3%) Init: systemd
v: 247 Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1260 Shell: fish v: 3.1.2
running in: konsole inxi: 3.3.01

That's great - thanks for that, my question would be: Do you know how to enter your BIOS, change settings and save them? (sorry if you do)

I think so. This is the BIOS settings, right?


I can't find the option for what ur asking though

It says EZ-Mode...I would look for a different mode, I fear this mode will not show/allow UEFI/Legacy details/changes.