Grub / KDE install fail

Hey guys,

also as mentioned already in Error on installing garuda linux - #3 by SGS or in Garuda Installation Failed - #28 by dr0hith

I've got the same issue. seems to be an issue due the new grub / systemd or calmares update.
Also got the same issue installing endavouros with the online installer.
Tried several usb sticks and different isos.
Used the dr4gonized iso and all times a encrypted install with luks.
Im not new to arch or to linux. Maybe considering to research the problem on the calmares installer or something with KDE/NVIDIA.

So that there is a issue in the endavouros iso and also your iso it really seems like a problem on calmares installer and not on user site. before I also runned arch and garudaos. both encrypted.

Take a watch

Also tried to install now an unencrypted install. Same issue again.

Hi,
please, could you post your

inxi -Fxxxza
lsblk --path

as text?

Also, the full ISO name you use.

It work fine for me on diff. DE, some user use gparted for a clean/fresh partition afterwards it work fine for him.

1 Like

I will. Just starting now a baritone setup .

Using the newest Garuda-daragonized-normal iso. downloaded from SourceForge.
As I mentioned I got the same issue with the endavouros iso online installer kde.

I clean my DISKS everytime completely before installing any distro.
Ill post if the barebone ode install is gonna failing to.

1 Like

Barebone also failed with the same issue as the other mentioned also in the other threads.
There is really something with the calmares/kde installed. Every time the same issue with gurb got not enough space. But there is enough space left.

God damn. Just wanted to switch from endavour to Garuda. Failed Garuda tried endeavor and they got the same issue. funny :smiley:

Please :slight_smile: :slight_smile:

You surely look like one...
The linked topics have never finished troubleshooting.
If you also don't try troubleshoot, how would we know if and where is the problem?

Act like an Arch user and we can communicate.
We want to fix any bug, but our systems work fine. Cooperate and provide info, so we can find the problem.
Or go to Windows...

2 Likes

Mostly, if EndavourOS is failing which I used a lot of installation also Garuda Linux used on my rig is performing.
both are using calmares installer. Many users reporting the same problem.

Im using linux since 5+ years, also im sysadmin for some business servers and homepages.

Then go for a clean install with LUKS with the newest iso in with kde and Nvidia drivers.
But yeah I should go back to windows after 7 years using linux only. You're welcome man :slight_smile:

Thats fine but didn't help us.

We are looking for experienced users to answer our questions and not tell us that others have the same problem. I mean this neither maliciously nor disrespectfully, a mere fact.

Because I am often said to be a bit harsh in my posts :wink:

Last time

inxi -Fxxxza
lsblk --path

LXQT Install was successful. Also encrypted.

Seems like KDE is broken.

Which one?

A developer ISO?

Full ISO name please.

I have here 3 KDE DE installed without problems except the Nvidia driver. I must use the free driver to install.

https://sourceforge.net/projects/garuda-linux/files/dr460nized/210225/garuda-dr460nized-linux-zen-210225.iso/download

TY

LANG=C sha256sum garuda-dr460nized-linux-zen-210225.iso 
3b55d9a711c9c4c1384c57a916c5882b822009a9d306c390df939bb98b8ac6ec  garuda-dr460nized-linux-zen-210225.iso

Can't test to night. Try it later.

I use an old PC :slight_smile: and it work too.

inxi -Fxxxza
System:    Kernel: 5.11.1-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=de_DE keytable=de tz=Europe/Berlin 
misobasedir=garuda misolabel=GARUDA_DR460NIZED_SOARING_ quiet systemd.show_status=1 splash 
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: MEDIONPC model: MS-7501 v: 3.1 serial: <filter> BIOS: American Megatrends 
v: A7501MLN.30E date: 04/28/2009 
CPU:       Info: Quad Core model: AMD Phenom 9650 bits: 64 type: MCP arch: K10 family: 10 (16) model-id: 2 
stepping: 3 microcode: 1000095 L2 cache: 2 MiB 
flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 18360 
Speed: 2300 MHz min/max: 1150/2300 MHz Core speeds (MHz): 1: 2300 2: 2300 3: 2300 4: 2300 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass status: Not affected 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD RV710 [Radeon HD 4550] vendor: PC Partner Limited driver: radeon v: kernel 
bus ID: 01:00.0 chip ID: 1002:9540 class ID: 0300 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: ati,radeon 
unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5") s-diag: 599mm (23.6") 
Monitor-1: HDMI-0 res: 1920x1200 hz: 60 dpi: 89 size: 550x344mm (21.7x13.5") 
diag: 649mm (25.5") 
OpenGL: renderer: AMD RV710 (DRM 2.50.0 / 5.11.1-zen1-1-zen LLVM 11.1.0) v: 3.3 Mesa 20.3.4 
compat-v: 3.0 direct render: Yes 
Audio:     Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
bus ID: 00:14.2 chip ID: 1002:4383 class ID: 0403 
Device-2: AMD RV710/730 HDMI Audio [Radeon HD 4000 series] vendor: PC Partner Limited 
driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aa38 class ID: 0403 
Sound Server: ALSA v: k5.11.1-zen1-1-zen 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
driver: r8169 v: kernel port: e800 bus ID: 02:00.0 chip ID: 10ec:8168 class ID: 0200 
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Device-2: IMC Networks AW-NU222 802.11bgn Wireless Module [Ralink RT2770+RT2720] type: USB
driver: rt2800usb bus ID: 2-4:4 chip ID: 13d3:3247 class ID: 0000 serial: <filter>
IF: wlp0s19f2u4 state: down mac: <filter>
Drives:    Local Storage: total: 1.52 TiB used: 903.7 MiB (0.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD6400AACS-00G8B1 size: 596.17 GiB
block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 4C05
scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HDT721010SLA360 size: 931.51 GiB
block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter>
rev: A31B scheme: MBR
ID-3: /dev/sdf maj-min: 8:80 type: USB vendor: Transcend model: TS-RDF5 SD Transcend
size: 29.72 GiB block size: physical: 512 B logical: 512 B serial: <filter> rev: TS35
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw size: N/A size: 2.87 GiB used: 903.7 MiB (30.7%) fs: overlay source: ERR-102
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 980.7 MiB used: 61.6 MiB (6.3%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 980.7 MiB used: 61.6 MiB (6.3%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 980.7 MiB used: 61.4 MiB (6.3%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 980.7 MiB used: 61.6 MiB (6.3%) priority: 32767 dev: /dev/zram3
Sensors:   Message: No sensors data was found. Is sensors configured?
Info:      Processes: 208 Uptime: 28m wakeups: 1 Memory: 3.83 GiB used: 3.17 GiB (82.9%) Init: systemd
v: 247 Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1221 lib: 299 Shell: fish
v: 3.1.2 running in: konsole inxi: 3.3.01

I am out.

After boot and update, before reboot.

1 Like

With soap and water? What does that even mean?

So if you've been around for 5+years, why the hell are you even asking this question here. Obviously by now if you have the same issue on two different distros and think it's a calamares issue, then take the issue to calamares.

You haven't posted any real info for help. I thought you were a sysadmin, and you can't provide basic info? I'm shocked. Thus far you're a help vampire at best. If you legit want help, you need to give details.

Not a bad idea. Their installer works great, and you can spam their Microsoft support chat. They like to hand hold people through problems.

4 Likes

Then act like it. You're embarrassing Tux. :wink:

Since it keeps happening with Calamares, it suggests some misstep in your installation process. Try a simpler method.

3 Likes

If you're an experienced Arch user why don't you test the KDE barebones edition to see if it will install properly for you.

If LXQt installs for you you could also swap desktops post install. I would never suggest that for a Newb, but seeing as how you're a sysadmin you should be able to pull that off.

Sure neither of those options is exactly what you'd want, as it involves far more configuration post install. However, it will give you a working KDE install without all the effort of an Arch install.

5 Likes