Freezes on boot after installing propriatary nvida GPU drivers

This seems to be a issue related to my GPU, as the same problem occurred on two different systems, but with the same GPU. It's the zotac GTX 1080 TI mini.

On first boot from live USB, if i select proprietary drivers, it just freezes at plymouth boot-screen, typically at least. It feels random where it freezes. I can successfully boot and install garuda if i select the open source drivers. When it is installed and booted, i do of course not have the proper drivers, and i install the drivers like i normally would. After reboot, i get the same freeze as when i select proprietary drivers from the live USB.

This issue was not present before, and right now, the same issue is with all arch based distros i tried. Mainline arch, garuda, manjaro, endeavoursOS, and one i can't recall the name of that doesn't use systemD.

I haven't tried every non-arch distro, but debian based distros seemed to work. I am stuck on popOS right now.

Edit: I use gardua KDE dragonized gaming edition.

I'm not expert of Nvidia stuff but I'd just suggest that you should try other kernels first of all.
Then maybe provide details on which drivers exactly you installed and from where (this for someone else to help :blush:)...


I have tried many different types of kernels since i have tried many kinds of arch systems. It seems to not be kernel related.

I just get the newest official proprietary drivers from the repo.

Please post your specs

inxi -Faz

and welcome on Garuda :slight_smile:


I already gave info regarding my specs on my profile, but i guess more info was needed here.

  Kernel: 5.12.12-xanmod1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: initrd=\EFI\Pop_OS-e97126fe-bf51-460b-85ec-133a029d1fbe\initrd.img 
  root=UUID=e97126fe-bf51-460b-85ec-133a029d1fbe ro quiet loglevel=0 
  systemd.show_status=false splash 
  Desktop: N/A wm: gnome-shell dm: GDM3 3.38.1 Distro: Pop!_OS 20.10 
  base: Ubuntu 20.10 Groovy 
  Type: Desktop System: ASUS product: N/A v: N/A serial: <filter> 
  Mobo: ASUSTeK model: TUF GAMING X570-PRO (WI-FI) v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 3603 date: 03/20/2021 
  Device-1: hidpp_battery_0 
  model: Logitech G305 Lightspeed Wireless Gaming Mouse serial: <filter> 
  charge: 100% (should be ignored) rechargeable: yes status: Discharging 
  Info: 16-Core model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3 
  family: 19 (25) model-id: 21 (33) stepping: N/A microcode: A201009 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 255991 
  Speed: 3999 MHz min/max: 2200/4000 MHz boost: enabled Core speeds (MHz): 
  1: 3998 2: 4006 3: 3996 4: 3997 5: 3979 6: 4005 7: 3988 8: 4017 9: 3996 
  10: 3998 11: 4000 12: 4020 13: 4000 14: 3995 15: 4003 16: 4016 17: 4001 
  18: 3987 19: 4007 20: 3999 21: 3998 22: 3995 23: 3997 24: 4000 25: 3999 
  26: 3992 27: 3997 28: 3998 29: 3995 30: 3998 31: 4008 32: 3997 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: always-on, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: ZOTAC driver: nvidia 
  v: 460.73.01 alternate: nvidiafb,nouveau,nvidia_drm bus ID: 09:00.0 
  chip ID: 10de:1b06 
  Display: x11 server: X.Org 1.20.9 compositor: gnome-shell driver: nvidia 
  display ID: :1 screens: 1 
  Screen-1: 0 s-res: 5760x2160 s-dpi: 157 s-size: 932x341mm (36.7x13.4") 
  s-diag: 992mm (39.1") 
  Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 92 
  size: 531x298mm (20.9x11.7") diag: 609mm (24") 
  Monitor-2: DP-0 res: 3840x2160 hz: 60 dpi: 157 
  size: 621x341mm (24.4x13.4") diag: 708mm (27.9") 
  OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
  direct render: Yes 
  Device-1: NVIDIA GP102 HDMI Audio vendor: ZOTAC driver: snd_hda_intel 
  v: kernel bus ID: 09:00.1 chip ID: 10de:10ef 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0b:00.4 chip ID: 1022:1487 
  Device-3: C-Media Multimedia Headset [Gigaware by Ignition L.P.] type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 chip ID: 0d8c:0139 
  Sound Server: ALSA v: k5.12.12-xanmod1 
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 04:00.0 
  chip ID: 8086:2723 
  IF: wlp4s0 state: down mac: <filter> 
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel 
  port: N/A bus ID: 05:00.0 chip ID: 8086:15f3 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 16.06 TiB used: 6.81 TiB (42.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 42B2S7JA scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WDS500G2B0A-00SM50 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: 20WD scheme: MBR 
  ID-3: /dev/sdb vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC26 scheme: GPT 
  ID-4: /dev/sdc vendor: Seagate model: ST6000DM003-2CY186 size: 5.46 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5425 rpm serial: <filter> rev: 0001 scheme: MBR 
  ID-5: /dev/sdd vendor: Western Digital model: WDS120G2G0B-00EPW0 
  size: 111.80 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: 0000 scheme: GPT 
  ID-6: /dev/sde type: USB vendor: Seagate model: Backup+ Hub BK 
  size: 7.28 TiB block size: physical: 4096 B logical: 512 B 
  serial: <filter> rev: D781 scheme: GPT 
  ID-7: /dev/sdf type: USB vendor: SanDisk model: Cruzer Switch 
  size: 14.56 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.27 scheme: MBR 
  ID-1: / raw size: 945.36 GiB size: 929.52 GiB (98.32%) 
  used: 298.04 GiB (32.1%) fs: ext4 dev: /dev/dm-1 
  Kernel: swappiness: 1 (default 60) cache pressure: 50 (default 100) 
  ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/dm-2 
  ID-2: swap-2 type: partition size: 111.79 GiB used: 0 KiB (0.0%) 
  priority: -3 dev: /dev/sdd1 
  System Temperatures: cpu: 42.8 C mobo: N/A gpu: nvidia temp: 45 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 62% 
  Processes: 555 Uptime: 1h 29m Memory: 62.78 GiB used: 4.11 GiB (6.6%) 
  Init: systemd v: 246 runlevel: 5 Compilers: gcc: 10.2.0 alt: 10 
  Packages: 2768 apt: 2741 lib: 1669 flatpak: 27 Shell: Bash v: 5.0.17 
  running in: gnome-terminal inxi: 3.1.07

Could be you must wait, seems your hardware is really fresh and not in the kernels, but IDK for sure.

1 Like

try updating your graphics drivers the latest nvidia drivers 465.31


This is from my new build, which only shares the same GPU as my old build. My old build had pretty outdated components, namely still a DDR3 motherboard. I had the exact same issue there.

Doesn't it give me the latest by default?

I dont no you are on pop os


Could this be useful?


I use popOS now since it is the only non-arch distro i would use. This issue is not on popOS. Garuda used pacman, so it should still give me the latest GPU drivers, and my point is that this didn't help.

Worth a try.

Another thing you could try is unplug the DVI monitor and see how boot goes

1 Like

Did that. Made no difference.

Have you searched online for or tested any different grub kernel boot parameters. There are many different ones you could try that may help. I don't use nvidia, so I'm not the one to ask for ones that may be of worth testing.


Grub boot parameters is beyond me. Only a last resort.

Well if you've tested many different Arch based distros and they all have the same issues you're going to have to get your hands dirty if you want your issue resolved.

Most users won't have the exact same hardware as you, so you will need to experiment for yourself. No one that doesn't have the identical hardware as you can predict what will work. It is a matter of trial and error. Research and experimentation is the way to find a solution to any issue.

Good luck.


Have a look in your var/log/boot.log it might give you a clue where it is freezing


Didn't work. Messing more with grub boot isn't worth it for me, so i can wait until i get a new GPU for garuda. Unless someone comes with something else of course.