Error: symbol `grub_debug_malloc' not found after system update with new GRUB version

I ran live usb and performed boot repair from garuda assistant. But the problem still persists. I can't boot into my installation. I am thrown a grub rescue prompt. Please guide me.

1 Like

Welcome :slight_smile:

Please search also in forum about,
you must chroot from garuda-welcome and grub-install and then update-grub.

1 Like

I tried doing that. It didn't work.

Searching or chroot?

2 Likes

chrooting didn't work.

I got that error the other day and reported about it on the forums. Be sure to NOT be running from an old snapshot.

Here is what I did:
Reinstalling GRUB from a Garuda Live USB while making sure you are not on an old snapshot after doing so (restoring to a recent snapshot after the system update with the new GRUB if you are on an old one [while still in the Garuda Live USB]) and then rebooting worked for me.

1 Like

Do you mean the chroot (change root) command doesn't work at all when you enter it using a Live USB, or that you are unsure how to use it? Or that the procedure you followed failed? Specifics help. There is no reason that chrooting should not work, AFAIK.

1 Like

As an update to my prior post something odd happened. Even though the update after I did all that worked fine, a recent system update game me the "Error: symbol `grub_debug_malloc' not found" error again even though I am not using a older restored snapshot. Which.. that is very odd because looking on info about it before lead me to believe it was the only case where it could happen. I had to reinstall Grub again... which strangely didn't work alone, so I had to revert to an old snapshot to just after the recent Grub update and then it did work. I am very confused :laughing:
I think I am going to just hold off on updates until the new fix GRUB update comes out. (or take TNE's recent suggestion to rollback the GRUB version and install it via grub-install again ... and block updates to it if I have to for a bit.)

4 Likes

exactly this, Kayo. I tried everything suggested and the error is persistent

1 Like

the procedure failed to solve the error

I'm having the same issue. I tried burning latest .iso file of Garuda into my USB and then rebooting my malfunctioning Garuda computer with the USB, but then it refuses to boot. I click the BIOS button on my keyboard to get past the GRUB rescue. And then it just enters a blank screen basically, and gets stuck there. Pressing the same BIOS button on my keyboard, but without the Garuda-boot USB inserted, results in BIOS menu showing up.

I am having the same issue... this occurred once last week and managed to get it back with the exact steps that Kayo did, however after this morning's update I am unable to get out of grub rescue mode....

Please let me know if you've managed to resolve this.

try pressing ctrl+alt+delete to reboot. And while it's rebooting, hold F12 to enter boot menu. Then pick whichever option you think makes the most sense and it should get you into your computer. It's not a solution to the GRUB Issue, but at least it's a way to bypass the problem and continue accessing your computer while the owners of GRUB work on an update to fix the bug (or until you figured out a way to solve the root issue).

if you see no other way to deal with this, have a go at Loading BIOS (Grub1) endlessly after system update ussing Garuda Assistant - #21 by UltraBlack

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.