Doesn't connect to 5Ghz Wifi directly

I recently installed Garuda KDE Dragonized edition but am having trouble connecting to wifi.
Whenever I start Garuda it fails to connect to wifi 5Ghz but it connects to 2.5 Ghz and then after connecting to 2.5 GHz it does connects to 5 GHz. But it doesn't connect to 5 GHz directly.

Check if this could help:

Additionally, I think you could check tihs one:

If none help, post the output of your inxi -Fxxxza as text, someone will help better :slight_smile:


You also don't mention whether a single SSID provides both frequencies, or whether you have two different SSID each providing a different frequency, or whether your have told Network Manager to automatically connect to the AP, or...


A single ssid provides single frequency one 5 Ghz and other 2.5 Ghz.
I followed the Advanced Network Configuration step and also did Hardware configuration and ticked the installed box besides open source box but now after restarting it is not able to detect any wifi.
The output of inxi -Fxxxza is:

System:    Kernel: 5.12.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=adc92075-750a-4e33-8970-583a995e3c10  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=f2a2bc9b-25aa-43a1-8529-906c47879220 loglevel=3
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: LENOVO product: 81BF v: Lenovo ideapad 520-15IKB serial: <filter> Chassis:  
type: 10 v: Lenovo ideapad 520-15IKB serial: <filter>  
Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> UEFI: LENOVO v: 6JCN33WW  
date: 06/30/2020  
Battery:   ID-1: BAT0 charge: 28.0 Wh (100.0%) condition: 28.0/35.3 Wh (79.4%) volts: 8.4 min: 7.6  
model: CPT-COS L16C2PB1 type: Li-poly serial: <filter> status: Full  
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: A (10) microcode: E0 cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800  
Speed: 3401 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3401 2: 3401 3: 3400 4: 3401  
5: 3400 6: 3400 7: 3400 8: 3400  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:5917 class-ID: 0300  
Device-2: NVIDIA GP108M [GeForce MX150] vendor: Lenovo driver: nvidia v: 465.31  
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1d10 class-ID: 0302
Device-3: Realtek EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:4 chip-ID: 0bda:58ea
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.1 direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.12.6-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: no
Sound Server-4: PipeWire v: 0.3.28 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: N/A
modules: r8169 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lenovo
driver: ath10k_pci v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 168c:003e class-ID: 0280
IF-ID-1: enp0s20f0u1 state: unknown speed: N/A duplex: N/A mac: <filter>
Bluetooth: Device-1: OPPO SDM710-MTP _SN:F7EE4CA5 type: USB driver: rndis_host v: kernel bus-ID: 1-1:9
chip-ID: 22d9:276a class-ID: 0a00 serial: <filter>
Device-2: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8 bus-ID: 1-7:3
chip-ID: 0cf3:e300 class-ID: e001
Report: ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block: hardware: no
software: yes address: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5060
bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 class-ID: 0104
Drives:    Local Storage: total: 1.82 TiB used: 40.25 GiB (2.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>
rev: LDM2 scheme: GPT
Partition: ID-1: / raw-size: 301.79 GiB size: 301.79 GiB (100.00%) used: 40.25 GiB (13.3%) fs: btrfs
dev: /dev/sda9 maj-min: 8:9
ID-2: /boot/efi raw-size: 4 GiB size: 3.99 GiB (99.80%) used: 560 KiB (0.0%) fs: vfat
dev: /dev/sda8 maj-min: 8:8
ID-3: /home raw-size: 301.79 GiB size: 301.79 GiB (100.00%) used: 40.25 GiB (13.3%) fs: btrfs
dev: /dev/sda9 maj-min: 8:9
ID-4: /var/log raw-size: 301.79 GiB size: 301.79 GiB (100.00%) used: 40.25 GiB (13.3%)
fs: btrfs dev: /dev/sda9 maj-min: 8:9
ID-5: /var/tmp raw-size: 301.79 GiB size: 301.79 GiB (100.00%) used: 40.25 GiB (13.3%)
fs: btrfs dev: /dev/sda9 maj-min: 8:9
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda7
maj-min: 8:7
ID-2: swap-2 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-6: swap-6 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-7: swap-7 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-8: swap-8 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-9: swap-9 type: zram size: 966.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors:   System Temperatures: cpu: 57.5 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 250 Uptime: 17m wakeups: 14778 Memory: 7.55 GiB used: 2.84 GiB (37.6%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1444 lib: 418
Shell: fish v: 3.2.2 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.04~~~

It is now detecting all the wifi's after I restarted again.
But the problem of not connecting to 5 Ghz directly continues.

Does it happen also if you stay closer to the AP?
Please edit the inxi part of your post with ~~~ before and after, for readability

1 Like

Have you searched for your QCA6174 Wifi adapter on the Garuda forum or elsewhere. This is a well known problematic adapter with a long list of mitigations that sometimes need to be performed. I would start by adding the grub kernel boot parameters as the first step.

Can you lower your channel assignment to 40 or below on the 5 GHz band on your router.?

Welcome to the forum.


You may want to search also by driver ath10k_pci, similar models might have common issues :wink:

I don't think I can change anything other than wifi name and password.

Have you searched this adapter's issues yet.

There is a list of fixs a mile long for this problematic adapter. Often the kernel and firmware versions enter into the mix. You can also test different driver options for the ath10k driver.

There's no shortage of info on this adapters many problems.

I would test the LTS kernel out to start.

1 Like

ok I will search issues specific to the adapter.

You have not stated if this issue only occurs on your home network or if it happens with other AP's as well?

I would test the LXQT-Kwin live edition to see if you have issues with the 5 GHz band there. It uses Connman, so this will tell us if Network Manager is a component to this problem or if possibly changes you've made are somehow involved here.


When I first booted into live for installation it was not able to detect any wifi. Had to connect to ethernet.

Please try with the LXQt live environment.

Please provide full feedback if you wish assistance. You provide unrelated unrequested info, yet ignore pertinent questions that are far more important to your issue.


I tried connecting with mobile hotspot (data and wifi tethering) it doesn't have an issue. I don't have any other network. It gives error only connecting to the wifi 5G.

Did you try

1 Like

Is there no library, internet cafe, friends home you can test your wifi out at. No one is going to spend a bunch of time troubleshooting an issue that is simply a problem connecting with your home access point (if it works properly everywhere else).

You have also not said how far this access point is from where you are attempting to use it. 2.4 GHz has better range than 5 GHz. Are you simply trying to use 5 GHz band too far away from the AP.

There are many fixes for this adapter what have you tested?


I could have access to my college library but due to lockdown I am not in college.
I use 5Ghz band on other devices and it works fine so it is in range and in fact sometimes it does connect to 5Ghz.


What fixes have you researched and tested?

Details are required my friend.

1 Like

I tried Advanced Network configuration steps and it didn't work also previously it was connecting to 5Ghz after connecting to 2.5Ghz but now it is not connecting to 5Ghz at all.
What details can I provide?