'clinfo' terminated by signal SIGABRT

This is related to this issue of SVP not launching that is still unresolved.

clinfo command gives this

Abort was called at 36 line in file:
fish: Job 1, 'clinfo' terminated by signal SIGABRT (Abort)

I ran garuda-update and re-installed NVidia drivers with nvidia-all.

My inxi

Kernel: 6.3.8-x64v1-xanmod1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod
root=UUID=58203bda-e2e2-4c32-a006-c91d933cad4e rw rootflags=subvol=@
loglevel=3 quiet intel_iommu=on iommu=pt ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Predator PH315-53 v: V1.01
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V1.01 serial: <superuser required>
UEFI: Insyde v: 1.01 date: 04/27/2020
ID-1: BAT1 charge: 42.4 Wh (100.0%) condition: 42.4/58.8 Wh (72.2%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF6
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1891 high: 2600 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 2600 2: 2600 3: 900
4: 2600 5: 900 6: 2600 7: 2600 8: 900 9: 900 10: 900 11: 2600 12: 2600
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none off: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 535.54.03
alternate: nvidiafb,nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: none off: HDMI-A-2 empty: DP-1 bus-ID: 01:00.0
chip-ID: 10de:1f15 class-ID: 0300
Device-3: Quanta HD User Facing driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0408:a061
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-0 note: disabled pos: primary
model: Samsung serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 40
gamma: 1.2 size: 1210x680mm (47.64x26.77") diag: 1168mm (46") ratio: 16:9
modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 mapped: eDP-1-1 note: disabled model: AU Optronics 0x82ed
built: 2018 res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce RTX
2060/PCIe/SSE2 direct-render: Yes
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-1.3:6 chip-ID: 08bb:29b0 class-ID: 0300
API: ALSA v: k6.3.8-x64v1-xanmod1-1 status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 08:00.0
chip-ID: 10ec:2600 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
IF-ID-2: virbr1 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5 chip-ID: 8087:0026
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 6.83 TiB used: 1.28 TiB (18.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBQNTY-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 11101100 temp: 24.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Western Digital
model: WD Blue SN570 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234200WD temp: 54.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD40NDZW-11A8JS1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1023 scheme: GPT
ID-1: / raw-size: 1.81 TiB size: 1.81 TiB (100.00%) used: 472.96 GiB (25.5%)
fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 51.2 MiB (53.4%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:3
ID-3: /home raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 472.96 GiB (25.5%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 472.96 GiB (25.5%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 472.96 GiB (25.5%) fs: btrfs dev: /dev/nvme1n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: zram size: 15.45 GiB used: 14.5 MiB (0.1%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 11.72 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p2 maj-min: 259:4
System Temperatures: cpu: 52.0 C pch: 72.0 C mobo: N/A gpu: nvidia
temp: 53 C
Fan Speeds (RPM): N/A
Processes: 380 Uptime: 3m wakeups: 1 Memory: available: 15.45 GiB
used: 3.76 GiB (24.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 alt: 11/12 clang: 15.0.7 Packages:
pm: pacman pkgs: 2130 libs: 559 tools: octopi,pamac,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2021-11-24
Last full system update: 2023-06-17
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:

I'd blame NVIDIA drivers, could try reinstalling them and all but...

It crashes in intel-compute-runtime?

Another attempt. Intel is integrated drivers, so let's try linux-zen kernel. Same problem.

I see intel-compute-runtime is on GitHub so let's open a ticket there

Can go one step further. Line 36 is here

auto compilerInterface = device.getCompilerInterface();

Nobody has any idea on this one?

from what i can tell the program is aborting itself because it's missing library files that it needs and doesn't have.
other than that i have no idea.

Not finding anything on this issue but a "similar" OpenCL problem here.

In his case, it turned out to be a kernel problem. So I tried switching kernel to linux-xanmod-lts. Problem persists. It had not loaded NVidia drivers at all and clinfo crashes, which makes me think NVIDIA drivers definitely have nothing to do and it's a kernel or system issue probably.

The curious part is... why is nobody else having this issue?

This is annoying because I cannot use SVP to watch videos anymore.

One person on the SVP forum said

I've seen this before.

You need the latest nvidia-opencl-icd and mesa-opencl-icd package.

If you're on a distro that does not offer them in the official repos you can just clone the git and build yourself.

If nvidia-opencl-icd and mesa-opencl-icd are neither in the official repos nor in the AUR, I don't think that's the right solution; but perhaps a hint in the right direction?

opencl-mesa and opencl-nvidia are installed.

That's strange I tried clinfo and it works no problem for me. Can you check if it's dependencies are fulfilled.
Here is clinfo's dependency tree in my system:

╰─λ pactree clinfo
└─ocl-icd provides opencl-icd-loader
╭─siddharth@siddharth in ~ took 51ms
╰─λ pacman -Qs ocl-icd
local/lib32-ocl-icd 2.3.2-1
OpenCL ICD Bindings (32-bit)
local/ocl-icd 2.3.2-1
OpenCL ICD Bindings

They're installed; except opencl-icd-loader is not a package.

Well yes as you can read:

it's ocl-icd that provides it. That's why I attached the output of

pacman -Qs ocl-icd

So that you can check if these two packages are in your system.

local/lib32-ocl-icd 2.3.2-1
OpenCL ICD Bindings (32-bit)
local/ocl-icd 2.3.2-1
OpenCL ICD Bindings

If you have these packages then how about reinstalling it

garuda-update -- clinfo

Maybe that helps


btw on the intel-compile-runtime git he asked me for strace which I published here

OK got feedback from intel-compute-runtime programmer

please adjust intel-graphics-compiler packages to neo packages. You have IGC packages from reference of release WW17, while neo packages from release WW09.
Please update neo to WW17 release or downgrade IGC to reference of WW09 release (1.0.13463.18)

Can someone translate that into Garuda language; or what happened here?

Looks like a problem with the repos; but then why am I the only one having the issue?

It seems like they are asking you to try either of the two

  1. update your neo packages. No idea what those are, please ask them for clarification.
  2. downgrade intel-graphics-compiler to v 1.0.13463.18.

According to them there is a version mismatch between these two. NGL, I don't even have this package in my system and yet clinfo works...? Well anyway to downgrade garuda has a preinstalled AUR utility called downgrade. So perform a simple

downgrade intel-graphics-compiler

and choose the version 1.0.13463.18 and check if it works. If it does then add this package to IgnorePkg in /etc/pacman.conf for the time being. If it doesn't contact them again and ask them what neo packages are and what WW17 versioning convention means with reference to this package.

from a quick online search it seems neo packages refer to some python package. So ask them if its one of these.

aur/python-neo4j-driver 4.0.1-1 [+0 ~0.00] [Out-of-date: 2022-06-14]
    Neo4j Bolt driver for Python
aur/python-neo4j 5.3.0-2 [+0 ~0.00]
    Neo4j Bolt driver for Python
aur/python-neo-git 0.5.2.r205.gc66dbfe-1 [+0 ~0.00]
    Neo is a Python package for working with electrophysiology data in Python
aur/python-neo 0.12.0-1 [+0 ~0.00]
    Neo is a package for representing electrophysiology data in Python, together with support for reading a wide range of neurophysiology file formats
aur/python-neotime 1.7.4-2 [+1 ~0.00]
    Python classes for working with temporal data to nanosecond precision
aur/python-neotermcolor 2.0.10-2 [+1 ~0.00]
    Modern ANSII Color formatting for output in terminal
aur/python-neobolt 1.7.17-2 [+1 ~0.00]
    Neo4j Bolt connector for Python

Downgrade did not work.

so still the same error? Then approach them on github again. Tell them you downgraded IGC to v: 1.0.13463.18 and still no dice.

1 Like

Why has this been marked as resolved??

And marked clinfo and core intel components as unsupported software? These are core components.

It's either a bug on the Intel side, or a packaging bug on the Garuda side... hopefully we'll know soon

Still not exactly sure what NEO stands for, but this is his reply. NEO v26241.22, that seems to be the intel-compute-runtime. Not sure why they'd call it NEO.

It's looking like a distribution packaging issue; but then the question is, why do I seem to be the only one having issues here?

I mean it looks like you are mixing packages from two different releases.

WW09 (work week 9 of 2023 year) release Release 23.09.25812.14 · intel/compute-runtime · GitHub contains NEO in version 23.09.25812.14 and IGC in version 1.0.13463.18

WW17 release Release 23.17.26241.22 · intel/compute-runtime · GitHub contains NEO in version 23.17.26241.22 and IGC in version 1.0.13822.6

We cannot guarantee that NEO in version 23.09.25812.14 works with IGC in version 1.0.13822.6 or NEO in version 23.17.26241.22 works with IGC in version 1.0.13463.18

Please ensure you are using corresponding version of NEO and IGC.
For other releases please find more details here: Releases · intel/compute-runtime · GitHub

I don't know about others but I have neither of those packages in my system and clinfo works... Still try to go with their suggestion and see if that helps and if it doesn't and the intel-graphics-compiler and intel-compute-runtime packages aren't some important dependency for something. (You can check this...

pactree --reverse [pkgName]

will print the packages that need [pkgName])

If they aren't required by something important or something must have try to remove them.

PS: just to make sure that you have actually downgraded to the version that they say try the

pacman -Qi [pkgName]

command to check the package's locally installed version. Just to make sure...

1 Like