Chaotic-AUR | Packages | Requests | Recompilation | Reports

Were you able to find a package that works for certain?

2 Likes

Yes
works perfect

thank you

1 Like

Unable to install libadwaita-without-adwaita-git
failed to resolve glib2-devel dependency

for a second I thought “Isn’t that one of Arnold Schönberg’s students?” Schönberg invented dodekaphony, which is why I got really confused lol.

His student’s name wasn’t “Alan Berg”. It was “Alban Berg”…

1 Like

I’m not sure what would cause this. Do you by chance have unmerged .pacnew files? glib2-devel is in core so not something I can simply rebuild to fix Arch Linux - glib2-devel 2.80.3-2 (x86_64)

A post was split to a new topic: Mint-Y-Purple theme makes the buttons and highlights green

The dependencies for hyprland-git in chaotic-aur don’t match the AUR repo causing updates to be blocked. The chaotic-aur has hard dep on libdisplay-info v1-64 when it’s been updated to v2-64 in the upstream arch repos.

chaotic-aur/hyprland-git

Depends On      : cairo  gcc-libs  glib2  glibc  glslang  hyprutils  hyprcursor  hyprwayland-scanner  libdisplay-info  libdrm  libglvnd  libinput  libliftoff  libx11  libxcb  libxcomposite  libxfixes  libxkbcommon  libxrender  mesa  opengl-driver  pango  pixman  polkit  seatd  systemd-libs  tomlplusplus  wayland  wayland-protocols  xcb-proto  xcb-util  xcb-util-errors  xcb-util-image  xcb-util-keysyms  xcb-util-renderutil  xcb-util-wm  xorg-xinput  xorg-xwayland  libdisplay-info.so=1-64  libhyprlang.so=2-64

AUR/hyprland-git

Depends On      : cairo  gcc-libs  glib2  glibc  glslang  hyprutils  hyprcursor  hyprlang  hyprwayland-scanner  libdisplay-info  libdrm  libglvnd  libinput  libliftoff  libx11  libxcb  libxcomposite  libxfixes  libxkbcommon  libxrender  mesa  opengl-driver  pango  pixman  polkit  seatd  systemd-libs  tomlplusplus  wayland  wayland-protocols  xcb-proto  xcb-util  xcb-util-errors  xcb-util-image  xcb-util-keysyms  xcb-util-renderutil  xcb-util-wm  xorg-xinput  xorg-xwayland  libdisplay-info.so
1 Like

Should be able to just rebuild against new libs. If that doesn’t help, then we have bigger problems caused by the interfere we use for deps.

@NaN Can you confirm fix? Finished making: hyprland-git 0.41.1.r57.0b924f54-1.1 (Sat 22 Jun 2024 07:29:28 PM CEST)

3 Likes

Yup, can install updated version of hyprland-git now.

4 Likes

Any chance on adding Superfile the chaotic?

1 Like
2 Likes

Hi all!
I would like to request Surfshark’s client to be added to the chaotic-aur:
https://aur.archlinux.org/packages/surfshark-client

Thank you!

1 Like

Unfortunately that would not be a great thing for us to add. It’s currently a Debian deb file for source (we try to avoid those as much as possible), and doesn’t actually take much (if any) power to compile, so it would effectively be “wasted” mirror space. Thanks for politely requesting :slight_smile:
See also my reply about surfshark here:

1 Like

That’s good to know, I’ll keep in mind for the future!

Thankfully as you say, building it from the AUR doesn’t take long.

Cheers!

1 Like

A post was split to a new topic: Request for the gutenprint package to be apart of the ISO

Cava fails after install. Building the cava-git from the aur. The pkg works as expected.

cava
cava: error while loading shared libraries: libiniparser.so.1: cannot open shared object file: No such file or directory

I bumped to rebuild, give it a try?
Finished making: cava 0.10.2-2.1 (Thu 11 Jul 2024 04:00:15 PM CEST)

No luck sadly looks like a upstream issue or at least that lib.

❯ cava
cava: error while loading shared libraries: libiniparser.so.1: cannot open shared object file: No such file or directory
1 Like

Here is the only “fix” I can give then:
Finished making: cava-git r955.3f6e931-1 (Thu 11 Jul 2024 06:11:17 PM CEST)

I can drop this when cava isn’t broken

1 Like

I used to use whisper-ctranslate2 as a makeshift, “proof of concept” way of doing subtitles on my streams (without routing my words through someone’s servers), and otherwise use faster-whisper for transcription. This was back on an Ubuntu variant. Been trying to use them under Garuda, but they either throw an error (e.g. ‘faster-whisper not found,’ ‘wrong bitrate,’ etc.), or CTranslate doesn’t seem to respond to my microphone at all for some reason.

Ironically, I got insanely-fast-whisper working (it didn’t on my old distro), but I can’t use it for real-time, live subtitles. (I also tried nerd-dictation and actually got it working, but I need something that stays in the same window, even when I tab out. :sweat_smile: )

Also, I’m not sure if this is on the side of the source code or Garuda or what, but OBS doesn’t have its menu bar, no matter what version I use (even tried the flatpak, just in case). This makes it hard to import my profile and stuff. I tried changing themes (just in case) - no dice. If it makes any difference, I’m on the Dragonized version.

If anyone more familiar with this stuff could help, I’d really appreciate it. :slightly_smiling_face: