Changing Default Kernel

So, after the latest kernel (linux-zen) update my laptop won't shutdown or reboot. So, I tried booting with another kernel (linux-lts) and the problem is gone. I don't want to downgrade the kernel everytime it brake the system. So, because linux-lts kernel is more stable, I was wondering how to change the default kernel (I don't wanna select Advance Options and linux-lts everytime I boot. And I tried changing GRUB_DEFAULT=0 to GRUB_DEFAULT=1 & GRUB_DEFAULT="1>3", but nothing changed. And changing the "Boot to" in Garuda Boot Options doesn't work as well.)?

Did you regenerate the GRUB configuration after making a change to its configuration file?

sudo grub-mkconfig -o /boot/grub/grub.cfg

To save any further questions if that was the problem :wink:.

(That may be wrong - actually managed to make brain remember something but there is a reason it doesn't do it more often + anyway I'm sure jonathon shall check it once :grin:)


I did. Apparently there's another uncommented line saying "GRUB_DEFAULT=0" under the commented line "#Uncomment to make GRUB remember the last selection". So, commenting out that fixed the issue. So sorry for inconvinience. :slightly_smiling_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.