Cant switch keyboard layout

Hello.
I'm trying to switch the keyboard layout using the default keyboard shortcut (Ctrl + Alt + K) and the the widget at the top dock but none of them is working.

Just updated and started having the problem.

Thanks!

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:es",
LC_ALL = (unset),
LC_ADDRESS = "en_US.UTF-8",
LC_NAME = "en_US.UTF-8",
LC_MONETARY = "es_MX.UTF-8",
LC_PAPER = "en_US.UTF-8",
LC_IDENTIFICATION = "en_US.UTF-8",
LC_TELEPHONE = "en_US.UTF-8",
LC_MEASUREMENT = "es_MX.UTF-8",
LC_TIME = "en_US.UTF-8",
LC_NUMERIC = "es_MX.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
System:
Kernel: 5.17.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e774603c-6d63-476a-950a-d3b0092c0f39 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Mini-pc System: LENOVO product: 10T8SSLP00 v: ThinkCentre M720q
serial: <superuser required> Chassis: type: 35 serial: <superuser required>
Mobo: LENOVO model: 312D v: SDK0J40697 WIN 3305369183414
serial: <superuser required> UEFI: LENOVO v: M1UKT62A date: 01/04/2021
CPU:
Info: model: Intel Core i5-9500T bits: 64 type: MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 840 high: 900 min/max: 800/3700 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 887
5: 855 6: 900 bogomips: 26399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Lenovo
driver: i915 v: kernel ports: active: HDMI-A-3
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:3e92
class-ID: 0300
Device-2: Xiongmai web camera type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-5:2 chip-ID: 23c5:1478 class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-3 mapped: HDMI3 model: Lenovo LEN S24e-10
serial: <filter> built: 2021 res: 1920x1080 dpi: 92 gamma: 1.2
size: 530x300mm (20.87x11.81") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
v: 4.6 Mesa 22.0.1 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: Xiongmai web camera type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-5:2 chip-ID: 23c5:1478 class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.17.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 78.23 GiB (16.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: A-Data model: SU800 size: 476.94 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 1A scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 78.23 GiB (16.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 78.23 GiB (16.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 78.23 GiB (16.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 78.23 GiB (16.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.63 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 238 Uptime: 18m wakeups: 0 Memory: 7.63 GiB
used: 2.78 GiB (36.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1623 lib: 484 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.1-1):
System install date:     2022-03-09
Last full system update: 2022-04-14
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Have you properly set a second keyboard layout in Plasma System Settings => Keyboard => Layouts ?
Locale settings are not relevant for this issue. Only keyboard layout.
In Plasma it can be set via GUI, while it can be generally set with setxkbmap command.

4 Likes

Thanks for your reply!
Sorry If im wrong, but do you mean this?
Here are the two layouts I have...

Thanks!

3 Likes

I mean, I have it that way but I still have the issue...

What is happening when you execute Ctrl+Alt+K? Nothing?

Was it working previously, and stopped working? Or are trying to get it working and haven't succeeded yet?

What window or program has focus when you try to use the shortcut and it doesn't work?

Have you tested out any other shortcuts in the menu you screenshotted? Are other shortcuts working normally, or also not working?

I have same problem described here
https://forum.garudalinux.org/t/switching-keyboard-layouts/18866

1 Like

It doesn't switch just shows single layout active by default

Like if I have us layout active by default when I press Ctrl+Alt+K it shows us
Even if repeat it twice, it shows us layout only

If activated manually then works
I added kannada KaGaPa Varient, Sanskrit KaGaPa Varient layout and after applying in settings the shortcut works

I was able to switch between sanskrit and kannada layout

Even in lock screen it shows up I just tested Meta+L

However it's better to select keyboard layout to default layout as password should be typed in default layout

1 Like

@isdr you just switch to tty press Ctrl+Alt+F2
You see a black login screen don't worry just press Ctrl+Alt+F1 to switch gui

After that u see a popup in system tray in gui if keyboard layouts configured correctly

Even if u can't switch back to gui then login after type reboot and hit Enter

I think tty5 is last switch to any of them note that they consume ram if logged in tty prompts u exit from them by typing exit

Here I have made a Youtube video [Watch at 2x speed 720p for clear view]

1 Like

When I press Ctrl + Alt + K it only shows my current keyboard but wont switch to the other like this.

image

I updated my system and started having this problem.

My other shortcuts are working perfectly fine.

Also, I have English kb as my default, but when I add another one it replaces it as my default.

Sheesh this has taken too long, I might go back to manjaro :frowning:

There is an open KDE bug on this.
Try to set English layout first and it should work.

2 Likes

@isdr did u try this on your system mine system is not upgraded

Try this one for updated system

Does it work when done manually through settings ?
If does then try switching tty and gui once then the layout icon may appear in system tray

No need to run scripts !
Simply type Ctrl+Alt+F2 then type Ctrl+Alt+F1

OR keep holding Ctrl+Alt then type F2 and F1

After few seconds the new icon pop into system tray as shown in the YouTube video there u can change layouts also the keyboard shortcuts work after this

You are not supposed to set layout again and again just activate using tty :slightly_smiling_face:

There are some Garuda specific packages, but generally we track very closely with upstream. If an update breaks something this is logically most likely an issue from an upstream project.

Most users prefer to stomp their feet and threaten to go back to $whatever_distro, when in fact filing a bug report with the upstream project is the best way to get the issue corrected.

2 Likes

Replace Netto with Manjaro.

1 Like

A post was split to a new topic: Why linux not in the market share

Thanks for the replies.

1 Like

This topic was automatically closed after 35 hours. New replies are no longer allowed.