Cannot enter Korean text

Text input in Korean is not possible in Kate or Libreoffice or in all other programs with test input.

By default, I use the German language and this works fine, but unfortunately the text input in Korean does not work at all. Unfortunately, all my attempts to solve this problem have been so far unsuccessful.

I installed all necessary language packs and updated them immediately and also installed in the system settings the keyboard layouts for the required languages. Also ibus and e.g. ibus-hangul had been installed but no success at all. Than I did try out fcitx with its packages but no change here too. Also Youtube videos and forum searches and other web searches did not lead to the desired result either.

I use Garuda KDE Lite but and to be sure I also tried Garuda XFCE + Cinnamon and Garuda dr460nized. I'm actually super happy with Garuda but unfortunately this language problem is currently burdening me. Before I used Manjaro (XFCE and later KDE) for many years with the same hardware and here I was able to get the Korean language input working.

My hardware and System:
Dell Precision M6700 32G
Garuda KDE Lite, 5.9.12.zen1-1
Language packages: global, de-DE, en-US, ko-KR
System language installed: German de_DE.UTF-8 (in use); English en_US.UTF-8; Korean ko_KR.UTF-8
Keyboard layouts: de; es; kr
Also tried the advanced keyboard settings: Korean hangul / hanja with all its options but no success. Even here, when advanced setting with hangu/hanja are activated than the German keyboard doesn’t work anymore.

Try this

sudo pacman -S fcitx-input-support fcitx-hangul asian-fonts noto-fonts-cjk

Reboot

1 Like

the result is:
Fehler: Ziel nicht gefunden: fcitx-input-support
Fehler: Ziel nicht gefunden: asian-fonts
Warnung: noto-fonts-cjk-20201206-1 ist aktuell -- Reinstalliere

error messages that the location was not found

the result is:
Fehler: Ziel nicht gefunden: fcitx-input-support
Fehler: Ziel nicht gefunden: asian-fonts
Warnung: noto-fonts-cjk-20201206-1 ist aktuell -- Reinstalliere

error messages that the location was not found

Warnung: noto-fonts-cjk-20201206-1 ist aktuell -- Reinstalliere (reinstall)

did uninstall and reinstall the above fonts, no sucess here too

Refresh mirrors and update your system fully

reboot, refreshed mirrors, system update all done - no success :cry:

did check with the Garuda Assistant the system settings and there was fcitx ibus and Asian fonts not activated. When trying to activate them and put in my root password nothing afterwards happend, means no activation is shown and set there. Also after posting theerror messages above I did install fcitx-support fcitx-hangul asian-fonts and noto-fonts-cjk manually but also no success with that too.

I did also install different Garuda systems in virtualboxes, to see and to check if I maybe did mess up something in the settings with my Garuda host system. But also with the original Garuda system installed in virtualbox I can not type in Korean too.

I remember that @librewish fixed one of my font problems with

fc-cache -fv

give it a try :slight_smile:

2 Likes

Btw,

2 Likes

I did but same result here too, no Korean input possible.

What I also noticed is that by selecting the Korean keyboard in the system settings the keyboard preview do not show me a Korean keyboard. I mean with the Korean letters, only the English letter version of a Korean keyboard is shown in the preview. Normally you can see in with preview the keyboard layout with the typical language letters.

Hmm,

locale
localectl list-x11-keymap-variants
localectl list-x11-keymap-variants de (korean? short?)
1 Like

short for Korean is kr. the Korean language name is hangul.

when I ran the commands above like localectl list-x11-keymap-variants I've got very long lists and de is inside but no kr or hangul only a kr104 is listed there but I'm not sure what it is.

also maybe the short for Korean could be ko so three posibilities are given: ko, kr and hangul

Here is what I have found:

English short name Alpha-2 code Alpha-3 code Numeric
Korea (the democratic People's Republic) KP PRK 408
Korea (the Republic of) KR KOR 410
5 Likes

so far no success here.

I just tried out a last check with garuda barebones in a virtualbox and there I noticed something strange maybe a bug. In the live session I could change or better said activate in the garuda assistant fctix and the asian fonts. but when i did install garuda in the virtualbox and restartet the installed system and than later do start the garuda aissistant again to activate both options (fcitx and asian fonts) nothing happened and the check boxes stay unchecked so far.

Not that it has anything to do with it.
We do not provide support for barbones and do not recommend their use in a VM.

On my system, for example, Cinnamon won't even start after I set up land/keyboard and so on in Grub.

post output please.

❯ localectl list-x11-keymap-variants kp or kr
Too many arguments.

❯ localectl list-x11-keymap-variants kr
kr104

'We do not provide support for barbones and do not recommend their use in a VM'

I know that and it was just a last try. As I wrote before I have garuda lite with fresh up mirrors and all updates running on my hardware directly but to figure out if I maybe missed something in the settings or did something wrong in the settings I installed garuda (xfce, cinnamon, kde, barbones ...) in a VB just to check if I can get Korean language input there running.

but this 'bug' that I can not change or better said activate in the garuda assistant fcitx and asian fonts is maybe something you should look into it.

2 Likes

Ok, Ok, we have a look.

localectl list-x11-keymap-variants kp

or

localectl list-x11-keymap-variants kr

I am more precise next time.

1 Like

no worries :wink:
I realized that by myself so I did enter only the command with kr only. the result there was kr104

and since this can potentially create some strange problems, i just want to make it clear that i am not in North Korea (kp) or have anything to do with that country. But i live in South Korea (kr)

1 Like

I think the other part can not post here :wink:
without problems of course .

But that is OT.

you do not post your

locale

and

locale -a