Buzzing noise from my speakers

Hi I have a problem with my speakers.
my speaker have buzzing noise problem.
it is like this : when I using an app that make sound I dont have noise problem but when I don't use any app that make sounds then it start to making buzzing noise sound.
and when I have noise I go to sound settings and change the colume and noise gone for some seconds but after that again it is buzzing.( I say this one because maybe it will help you to know the problem better)
I should notice that I dont have this problem on windows 10 and 11 but at ubuntu and arcolinux I see this problem too like garuda linux.

garuda-inxi
System:
`Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0`
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2adb3662-5c5c-40c0-8707-e5e5b172df3c rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.24.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: TUF X470-PLUS GAMING v: Rev X.0x
serial: UEFI: American Megatrends v: 5861
date: 08/10/2021
CPU:
Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2355 high: 4212 min/max: 2200/3700 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2466 2: 2891
3: 1780 4: 1776 5: 2029 6: 1995 7: 4212 8: 2092 9: 2043 10: 2844 11: 1719
12: 1719 13: 1872 14: 1960 15: 4191 16: 2102 bogomips: 118181
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Micro-Star MSI
driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 09:00.0
chip-ID: 10de:1b82 class-ID: 0300
Display: x11 server: [X.Org](http://X.Org) 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 90 s-size: 452x251mm (17.8x9.9")
s-diag: 517mm (20.4")
Monitor-1: HDMI-0 res: 1600x900 hz: 60 dpi: 92
size: 443x249mm (17.4x9.8") diag: 508mm (20")
OpenGL: renderer: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 510.47.03 direct render: Yes
Audio:
Device-1: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 10de:10f0
class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 0b:00.3 chip-ID: 1022:1457 class-ID: 0403
Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac:
Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus-ID: 1-13:3 chip-ID: 148f:7601 class-ID: 0000 serial:
IF: wlp1s0f0u13 state: up mac:
Drives:
Local Storage: total: 2.05 TiB used: 918.4 GiB (43.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 4B6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EZRZ-00Z5HB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial:
rev: 0A80 scheme: GPT
Partition:
ID-1: / raw-size: 40.64 GiB size: 40.64 GiB (100.00%)
used: 7.21 GiB (17.7%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sda6 maj-min: 8:6
ID-3: /home raw-size: 49.33 GiB size: 49.33 GiB (100.00%)
used: 147 MiB (0.3%) fs: btrfs dev: /dev/sdb5 maj-min: 8:21
ID-4: /var/log raw-size: 40.64 GiB size: 40.64 GiB (100.00%)
used: 7.21 GiB (17.7%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 40.64 GiB size: 40.64 GiB (100.00%)
used: 7.21 GiB (17.7%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.32 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.5 C mobo: N/A gpu: nvidia temp: 55 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 383 Uptime: 1h 3m wakeups: 0 Memory: 31.32 GiB
used: 3.27 GiB (10.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 Packages: pacman: 1199 lib: 289 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date: 2022-02-10
Last full system update: 2022-02-11
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: Probably (Run as root to verify)
Snapshots: Snapper
Failed units: bluetooth-autoconnect.service

Do you really need all three servers running?

No , I don't need.
I install them to fix my sound noise problem.
is it better to delete 2 of them??

Pipewire is the en vogue server at present. And you'll need ALSA. I would eliminate as much Pulseaudio as I could. JamesDSP also has a Pulseaudio package (jamesdsp-pulse), but that is neither installed or enabled in Dr460nized. It is geared to Pipewire.

And that should (may) also fix this:

IDK nothing about Sound stuff but JamesDSP but it is in my KDE in autostart folder.
I had wondered what this was, but since I have no problems whatsoever did not investigate further. :smiley:

It's a great little sound effects processor. Lots of tweaks for your sound system. PipeWire - ArchWiki Since we rely on my desktop PC for entertainment, it is very handy, easy to use, and understandable by normal human beings. I believe dr460nf1r3 said he ran across it and liked it, so now we get to benefit from it. :slight_smile:

2 Likes

I dont have bluetooth device to worry about that.
then for my speaker problem what you suggest ?
do you know what is the problem.
becayse the problem isn't from installing that audio softwares.

Seems your hardware is build for M$ and got no drivers for Linux.

4 Likes

That's cool. At this point you should probably see if some of the forum audiophiles can come to your aid.

2 Likes

if you see this topic , you see one of the forum members have this problem and says with adding
options snd-hda-intel and power_save=0 power_save_controller=N he fix the problem.
but I have one problem and I don't know how can I change this file.
forexample they say the path is will be like this.
sudo micro /path/to/file/your.config
but I dont how is will be?
and is this solution can help me?
because mine is detected as snd-hda-intel in terminal if you see

for now I run this code at terminal :
sudo micro /etc/modprobe.d/local.conf
and write options snd-hda-intel and power_save=0 power_save_controller=N in it.
is it ok?
Am I do correct?

That is an excellent option. It should do the job. :slight_smile:
There are various ways to write/install this option, but it's nice to see someone using a terminal.
I keep that and similar options for modprobe.d backed-up to file, which makes it very handy to just plop them into /etc/modprobe.d in any Arch-based distribution.

1 Like

I should say that I do this job and it worked for me and no noise from my speaker.
but what is that solve noise problem?
I mean do you know why this code fix this problem ?
or what was the problem from?

Sound cards have power-saving features. Some of those features can interfere.

1 Like

as I understand , I think you mean you keep config file at a safe place and backup them to use them if you want in the future .
to not doing that config again and again?
or you meant other thing and I understand badly?

1 Like

You got it. :+1:

I've also got .conf's for iwlwifi and i915 (intel) and a few others. They tend to accumulate over time.
:wink:

2 Likes

@Secure832 The simple answer is with those settings your speakers don't lose the low voltage current on the cable.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.