/@/boot/vmlinuz-linuz-zen not found

System:
Kernel: 5.16.9-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/[email protected]_105424368/boot/vmlinuz-linux
root=UUID=307d340d-141b-4ab8-84f4-d9a41f921f6f quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=08186c96-ea26-402a-8bb2-a15a5e575416 loglevel=3
rootflags=defaults,noatime,noautodefrag,compress=zstd,[email protected]_105424368
Desktop: KDE Plasma 5.24.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: X556UQK v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: X556UQK v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: X556UQK.317 date: 04/16/2019
Battery:
ID-1: BAT0 charge: 23.7 Wh (100.0%) condition: 23.7/38.0 Wh (62.4%)
volts: 7.6 min: 7.6 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Not charging cycles: 201
CPU:
Info: model: Intel Core i7-7500U bits: 64 type: MT MCP
arch: Amber/Kaby Lake note: check family: 6 model-id: 0x8E (142)
stepping: 9 microcode: 0xEC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 900 min/max: 400/3500 scaling: driver: intel_pstate
governor: powersave cores: 1: 900 2: 900 3: 900 4: 900 bogomips: 23209
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
Device-2: NVIDIA GM108M [GeForce 940MX] vendor: ASUSTeK driver: nvidia
v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:134d
class-ID: 0302
Device-3: Chicony USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-6:7 chip-ID: 04f2:b52b class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia note: n/a (using device driver) display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142
size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.6
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.16.9-arch1-1 running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.46 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
vendor: Lite-On driver: ath9k v: kernel bus-ID: 03:00.0 chip-ID: 168c:0036
class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 1-8:13
chip-ID: 04ca:3018 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
Local Storage: total: 1.15 TiB used: 140.93 GiB (12.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 2J scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: MZ7PD256HCGM-000H7
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 6H6Q scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Imation model: Ridge
size: 7.47 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 140.9 GiB (73.6%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-2: /boot/efi raw-size: 451 MiB size: 450.1 MiB (99.80%)
used: 556 KiB (0.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 140.9 GiB (73.6%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-4: /var/log raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 140.9 GiB (73.6%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-5: /var/tmp raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 140.9 GiB (73.6%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.58 GiB used: 29.5 MiB (0.2%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 11.46 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda4 maj-min: 8:4
Sensors:
System Temperatures: cpu: 48.0 C pch: 42.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3100
Info:
Processes: 294 Uptime: 8h 36m wakeups: 2 Memory: 11.58 GiB
used: 7.45 GiB (64.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 1515 pacman: 1501 lib: 435 snap: 14
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.4-2):
head: impossible d'ouvrir '/var/log/pacman.log' en lecture: Aucun fichier ou dossier de ce type
System install date:
Last full system update: 2022-02-17
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            logrotate.service

Ca anyone help me , after updating my system i have this message on boot "/@/boot/vmlinuz-linuz-zen not found . You need to load the kernel first. Failed to boot default and fallback entries . "

Thanks for your help .

Before getting too deep in the weeds, a quick and easy thing to check would be the boot settings in your UEFI BIOS menu (make sure it is pointing to the correct boot option).

You boot in a snapshot, did you restore this one after posting the garuda-inxi?

Please format your terminal output with 3 ~ in first and last line.

2 Likes

Yes i boot on snapshot currenlty and i restor it to this snapshot but after rebooting system i have the same problem.

So this is the best format :

System:
Kernel: 5.16.9-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/[email protected]_105424368/boot/vmlinuz-linux
root=UUID=307d340d-141b-4ab8-84f4-d9a41f921f6f quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=08186c96-ea26-402a-8bb2-a15a5e575416 loglevel=3
rootflags=defaults,noatime,noautodefrag,compress=zstd,[email protected]_105424368
Desktop: KDE Plasma 5.24.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: X556UQK v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: X556UQK v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: X556UQK.317 date: 04/16/2019
Battery:
ID-1: BAT0 charge: 23.2 Wh (98.7%) condition: 23.5/38.0 Wh (61.8%)
volts: 7.6 min: 7.6 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Not charging cycles: 201
CPU:
Info: model: Intel Core i7-7500U bits: 64 type: MT MCP
arch: Amber/Kaby Lake note: check family: 6 model-id: 0x8E (142)
stepping: 9 microcode: 0xEC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 800 min/max: 400/3500 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 23209
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300
Device-2: NVIDIA GM108M [GeForce 940MX] vendor: ASUSTeK driver: nvidia
v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:134d
class-ID: 0302
Device-3: Chicony USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-6:7 chip-ID: 04f2:b52b class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142
size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.6
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.16.9-arch1-1 running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.46 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
vendor: Lite-On driver: ath9k v: kernel bus-ID: 03:00.0 chip-ID: 168c:0036
class-ID: 0280
IF: wlp3s0 state: down mac: <filter>
Bluetooth:
Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 1-8:11
chip-ID: 04ca:3018 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 141.15 GiB (12.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 2J scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: MZ7PD256HCGM-000H7
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 6H6Q scheme: GPT
Partition:
ID-1: / raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 141.15 GiB (73.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-2: /boot/efi raw-size: 451 MiB size: 450.1 MiB (99.80%)
used: 556 KiB (0.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 141.15 GiB (73.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-4: /var/log raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 141.15 GiB (73.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
ID-5: /var/tmp raw-size: 191.41 GiB size: 191.41 GiB (100.00%)
used: 141.15 GiB (73.7%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.58 GiB used: 310.8 MiB (2.6%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 11.46 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda4 maj-min: 8:4
Sensors:
System Temperatures: cpu: 49.0 C pch: 43.5 C mobo: N/A
Fan Speeds (RPM): cpu: 3100
Info:
Processes: 298 Uptime: 3h 28m wakeups: 103 Memory: 11.58 GiB
used: 7.93 GiB (68.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 1515 pacman: 1501 lib: 435 snap: 14
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.4-2):
head: impossible d'ouvrir '/var/log/pacman.log' en lecture: Aucun fichier ou dossier de ce type
System install date:
Last full system update: 2022-02-17
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

@SGS where can i edit BOOT_IMAGE = /restore_backup_ ?

Have you already tried a sudo update-grub and reboot?
If nothing changes you could to do it manually in /boot/grub/grub.cfg but the risk is that at the next update-grub this will occur again. In that case we'll have to check the grub config files.
You could even try changing it from the grub, pushing button E at the grub line you normally use.

2 Likes

@filo yes do it but after there's nothing change on boot .

You tried all the three hints and all failed? :frowning:

1 Like

@filo I've tried update-grub but it can't help . But the two others i don't understand it clearly . Can you help me and check for it ?

Unfortunately I'm travelling without my Garuda laptop and cannot be 100% precise.

  1. When you are in the grub, in the line that you normally use (probably the first one) instead of pressing enter press button E. You'll be presented with a long string which is what the grub is actually doing to boot. Try to locate that part which is unneeded: /[email protected]_105424368, so that you should leave only the part /boot/vmlinuz-linux-zen. Then press ctrl+X to continue booting.
    or
  2. When you're logged as above in the snapshot, do a
    sudo micro /boot/grub/grub.cfg and again locate that part to remove as above. Then exit with ctrl+Q and confirm to save changes. Then sudo update-grub

Please Note: I added the -zen because by your error message it looks like you should boot into the linux-zen kernel, while your snapshot seems to be from a linux kernel.
This suggests me also another possibility, that the linux-zen is missing at all for some reasons?
So, you could also use a live USB, login, use the chroot function in the Garuda Welcome and do a
pacman -S linux-zen linux-zen-headers

3 Likes

I test first suggestion so where i can edit to what you suggest . Sorry ot bother you . I Really need these helo .

It's correct.
Try directly the last suggestion (live USB -> chroot -> install kernel)

I'm on garuda live now . So i chroot with this button ?

Yes, of course, it's the only button with that name :slight_smile:
Please try to avoid pictures, especially when unneded...

2 Likes

Do you have skype or something like that ? Now garuda say to me after executing "pacman -S linux-zen linux-zen-headers" failed to retrieve somes files .

No skype of course, I'm travelling on a train :slight_smile: And I cannot be so much available, sorry.
Try to enter update. This should hopefully update your system and maybe freshing the mirrors might help also installing the kernel. It's difficult to understand what's going on there...
You can copy the error text from your chroot terminal and past it in your posts.

@filo I execute update on the live usb ?

When you are into the chroot, not in a "normal" USB terminal.
In that moment you're logged as root into your installed system.

2 Likes

@niavo - more about chroot and what it is/does.

https://wiki.archlinux.org/title/Chroot#Using_arch-chroot

Using chroot from garuda does most of that for you.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.