Bluetooth Keyboard Usage at Login

Hello:

I want to use my Bluetooth keyboard upon login to enter my password. However it does not automatically connect. I have tried to trouble shoot the issue myself through some forums but it has been unsuccessful thus far.

Perhaps I am doing a procedure incorrectly. I have tried to go into /etc/bluetooth/main.config to change the AutoEnable = true bur that hasnt worked. I also set to AlwaysDiscoverable

I looked the issue up on stackoverflow, and a few other links but I am not as technically proficient with these steps. It took me quite a bit to figure out how to get to the main.config file via terminal (I know I can use Thunar File Manager but I wanted to learn to do it via CLI.

Please advise on how I should proceed? Do I need to remove the "#" from the AutoEnable = true for it to work?

System: Gardua i3wm

I looked at this post: Bluetooth not Connecting and this one [SOLVED] How to use a Bluetooth Keyboard in the Boot manuel although I didnt quite understand the second forum discussion and how it got solved.

However I tried to follow both forums steps but it didnt pan out for me.
image
My Keyboard: Keychron K6 65%
Main.config File: Main.config - Google Docs

Note: I dont have crazy tech experience. Im mainly a business professional interested in Linux. So please be courtesy in your reply and my lack of know how in this situation.

From what I can read and not being expert, the hash mark # comments out lines, so should be removed.
Also, the link @tbg links, gives - Configuration


### Auto power-on after boot

By default, the Bluetooth adapter does not power on after a reboot, you need to add the line `AutoEnable=true` in the configuration file `/etc/bluetooth/main.conf` at the bottom in the `[Policy]` section:

/etc/bluetooth/main.conf

[Policy] AutoEnable=true

### Discoverable on startup

If the device should always be visible and directly connectable:

/etc/bluetooth/main.conf

[General] DiscoverableTimeout = 0


Try to make the changes and test, then report your findings. :slightly_smiling_face:

4 Likes

OH! Thank you!!!!! I have been trying to figure it out all day haha..who knew it was as simple as removing the hash sign. I had a hunch that it was the issue but I didnt want to destroy my whole file by doing something wrong.

Thank you, I appreciate the simple fix. I saw the solution on the forums but assumed that I should keep the "#" symbols inplace since it was already there.

Thanks again saved me!

3 Likes

Glad to see you worked it out. If you are nervous about editing root configuration files the best practice is to always make a backup of the original first.

Use the copy command cp to create a duplicate first. Simply add a .bak suffix to the new backup file. See the manfile for the copy command.

man cp

4 Likes

You'll see this throughout Linuxland (at least), so it's valuable stuff you've learned today. Kudos! :slight_smile:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.