Bluetooth disabled on KDE when I start the day

Hello folks!

I don’t know why/when/how but somewhere along the line the system configuration and KDE interface stopped seeing my Bluetooth as being active, despite systemctl status showing it as running. This happens right when I turn the system on to start the day.

systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: active (running) since Wed 2023-11-01 07:15:04 -03; 43min ago
       Docs: man:bluetoothd(8)
   Main PID: 895 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18656)
     Memory: 3.3M
        CPU: 44ms
     CGroup: /system.slice/bluetooth.service
             └─895 /usr/lib/bluetooth/bluetoothd

nov 01 07:15:04 johnny-g55590 systemd[1]: Started Bluetooth service.
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: Starting SDP server
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: src/plugin.c:plugin_init() System does not support csip plugin
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: profiles/audio/micp.c:micp_init() D-Bus experimental not enabled
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: src/plugin.c:plugin_init() System does not support micp plugin
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: src/plugin.c:plugin_init() System does not support vcp plugin
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: src/plugin.c:plugin_init() System does not support mcp plugin
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: src/plugin.c:plugin_init() System does not support bass plugin
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: src/plugin.c:plugin_init() System does not support bap plugin
nov 01 07:15:04 johnny-g55590 bluetoothd[895]: Bluetooth management interface 1.22 initialized

If I run sudo modprobe -r btusb && sleep 10 && sudo modprobe btusb as @tbg suggested here, KDE sees the Bluetooth as active once again…

But it’s a pain to manually reset the Bluetooth everytime I tun the computer on, I’d really like to solve whatever problem is going on here.

  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=468e3250-834f-4678-85b1-f50f268e557d rw rootflags=subvol=@ quiet console=tty0
    console=ttyS0,115200n8 cryptomgr.notests initcall_debug intel_iommu=igfx_off
    kvm-intel.nested=1 no_timer_check noreplace-smp page_alloc.shuffle=1 rcupdate.rcu_expedited=1
    rootfstype=ext4,btrfs,xfs,f2fs tsc=reliable rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=92d5bc58-440e-4eab-9f01-4fa35d34e02b loglevel=3 rw ibt=off
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: G5 5590 v: N/A serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Dell model: 0F3T2G v: A00 serial: <superuser required> UEFI: Dell v: 1.22.0
    date: 11/10/2022
  ID-1: BAT0 charge: 45.4 Wh (100.0%) condition: 45.4/60.0 Wh (75.6%) volts: 16.9 min: 15.2
    model: SMP DELL JJPFK87 type: Li-poly serial: <filter> status: full
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xA (10)
    microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4000 high: 4003 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4000 2: 4000 3: 4000 4: 4000 5: 4000 6: 4000 7: 4000 8: 4000
    9: 4000 10: 4003 11: 4000 12: 4000 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: none off: eDP-1 empty: DP-1,
    DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Dell driver: nvidia v: 535.113.01
    alternate: nouveau,nvidia_drm non-free: 535.xx+ status: current (as of 2023-09) arch: Turing
    code: TUxxx process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max:
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f11 class-ID: 0300
  Device-3: Microdia [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 1-5:3 chip-ID: 0c45:671f class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x2160 s-dpi: 114 s-size: 571x482mm (22.48x18.98") s-diag: 747mm (29.42")
  Monitor-1: DP-0 pos: primary,top res: 2560x1080 dpi: 81 size: 798x334mm (31.42x13.15")
    diag: 865mm (34.06") modes: N/A
  Monitor-2: HDMI-0 pos: bottom res: 2560x1080 hz: 60 dpi: 96 size: 677x290mm (26.65x11.42")
    diag: 736mm (29") modes: N/A
  Monitor-3: eDP-1-1 size-res: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: gbm: drv: nvidia
  API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 glx-v: 1.4 direct-render: yes renderer: NVIDIA
    GeForce RTX 2060/PCIe/SSE2 memory: 5.86 GiB
  API: Vulkan v: 1.3.269 layers: 14 device: 0 type: integrated-gpu name: Intel UHD Graphics 630
    (CFL GT2) driver: mesa intel v: 23.2.1-arch1.2 device-ID: 8086:3e9b surfaces: xcb,xlib
    device: 1 type: discrete-gpu name: NVIDIA GeForce RTX 2060 driver: nvidia v: 535.113.01
    device-ID: 10de:1f11 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe (LLVM 16.0.6 256
    bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_int
el_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Device-3: Generalplus [] driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4.1:4 chip-ID: 1b3f:2008 class-ID: 0300
  Device-4: Realtek [] driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 1-4.5:8 chip-ID: 0bda:4014 class-ID: 0102 serial: <filter>
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 3c:00.0 chip-ID: 10ec:2502 class-ID: 0200
  IF: enp60s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell
    driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 3d:00.0
    chip-ID: 168c:003e class-ID: 0280 temp: 48.0 C
  IF: wlp61s0 state: down mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB rev: 3.0
    speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 6-1.2:3 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp58s0u1u2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Qualcomm Atheros [] driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-14:7 chip-ID: 0cf3:e007 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.2 lmp-v: 8 status:
    discoverable: no pairing: no class-ID: 7c010c
  Local Storage: total: 1.14 TiB used: 862.72 GiB (73.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 NVMe WDC 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 tech: SSD
    serial: <filter> fw-rev: 20240012 temp: 58.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-75Z10T3 size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 4514 scheme: GPT
  ID-1: / raw-size: 221.19 GiB size: 221.19 GiB (100.00%) used: 129.8 GiB (58.7%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 636 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 221.19 GiB size: 221.19 GiB (100.00%) used: 129.8 GiB (58.7%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 221.19 GiB size: 221.19 GiB (100.00%) used: 129.8 GiB (58.7%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 221.19 GiB size: 221.19 GiB (100.00%) used: 129.8 GiB (58.7%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.31 GiB used: 12.5 MiB (0.1%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.98 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 75.0 C pch: 78.0 C mobo: N/A gpu: nvidia temp: 61 C
  Fan Speeds (rpm): N/A
  Processes: 339 Uptime: 1h 30m wakeups: 5 Memory: total: 16 GiB note: est. available: 15.31 GiB
  used: 7.13 GiB (46.6%) Init: systemd v: 254 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 clang: 16.0.6 Packages: 1957 pm: pacman pkgs: 1948 libs: 497
  tools: gnome-software,octopi,pamac,paru,yay pm: flatpak pkgs: 9 Client: shell wrapper
v: 5.2.15-release inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2023-04-01
  Last full system update: 2023-10-31
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            

Just suggesting ideas off the top of my head, can you check if running this command

systemd-analyze cat-config modprobe.d

has this as a part of its output

# /usr/lib/modprobe.d/bluetooth-usb.conf
# use "reset=1" as default, since it should be safe for recent devices and
# solves all kind of problems.
options btusb reset=1
1 Like

it does

Hmm, I don’t have a lot of great ideas since I haven’t faced BT or networking related issues in general with garuda before but how about trying out the various suggestions listed in the thread?

  1. Switch to LTS kernel and see if it helps
  2. Switch to linux-firmware-git and see if it helps.

    :warning: Note: It was explicitly mentioned that if this package doesn’t help immediately switch back to the non git version to avoid errors that having a git package might expose. (sometimes being too close to the bleeding edge is not good).

  3. If none of this works then please reproduce the bug, run the command to correct it and provide the following diagnostic as mentioned in that thread as well. Let’s see if we can find anything worthwhile.
sudo dmesg | grep -Ei 'blue|firm'

nope =( moving on to git test… shakes on dread

no luck here either. going back to non-git

[    2.637318] calling  firmware_memmap_init+0x0/0xc0 @ 1
[    2.637348] initcall firmware_memmap_init+0x0/0xc0 returned 0 after 27 usecs
[    4.632904] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    5.500038] systemd[1]: TPM2 PCR Machine ID Measurement was skipped because of an unmet condition check (ConditionPathExists=/sys/firmware/efi/efivars/StubPcrKernelImage-4a67b082-0a4c-41cf-b6c7-440b29bb8c4f).
[    7.224102] ath10k_pci 0000:3d:00.0: firmware ver WLAN.RM.4.4.1-00288- api 6 features wowlan,ignore-otp,mfp crc32 bf907c7c
[    7.286779] calling  bt_init+0x0/0xd0 [bluetooth] @ 567
[    7.286837] Bluetooth: Core ver 2.22
[    7.287166] NET: Registered PF_BLUETOOTH protocol family
[    7.287168] Bluetooth: HCI device and connection manager initialized
[    7.287172] Bluetooth: HCI socket layer initialized
[    7.287175] Bluetooth: L2CAP socket layer initialized
[    7.287179] Bluetooth: SCO socket layer initialized
[    7.287182] initcall bt_init+0x0/0xd0 [bluetooth] returned 0 after 344 usecs
[    7.440528] Bluetooth: hci0: HCI Enhanced Setup Synchronous Connection command is advertised, but not supported.
[    9.470926] Bluetooth: hci0: Opcode 0x c03 failed: -110
[   11.057044] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   11.057046] Bluetooth: BNEP filters: protocol multicast
[   11.057050] Bluetooth: BNEP socket layer initialized

For in depth information on Bluetooth always refer to the Arch Wiki. Specifically, see section 3.2 of the Arch Wiki on BT - Discoverable on startup:

Be sure to also see the other Arch Wiki entries pertaining to Bluetooth:

This could possibly be a conflict between your wifi driver (or some other driver) and your bluetooth driver clashing at startup. A workaround for this is to write a systemd service that will delay (or restart) your bluetooth driver once your other drivers have finished loading. This will usually allow for your bluetooth to load automatically at startup, (with a slight delay). Not exactly a fix for what is causing this, but most people find it a satisfactory workaround until their issue is corrected.

You may find services of this type that I’ve written on the forum if you search thoroughly here. There used to be a ton of my services posted for reference on a green Arch derivitave distro’s forum, but unfortunately they have repeatedly deleted their past forum instances. Therefore most my past services I’d written are no longer available online. I am super busy ATM, but I may possibly be able to help you write a service when I have some time available.

Good luck.


but that’s the thing - and now in hindsight I think I failed to mention: I can use bluetooth on terminal, and connect to a previously paired device, or pair to a new device, through the terminal, without restarting it. It’s only the GUI on KDE that says the bluetooth is disabled, and clicking “activate” on it won’t do nothing. But if I restart the bluetooth on the terminal, the GUI on KDE updates and works.

thanks for this guidance, I’ll look into it!

added ExecStartPre=/bin/sleep 30 to [Service], as mentioned here, but didn’t work. And, once again, running sudo modprobe -r btusb && sleep 10 && sudo modprobe btusb did.

And it’s really a real-time change. If I leave the KDE System Configuration window open, looking at it with the bluetooth offline, and run the command, I’ll see it become disabled/unavailable, then come back with the list of previously paired devices.

Do everyone providing assistance here on the forum a favour, please don’t post excerpts of errors, command outputs, or any scripts/services you’ve written. Always post a complete record of what you have tried, don’t post a summary in your own words, or an excerpt. We need everything in its entirety to have a chance of making the correct diagnosis remotely.

Could you please provide the complete contents of the service you tested and it’s status when run.

Description=Bluetooth service

#ExecStartPre=/bin/sleep 10

# Filesystem lockdown

# Execute Mappings

# Privilege escalation

# Real-time



this one was on OP, adding the sleep ExecStartPre parameter changed nothing.

But between this and these other 2 problems, I decided to just give up on dragonized gaming for the moment and go check out what this Hyprland is about.

Thank you all for all the support provided, and I’m sorry for those mistakes annoying you so much.

I assume you weren’t running the command as it shows currently. You didn’t have the line commented out when testing?

1 Like

Line wasn’t commented while testing. I added it, rebooted, nothing changed so I commented it and rebooted again.

Ya, I figured so, but I always have to be certain.

I’m doubtful this will work, but try it anyways as it does not require sudo privileges.

nmcli r off; sleep 5; nmcli r on

If that command actually worked to restart your BT properly it could be easily run at login automatically.

1 Like

Thanks, but I’m already moving on with install =p

Guess what? Format & reinstall of Dr460nized Gaming didn’t solve the issue. I had to, once again, use sudo modprobe -r btusb && sleep 10 && sudo modprobe btusb to make the settings see that bluetooth is enabled :man_facepalming:

wouldn’t it be the same as … oh, no sudo, I see. Let me reboot here and test it.

nmcli r off; sleep 5; nmcli r on

Erro: argumento “off” não compreendido. Tente passar --help.
Erro: argumento “on” não compreendido. Tente passar --help.

This error would be like “arguments off and on not understood. Try using --help”

nmcli r --help
Uso: nmcli radio { COMANDO | help }

COMANDO := { all | wifi | wwan }

  all | wifi | wwan [ on | off ]

 ╭─johnny@johnny in ~ took 1m9s
 ╰─λ nmcli r all off

 ╭─johnny@johnny in ~ took 13s
 ╰─λ nmcli r all on

yeah, no deal. Bluetooth settings still say the BT is disabled. But, once again, if I sudo modprobe -r btusb && sleep 10 && sudo modprobe btusb, it works.

How about trying to use the “normal” dr460nized version and see if anything changes with it? I attached a post before where a software was boot blocking some people so it wouldn’t be strange if it was the same here.

Also, although your UEFI version is very recent try to look online if there are any UEFI updates for your system from your vendor. Maybe this is the cause of your strange issue. :thinking:

Try this:

A startup service with root privileges can start your BT connection automatically without any password required. The following is a simple system service I wrote to delay Bluetooth startup. Delaying your Bluetooth startup will hopefully remove any clashes that are preventing Bluetooth from initiating correctly.

The best way to ensure there is no Bluetooth conflicts at startup is to blacklist the btusb module.

To blacklist the btusb module, run this command:

echo 'blacklist btusb' | sudo tee /etc/modprobe.d/blacklist_btusb.conf

This will create an /etc/modprobe.d/blacklist_btusb.conf file which will prevent the bluetooth module from starting automatically. Even with Bluetooth blacklisted, your Bluetooth can still be started by alternate means. To do this automatically after a slight time delay, create the following restart bluetooth service:

Restart Bluetooth Service

With a text editor create:


Systemd service file contents:

#cat /etc/systemd/system/restart-bt.service
#systemctl enable restart-bt.service
#systemctl start restart-bt.service
#systemctl stop restart-bt.service
#systemctl disable restart-bt.service
#systemctl status restart-bt.service
#systemctl daemon-reload

Description=Restart Bluetooth Service

ExecStartPre=/usr/bin/sleep 5
ExecStart=/usr/bin/modprobe btusb
ExecStop=-/usr/bin/systemctl restart bluetooth


Save the newly created service file, then enable the service:

systemctl enable restart-bt.service

Then restart.

Bluetooth should now automatically be started after all your other drivers and network components have been loaded at startup.

If this service does not correct your issue, then you can disable this service and delete the /etc/modprobe.d/blacklist_btusb.conf blacklist file.


this is one thing I always found weird about Arch Wiki - it says my laptop won’t update BIOS through fwupd, but it works here [1]. No updates found anywhere.

It did not… but at least it’s a different status now:

instead of saying it’s disabled, it says that no adapter were found. But guess what happens when I run sudo modprobe -r btusb && sleep 10 && sudo modprobe btusb again? It works =p

honestly, this happens to me from time to time with my bluetooth headset.

I just remove the file .config/bluedevilglobalrc and all is good again next time


removed it, rebooted it, nothing =( I’m doomed to use sudo modprobe -r btusb && sleep 10 && sudo modprobe btusb for the rest of my life.

I would still suggest trying out the “normal” dr460nized version who knows maybe it’s a preinstalled software that’s causing this issue?

or, if all fails you can make this a systemd command.

1 Like