Black screen during boot

I downloaded the Garuda Linux dragonized, XFCE but both get stuck on a black screen after I'm past the boot section. I tried free as well as non free drivers, but nothing shows up. I tried going into TTY but no luck there. Can i get some help please? I don't have any NVIDIA or any hardware that needs proprietary drivers.

on said black screens, does pressing the up arrow do anything? it takes away the splash screen usualy and shows u whats going on

We'd need more information (like logs) to have any clue what's happening. Search for how to start the Calamares installer in debug mode.

Inspect your UEFI/BIOS settings.
Set AHCI, or other change.

1 Like

I've also had this problem in Hyper-V.

In my experience a black screen means you may need to use the framebuffer driver which is not installed by default.

At the black screen, type:

ALT-F5

To get to a console.
Then login and install the FB driver:

pacman -Sy xf86-video-fbdev
systemctl restart display-manager.service

But if you can't even get into a console then this probably isn't the problem.
It's more likely you need to disable KMS.

Have you tried editing the kernel line to disable KMS by adding a nomodeset?

https://wiki.archlinux.org/index.php/kernel_mode_setting