[XFCE build] Nouveau: Installer failure 'mkinitcpio' error + Nvidia: Black screen before Xorg

Hello everyone,

I found out about Garuda and wanted to give it a try but I am getting errors with both nvidia and open source grub options. First I tried nvidia drivers and got a black screen before getting in the desktop environment. (See install attempt #1 below)

I figured I'd just install nvidia drivers later so, I tried open source video option in the grub instead. This booted fine but the installer failed near the end of the installation process. (See install attempt #2 below)

Here are the details of both screnarios, and some context about my pc / desired outcome;



My desired end result:

xfce desktop, full disk install (+swap), using nvidia driver
(installed with the latest xfce image from garuda downloads)

What's plugged in the laptop:

power cable, live usb stick, network cable rj45

Hard drive status before live boot:

formatted to ext4, empty disk, one partition (no os installed on disk)

My bios details:

legacy boot only (no uefi on this laptop), no option to change any video settings, (no AHCI option). Actually the only option available are boot order and hyper-v which is turned on (not sure it matters but I did not mess with that). I have the latest update.

My system details:

Machine:   Type: Laptop System: Sony product: VPCF120FD v: C605K21R serial: <filter> Chassis: 
           type: 10 serial: N/A 
           Mobo: Sony model: VAIO serial: <filter> BIOS: American Megatrends v: R1110Y6 
           date: 05/31/2010 
Battery:   ID-1: BAT0 charge: 41.9 Wh (100.0%) condition: 41.9/48.8 Wh (85.7%) volts: N/A 
           min: 108.7 model: Sony Corp. type: Li-ion serial: N/A status: Full 
CPU:       Info: Dual Core model: Intel Core i5 M 430 bits: 64 type: MT MCP arch: Nehalem 
           family: 6 model-id: 25 (37) stepping: 2 microcode: 11 cache: L1: 128 KiB L2: 3 MiB 
           L3: 3 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18088 
           Speed: 1563 MHz min/max: 1199/2267 MHz base/boost: 2266/2266 boost: enabled 
           volts: 1.4 V ext-clock: 133 MHz Core speeds (MHz): 1: 1563 2: 2349 3: 1609 4: 1631 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GT218M [GeForce 310M] vendor: Sony driver: N/A alternate: nouveau 
           bus-ID: 01:00.0 chip-ID: 10de:0a75 class-ID: 0300 
           Device-2: Ricoh type: USB driver: uvcvideo bus-ID: 1-1.2:3 chip-ID: 05ca:18ba 
           class-ID: 0e02 
           Display: server: X.org 1.20.12 driver: loaded: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa tty: 102x38 
           Message: Advanced graphics data unavailable in console for root. 
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Sony 
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403 
           Device-2: NVIDIA High Definition Audio vendor: Sony driver: snd_hda_intel v: kernel 
           bus-ID: 01:00.1 chip-ID: 10de:0be3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.5-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.32 running: no 
Network:   Device-1: Qualcomm Atheros AR9287 Wireless Network Adapter vendor: Foxconn 
           driver: ath9k v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 168c:002e class-ID: 0280 
           IF: wlp2s0 state: down mac: <filter> 
           Device-2: Marvell 88E8057 PCI-E Gigabit Ethernet vendor: Sony driver: sky2 v: 1.30 
           port: a000 bus-ID: 04:00.0 chip-ID: 11ab:4380 class-ID: 0200 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Foxconn / Hon Hai Foxconn T77H114 BCM2070 [Single-Chip Bluetooth 2.1 + EDR 
           Adapter] 
           type: USB driver: btusb v: 0.8 bus-ID: 1-1.6:4 chip-ID: 0489:e00f class-ID: fe01 
           serial: <filter> 
           Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running 
           rfk-block: hardware: no software: no address: <filter> 
Drives:    Local Storage: total: 193.58 GiB used: 0 KiB (0.0%) 
           ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS543216L9A300 
           family: Travelstar 5K320 size: 149.05 GiB block-size: physical: 512 B logical: 512 B 
           sata: 2.6 speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: C40C temp: 34 C 
           scheme: MBR 
           SMART: yes state: enabled health: PASSED on: 1y 38d 23h cycles: 1033 
           ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston model: DataTraveler 3.0 
           size: 28.82 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> 
           scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Generic model: Flash Disk 
           size: 15.71 GiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> 
           rev: 8.07 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?


What I did, install attempt #1: (Using Nvidia option in grub )

Got a black screen just before reaching the desktop environment, so I used alt-f5 and logged in. Then I typed "startx". This resulted in an error saying:

[   585.160] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[   585.164] 
X.Org X Server 1.20.12
X Protocol Version 11, Revision 0
[   585.178] Build Operating System: Linux Archlinux
[   585.198] Current Operating System: Linux garuda-xfce 5.13.5-zen1-1-zen #1 ZEN SMP PREEMPT Sun, 25 Jul 2021 18:03:00 +0000 x86_64
[   585.199] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda misolabel=GARUDA_XFCE_SOARING_ quiet systemd.show_status=1 systemd.unified_cgroup_hierarchy=1 driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
[   585.268] Build Date: 29 July 2021  08:42:26AM
[   585.287]  
[   585.308] Current version of pixman: 0.40.0
[   585.354] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   585.354] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   585.468] (==) Log file: "/home/garuda/.local/share/xorg/Xorg.0.log", Time: Wed Aug  4 23:31:08 2021
[   585.501] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   585.535] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   585.536] (==) No Layout section.  Using the first Screen section.
[   585.536] (==) No screen section available. Using defaults.
[   585.536] (**) |-->Screen "Default Screen Section" (0)
[   585.536] (**) |   |-->Monitor "<default monitor>"
[   585.536] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   585.536] (==) Automatically adding devices
[   585.536] (==) Automatically enabling devices
[   585.536] (==) Automatically adding GPU devices
[   585.536] (==) Automatically binding GPU devices
[   585.536] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   585.536] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc".
[   585.536] 	Entry deleted from font path.
[   585.536] 	(Run 'mkfontdir' on "/usr/share/fonts/misc").
[   585.536] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[   585.536] 	Entry deleted from font path.
[   585.536] 	(Run 'mkfontdir' on "/usr/share/fonts/TTF").
[   585.536] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[   585.536] 	Entry deleted from font path.
[   585.536] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[   585.536] 	Entry deleted from font path.
[   585.536] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[   585.536] 	Entry deleted from font path.
[   585.536] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[   585.536] 	Entry deleted from font path.
[   585.536] (==) FontPath set to:
	
[   585.536] (==) ModulePath set to "/usr/lib/xorg/modules"
[   585.536] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   585.536] (II) Module ABI versions:
[   585.536] 	X.Org ANSI C Emulation: 0.4
[   585.536] 	X.Org Video Driver: 24.1
[   585.536] 	X.Org XInput driver : 24.1
[   585.536] 	X.Org Server Extension : 10.0
[   585.537] (++) using VT number 5

[   585.540] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[   585.544] (--) PCI:*([email protected]:0:0) 10de:0a75:104d:9067 rev 162, Mem @ 0xe2000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/131072
[   585.544] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   585.544] (II) LoadModule: "glx"
[   585.546] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   585.548] (II) Module glx: vendor="X.Org Foundation"
[   585.548] 	compiled for 1.20.12, module version = 1.0.0
[   585.548] 	ABI class: X.Org Server Extension, version 10.0
[   585.548] (==) Matched nouveau as autoconfigured driver 0
[   585.548] (==) Matched nv as autoconfigured driver 1
[   585.548] (==) Matched modesetting as autoconfigured driver 2
[   585.548] (==) Matched fbdev as autoconfigured driver 3
[   585.548] (==) Matched vesa as autoconfigured driver 4
[   585.548] (==) Assigned the driver to the xf86ConfigLayout
[   585.548] (II) LoadModule: "nouveau"
[   585.548] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[   585.548] (II) Module nouveau: vendor="X.Org Foundation"
[   585.548] 	compiled for 1.20.10, module version = 1.0.17
[   585.548] 	Module class: X.Org Video Driver
[   585.548] 	ABI class: X.Org Video Driver, version 24.1
[   585.548] (II) LoadModule: "nv"
[   585.548] (WW) Warning, couldn't open module nv
[   585.548] (EE) Failed to load module "nv" (module does not exist, 0)
[   585.548] (II) LoadModule: "modesetting"
[   585.549] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   585.549] (II) Module modesetting: vendor="X.Org Foundation"
[   585.549] 	compiled for 1.20.12, module version = 1.20.12
[   585.549] 	Module class: X.Org Video Driver
[   585.549] 	ABI class: X.Org Video Driver, version 24.1
[   585.549] (II) LoadModule: "fbdev"
[   585.550] (WW) Warning, couldn't open module fbdev
[   585.550] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   585.550] (II) LoadModule: "vesa"
[   585.550] (WW) Warning, couldn't open module vesa
[   585.550] (EE) Failed to load module "vesa" (module does not exist, 0)
[   585.550] (II) NOUVEAU driver 
[   585.550] (II) NOUVEAU driver for NVIDIA chipset families :
[   585.550] 	RIVA TNT            (NV04)
[   585.550] 	RIVA TNT2           (NV05)
[   585.550] 	GeForce 256         (NV10)
[   585.550] 	GeForce 2           (NV11, NV15)
[   585.550] 	GeForce 4MX         (NV17, NV18)
[   585.550] 	GeForce 3           (NV20)
[   585.550] 	GeForce 4Ti         (NV25, NV28)
[   585.550] 	GeForce FX          (NV3x)
[   585.550] 	GeForce 6           (NV4x)
[   585.550] 	GeForce 7           (G7x)
[   585.550] 	GeForce 8           (G8x)
[   585.550] 	GeForce 9           (G9x)
[   585.550] 	GeForce GTX 2xx/3xx (GT2xx)
[   585.550] 	GeForce GTX 4xx/5xx (GFxxx)
[   585.550] 	GeForce GTX 6xx/7xx (GKxxx)
[   585.550] 	GeForce GTX 9xx     (GMxxx)
[   585.550] 	GeForce GTX 10xx    (GPxxx)
[   585.550] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   585.551] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[   585.551] (EE) open /dev/dri/card0: No such file or directory
[   585.551] (WW) Falling back to old probe method for modesetting
[   585.551] (EE) open /dev/dri/card0: No such file or directory
[   585.551] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   585.551] (EE) Screen 0 deleted because of no matching config section.
[   585.551] (II) UnloadModule: "modesetting"
[   585.551] (EE) Device(s) detected, but none match those in the config file.
[   585.551] (EE) 
Fatal server error:
[   585.551] (EE) no screens found(EE) 
[   585.551] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   585.551] (EE) Please also check the log file at "/home/garuda/.local/share/xorg/Xorg.0.log" for additional information.
[   585.551] (EE) 
[   585.654] (EE) Server terminated with error (1). Closing log file.
e[1me[31m> e[mInstalled PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2021.02.19                true            PCI


e[1me[31mWarning: e[mNo installed USB configs!

The nvidia driver does not seem to even load. At least I think. So at this point I went back to grub to try again without nvidia.



What I did, install attempt #2: (Using open source video option in grub )

This booted fine but then I got an install failure near the end of the process :

Installation failed Extrenal command mkinitcpio finished with exit code 1
Output:
/usr/sbin/mkinitcpio: line 268: /etc/mkinitcpio.d/linux-lts.preset: No such file or directory
==> ERROR: Failed to load preset: '/etc/mkinitcpio.d/linux-lts.preset'

Then I tried searching for "black screen" and other related terms in this forum, except the results are showing me similar errors that happened to people AFTER they had installed the os. OR, the search results appeared relevant at first but, in the end, were not.

For example:

My problem is during the installation process. So instead I went on duckduckgo and found some hints, I think. But to be honest, at that point, I was reading stuff that's a bit out of my league...

For example:

Maybe I missed the post that had a solution, I am not sure. I'll appologize now just in case. Might be because I am starting to get "tunnel vision"... reading about this for too long.

Last, I decided to try another build instead, the lxqt. The installer went through without any issue (nouveau video mode). But I am desperate to use xfce because this is what I am familliar with and felt uncomfortable using lxqt.

Please, is there any chance someone could help me find a workaround? I would really like to use the xfce desktop if possible. I can defenitely post any other logs if needed.



Edit:
Adding other things I've tried but did not help, unfortunately:

Adding "nomodeset" in grub
Info from: Black screen during boot - #5 by Bog

Checksum test: no issue there

1 Like

The same issue was reported by another user earlier today. It is probably an issue with that ISO that needs to be fixed.

1 Like

Oh! looks like I did not see that post. Thanks for letting me know. Maybe I could use an older ISO an update from there ?

Edit: maybe not :frowning:

The answer is there is no place to find older ISOs.

from:

Worth a shot if you have an older ISO. Garuda is rolling so using a slightly out-of-date ISO should be fine.

I was searching for older ISO in the meantime, but looks like there is no "archive" or older download. Edited my other reply with source ^

I'll keep looking a bit just to be sure

Edit: Got it! Found xfce iso build (210720), i'll try that instead

1 Like

You can still transform your current installed system to almost Garuda XFCE, if you install the appropriate packages.
After you successfully get to an XFCE session in your system, you can remove whatever is LXQt related and add your preferred applications.

FWIW your nvidia card is too old. You can use only open source nouveau (video-linux config in Hardware Manager) and I suggest so.

2 Likes

True that, actually I was looking at installing xfce on the lxqt build I had installed earlier. But then, I researched about that and found it is not a good idea to have 2 DE at the same time / same user. Somehow this info made me ditch the idea but I never thought of just removing the lxqt afterwards lol. I must be tired, that is defenitely worth a try. Probably better than using the old ISO I just found actualy (since it's from a thirdparty website). Thank you guys, i'll see if I can manage.

Have a look in this list (xfce ISO packages).
Most of them may already exist/be installed.
Maybe compare with LXQt ones.

2 Likes

Nice, I will use this as a reference then. I just hope that if I go that way and replace with xfce DE, the application menu will be organized like it is when using the actual xfce iso. I guess I will find out soon hehe

Yes. Compare and see what's missing.
Start with the xfce group and the goodies. Check.

You have to be alert though, during installation (using pacman in terminal), as there maybe conflicts and you may have to respond correctly (replace or not).
It may need research, or you may be lucky (I hope so :wink: ).

1 Like

Gotcha! Maybe one last thing before trying this harder route. If I use the ISO I found, could I just do sha256sum on that thirdparty iso and compare with the official checksum data? I did it just now and got:

$ sha256sum garuda-xfce-linux-lts-210720.iso 
eaa1a413d14690dba8e061fea59bd590a03305d74fad4ed54c359118f1276e09  garuda-xfce-linux-lts-210720.iso

but found nothing to compare it to. I'm thinking, if I did have that info, there wouldn't be any cause for concern i guess. (and would be easier than replacing desktop)

I guess it's a failed expectation... Sorry :man_shrugging:


Different date on the servers

Post link please.

@petsam those won't match for sure since it's not the same build
(210720 vs 210729). Oh well, I thought I'd ask. Thank you tho

@SGS sure, I did not post it before since it might have been forbidden to do so. Anyways, here goes (I have no idea if this is reliable btw, never used that site before)

https://linuxtracker.org/index.php?page=torrent-details&id=efd06ab98bf82f85a0185084c2c260fb86c6f75e

I know there is a md5 hash there but, I can't trust it for obvious reasons

Firstly congratulations for writing such a detailed post as your first post!

Read this

It would be really helpfull in switching versions. You can make use of the --needed flag to stop the package from a group selection choices which get really confusing.

Its a know bug

3 Likes

Thanks, I am working as a QA / QA analyst using Agile. Been 16 years now . So i had training and much experience in writing bugs haha. That helps :stuck_out_tongue:

Also I want to thank you all for helping out. I will study those replies / links carefully and try my luck with the installation proceedure after that. Garuda rocks! I installed various versions on all my gear lol (will donate too, it's too awesome)

cheers!

1 Like

Alright, just to share my findings (might help someone idk :P), I did install that older "rogue" iso, just as a test. I used the exact same scenario described in OP ^ (install attempt #2:). The install went through without any problem.

Of course I will not use that installation, the last thing i'll try before formatting is installing nvidia drivers. Even though my nvidia card is too old, like petsam said. I'm just stubborn and I like to test stuff haha. Then I will build XFCE manually or, worst case, I can just wait for a newer version of the XFCE iso. I am not in a hurry

Finally, I just wanna add that the payment went through (donation using librapay). I know it's not a huge amount, I do what I can to help at this time. You guys/gals defenitely deserve something so there you go. Good job with this distro.

(Note: I was never able to compile ungoogled-chrome myself and, when I saw it's in Garuda repo ... just wow! :partying_face: )

Anyway, keep up the good work !

2 Likes

This old BIOS date concerns me. Is there an updated BIOS available? How much RAM do you have installed? It takes a minimum 3 Gigs to boot , 4 to run (halfway comfortably)--or so I believe I read.

I had the same concern when I got the laptop. I am trying to "revive" it for a friend (who knows nothing about pc). So I did check the bios before anything else, except it looks like Sony removed the downloads for it.

Sony VAIO model: PCG-812214L
Drivers and Software updates for PCG-812 | Sony USA

So I kinda of assumed that this bios was the latest... I guess I could dig deeper to see if there is a newer version somewhere else but, I don't think I should trust another source other than the manufacturer. idk

This laptop has 4GB of ram and seems to work just fine, no lag or anything. I did test lxqt iso and now xfce.

Average RAM usage after full updates and all desktop effect / animations turned on: (no apps opened by user)

lxqt : 1.92 GB ram used out of 3.8GB
xfce: 1.2 GB ram used out of 3.8GB

Were you asking due to a concern like, security-wise?

Edit: Anyways, even if I wanted to update from third-party downloads, I can't seem to find any websites that have an update file for this bios. Looks like this is as good as it gets.

What concerned me about the old BIOS date was that new operating systems and, sometimes old BIOS' and hardware don't mix, especially if updates have not been applied, if available.

You've settled that and the RAM question, so it 'sounds' like an nVidia driver problem? Someone with experience on older hardware and nVidia may probably help you from here, as I haven't had an nVidia card for quite some time.

Good luck--and welcome to Garuda Linux.

regards

2 Likes