ASUS Vivobook S14 + Garuda Linux

Hello everyone,

First time posting a problem on this forum (and any forum). I have read the recommendations, but if I forget something or you want to recommend me how to do something better, please feel free to tell me.

Problem

Due to problems with my previous laptop, last week I bought the ASUS Vivobook S14 (model S435EA) and I'm quite happy with it, but there has been an unexpected problem: I can't install Garuda Linux.

More precisely, I can install it, but I can't use it; because when I reboot the system after installation, it doesn't even reach the first login. I've left it for about 6 hours, but the loading bar gets to a point where it doesn't move.

I'm considering returning the laptop (while I can) if I can't install Garuda, because I have several options of laptops that meet my needs: I don't need this one in particular. However, it would be quite annoying.

Steps

I'm not an expert on BIOS issues because in my career it hasn't been looked at in depth, so I'm sure I'll fail at the jargon. I hope I'm understood.

BIOS

The steps I have followed have been as described on the official downloads page, with the ISOs available there. I have done them all, except:

  • "If your firmware supports UEFI then set your BIOS settings to UEFI only."
    The laptop uses ASUS BIOS and if I am not mistaken, it is UEFI only.

  • "Make sure that SATA controller is set to AHCI mode in BIOS settings".
    This is the only one I haven't done, because after searching in the BIOS itself and on the internet, I haven't found anything related. I think it is AHCI by default according to what I have read, but I am not sure.

  • I used Etched to burn the ISO, having tried the 3 Dr460nized editions and the GNOME one; all failed at the same point (why did I try so many?).

GRUB

After the above steps, change the boot order and set the initial parameters from GRUB:

  1. The "live" version boots without problems.
  2. I start the installation: erase the whole disk, with or without Swap (nothing changed).
  3. I shut down or reboot the laptop (nothing changed), without the USB.

Finished

This is where it fails:

  1. The laptop boots and loads GRUB, and Garuda.
  2. The wallpaper appears with the loading dragon icon (new?) and a bar starts loading.

The bar starts to move very slowly and after about 30 min, it stops (I think at about 75 %), I can't even do my first login.


inxi -Fxxxza

I installed Kali on the laptop to run the command, please note that.

System:
  Kernel: 5.10.0-kali7-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-kali7-amd64 
  root=UUID=957f7848-b050-48c2-b2ae-2c45dddbb0fe ro quiet splash 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.24 wm: gnome-shell dm: GDM3 3.38.2.1 
  Distro: Kali GNU/Linux 2021.2 base: Debian testing 
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X435EA_S435EA 
  v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X435EA v: 1.0 serial: <filter> 
  UEFI: American Megatrends LLC. v: X435EA.301 date: 01/27/2021 
Battery:
  ID-1: BAT0 charge: 21.9 Wh condition: 68.0/67.3 Wh (101%) volts: 15.9/15.9 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging 
  cycles: 1 
CPU:
  Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP 
  arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 60 
  L2 cache: 12 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44851 
  Speed: 1425 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 1425 2: 1438 
  3: 1402 4: 1397 5: 1404 6: 1333 7: 1402 8: 1353 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel TigerLake GT2 [Iris Xe Graphics] vendor: ASUSTeK 
  driver: i915 v: kernel bus ID: 0000:00:02.0 chip ID: 8086:9a49 
  class ID: 0300 
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 3-6:2 chip ID: 13d3:56dd class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting unloaded: fbdev,vesa display ID: :1 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 
  size: 309x174mm (12.2x6.9") diag: 355mm (14") 
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK 
  driver: sof-audio-pci alternate: snd_hda_intel,snd_sof_pci 
  bus ID: 0000:00:1f.3 chip ID: 8086:a0c8 class ID: 0401 
  Sound Server: ALSA v: k5.10.0-kali7-amd64 
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 3000 
  bus ID: 0000:00:14.3 chip ID: 8086:a0f0 class ID: 0280 
  IF: wlan0 state: up mac: <filter> 
Bluetooth:
  Device-1: Intel type: USB driver: btusb v: 0.8 bus ID: 3-10:4 
  chip ID: 8087:0026 class ID: e001 
  Report: ID: hci0 state: down address: <filter> 
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff 
  link-mode: slave accept 
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller 
  driver: vmd v: 0.6 port: 3000 bus ID: 0000:00:0e.0 chip ID: 8086.9a0b 
  rev: N/A 
Drives:
  Local Storage: total: 476.94 GiB used: 9.55 GiB (2.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 004C 
  temp: 33.9 C scheme: GPT 
Partition:
  ID-1: / raw size: 475.49 GiB size: 466.95 GiB (98.21%) 
  used: 9.55 GiB (2.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) 
  used: 148 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 976 MiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2900 
Info:
  Processes: 231 Uptime: 1h 37m wakeups: 568 Memory: 15.32 GiB 
  used: 1.79 GiB (11.7%) Init: systemd v: 247 runlevel: 5 Compilers: 
  gcc: 10.2.1 alt: 10 clang: 11.0.1-2 Packages: apt: 2383 lib: 1062 
  Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.3.01 


I think this may be due to the laptop's own HW, but I have searched for compatibility information both on the forum and on the internet and found nothing, so I'm not sure.

I'm also not sure what else to attach, but if anything else is needed please don't hesitate to ask.

Thanks for your attention.

1 Like

Type esc at the dragon loading
Then give us the output

4 Likes

This time try with Garuda barebones iso
As that has lts kernel in it

3 Likes

Did a quick search - this article (first one which came up, Fedora related but its about the BIOS configuration rather than that) claims there are options to configure AHCI:

If your SSD is not detected by Fedora setup, then you might need to change the SATA option in the BIOS. My laptop offered two SATA Mode selection:

AHCI
Intel RST Premium With Intel Optane System Acceleration (default)

I had to switch to AHCI for Fedora 30 to detect my NVMe SSD.

Why do so many people misspell it like this? :frowning_face_with_open_mouth: :joy:

2 Likes

When I installed it on my laptop ssd I had same problem with manjrao I didn't have the option of ahci in uefi I think, don't remember or there was some data loss warning.
So anyways I did it the safe way by going to device manager in windows 10 and manually switching the drivers of ssd from intel to Microsoft or something and it worked

Ok after refreshing my memory again basically u should be able to switch it from bios. The device manager part is specific to windows to work so u do the driver change and then Change in uefi

Firstly Thank you for such a detailed post.
Can you send a pic through Imgur where exactly you got stuck?

@dr460nf1r3
How would the grub load if the problem was disk related?

2 Likes

I just wanted to show that there seems to be an option for configuring this :slight_smile:

1 Like

A post was split to a new topic: KDFONTOP: Function not implemented

I just did, but the only change it's the UUID in the emergency shell (59d92e39-1e03-48ea-873c-e99ee81f6fa4). The problem persist.

setfont: KDFONTOP: Function not implemented
mount: /new_root: can't find UUID=4337a389-274a-4653-bf40-0978d3531c51
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]#

Do I need to run any commands in the emergency shell to get more information?

Did you chechk your /etc/fstab ?

1 Like

I think you could try the following:

  • use the USB and from there chroot into your system
  • run sudo micro /etc/mkinitcpio.conf
  • add the module vmd to the MODULES list
  • run sudo mkinitcpio -P to regenerate all initramfs
  • run sudo micro /etc/default/grub
  • add nvme_load=YES to GRUB_CMDLINE_LINUX line
  • run sudo grub-mkconfig -o /boot/grub/grub.cfg to regenerate the GRUB menu
  • reboot
2 Likes

I remember coming across that article, but although it is the same laptop, I think it is not the same model: mine has 16 Gb RAM, a 512 Gb SSD and no HDD.

When I read it I started looking inside the BIOS options, but no tab relates to what is described there. I don't have anything like "SATA mode" and in fact, I just rechecked before writing this to confirm that :pensive:


Oops, I'll correct it, I don't like spelling mistakes :nerd_face: :sweat_smile:

Yes, here you have:


Having done this:

It is no longer the dragon theme, but the same thing happens.

No, but I did it now.

[rootfs ]# cat /etc/fstab
[rootfs ]#

I don't know if it's even possible, but it seems empty.

I think you need to generate your fstab.

1 Like

I remember several cases in the past where the vmd module was loaded from the USB, so the installer was seeing the nvme disk, but not on the installed system, which was not seeing the nvme disk and fell onto rootfs.
That's why i suggested the procedure above.

2 Likes

You have to mount all partitions using the live cd of garuda.
Use this link to re gen your fstab

Secondly

This isn't a issue it simply means the font you have selected isnt possible to load in tty

You have to verify what is the Boot mode setting (each vendor names it differently).
Garuda ISOs provide two boot entries, one for UEFI and one for Legacy. If you have a BIOS setting for Auto or other vendor smart option, this could be the reason.

If this is not AHCI, then this is the reason of your issue. Read the user manual about BIOS configuration extensively. If you can't find it, post a link to the manual.

There is an Advanced options menu at grub menu. Select it and boot the fallback kernel option (not the 1st entry). If you are lucky, it may boot normally (not many chances, but you may try).

At this point, press Esc key to see messages.
Provide feedback about them, even a photo may help.

From all the above suggestions, don't change the order. Start from the top and after finishing/verifying, only then go the next.

4 Likes

This is the reason why I think that the following is false

These details can be checked only directly or with the BIOS manual, but for sure, if this can be found e.g. in the BIOS advanced settings and set to AHCI, this would be the best thing, and I found a post where this was successful (although for a different model).
My previous suggestion instead, came from here.