Trying to boot with Intel-VMD enabled

Hi everyone,
I was having some issues while trying to install Garuda in my ThinkBook T14s Yoga (11th gen i7). After "succesfully" installing, it would hang on the splash screen, so I disabled the quiet splash option and changed it for nosplash debug, which showed me that it couldn't find the disk and fell into rootfs, where I noticed the nvme drives were not recognized, only the usb stick.
After one week of some research and trial and error I noticed this post: [SOLVED] Cannot boot because nvme device cannot be found / Installation / Arch Linux Forums, and modified mkinitcpio.conf and similar actions. In the end, what actually made the difference was disabling Intel-VMD in the BIOS.
First I thought this was a garuda only issue but I tried a manjaro install and the same result happened. Anyway, the actual problem is if you know of a way to boot succesfully with vmd enabled since I still need my windows system sporadically and I can't boot into it with the vmd option disabled. I added vmd to the mkinitcpio.conf but apparently it is not enough, maybe I'm missing something but can't find a topic in other forums about this.
Any help appreciated.

1 Like

Please provide the exact details of what you have tried.

For example, post 17 of the Arch forum thread has specific changes but does not include specific instructions for rebuilding the initramfs (which is implied by altering mkinitcpio.conf).

1 Like

I just added "vmd" to the MODULES=(...) list , since the comments are somewhat scarce in details into how to properly do it. I noticed though that by executing $ mkinitcpio -M the module vmd is actually not listed, so I assume it is not doing anything.

This is where reading (e.g. the GitHub gist linked in the thread, and/or the Arch wiki), rather than assuming, comes in.

But, let's look at each of the bullet points and expand on them:

  • Change SATA mode to AHCI in system configuration of my Dell Precision 7920 (BIOS system settings)
  • Enable Intel VMD in the system configuration

These should be straightforward as they are BIOS/EFI settings.

  • add "vmd" module to /etc/mkinitcpio.conf

Add the module vmd to the MODULES list, then run sudo mkinitcpio -P to regenerate all initramfs.

  • add nvme_load=YES

Edit /etc/default/grub and add nvme_load=YES to GRUB_CMDLINE_LINUX line, then regenerate the GRUB menu with sudo grub-mkconfig -o /boot/grub/grub.cfg .

7 Likes

Thanks @jonathon , I was typing mkinitcpio with small -p and not the capital -P, I just saw it like that in another thread, so in turn I typed mkinitcpio -g. So this time it worked!
Thank you so much for your quick responses and disposition.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.