ASUS Vivobook S14 + Garuda Linux

I just wanted to show that there seems to be an option for configuring this :slight_smile:

1 Like

A post was split to a new topic: KDFONTOP: Function not implemented

I just did, but the only change it's the UUID in the emergency shell (59d92e39-1e03-48ea-873c-e99ee81f6fa4). The problem persist.

setfont: KDFONTOP: Function not implemented
mount: /new_root: can't find UUID=4337a389-274a-4653-bf40-0978d3531c51
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]#

Do I need to run any commands in the emergency shell to get more information?

Did you chechk your /etc/fstab ?

1 Like

I think you could try the following:

  • use the USB and from there chroot into your system
  • run sudo micro /etc/mkinitcpio.conf
  • add the module vmd to the MODULES list
  • run sudo mkinitcpio -P to regenerate all initramfs
  • run sudo micro /etc/default/grub
  • add nvme_load=YES to GRUB_CMDLINE_LINUX line
  • run sudo grub-mkconfig -o /boot/grub/grub.cfg to regenerate the GRUB menu
  • reboot

I remember coming across that article, but although it is the same laptop, I think it is not the same model: mine has 16 Gb RAM, a 512 Gb SSD and no HDD.

When I read it I started looking inside the BIOS options, but no tab relates to what is described there. I don't have anything like "SATA mode" and in fact, I just rechecked before writing this to confirm that :pensive:

Oops, I'll correct it, I don't like spelling mistakes :nerd_face: :sweat_smile:

Yes, here you have:

Having done this:

It is no longer the dragon theme, but the same thing happens.

No, but I did it now.

[rootfs ]# cat /etc/fstab
[rootfs ]#

I don't know if it's even possible, but it seems empty.

I think you need to generate your fstab.

1 Like

I remember several cases in the past where the vmd module was loaded from the USB, so the installer was seeing the nvme disk, but not on the installed system, which was not seeing the nvme disk and fell onto rootfs.
That's why i suggested the procedure above.


You have to mount all partitions using the live cd of garuda.
Use this link to re gen your fstab


This isn't a issue it simply means the font you have selected isnt possible to load in tty

You have to verify what is the Boot mode setting (each vendor names it differently).
Garuda ISOs provide two boot entries, one for UEFI and one for Legacy. If you have a BIOS setting for Auto or other vendor smart option, this could be the reason.

If this is not AHCI, then this is the reason of your issue. Read the user manual about BIOS configuration extensively. If you can't find it, post a link to the manual.

There is an Advanced options menu at grub menu. Select it and boot the fallback kernel option (not the 1st entry). If you are lucky, it may boot normally (not many chances, but you may try).

At this point, press Esc key to see messages.
Provide feedback about them, even a photo may help.

From all the above suggestions, don't change the order. Start from the top and after finishing/verifying, only then go the next.


This is the reason why I think that the following is false

These details can be checked only directly or with the BIOS manual, but for sure, if this can be found e.g. in the BIOS advanced settings and set to AHCI, this would be the best thing, and I found a post where this was successful (although for a different model).
My previous suggestion instead, came from here.

I am trying things you have told me, but in the meantime I will leave this here:

My previus laptop:

My current laptop:

As mentioned around here, it's most likely all about AHCI, but I'm still trying to find a solution to change the SATA mode to AHCI, because that option I'm missing on the current laptop is what's bothering me :anger:

I'm trying to look for the BIOS manual for my laptop, but I'm not having much success because I'm only finding BIOS manuals for other models that evidently, don't match mine (although I might also be terrible at searching...) and on the other hand, the ASUS website doesn't offer much in the way of documentation directly: filtering by model in the documentation section and stuff :mag: :eye:

Ask the shop you purchased it from.

Have you checked submenus going deeper into each of them . For example the storage related stuff with intel rapid in your screenshot. Maybe they have it hidden under submenu's jargon name instead of data controller mostly it's realated to something storage controller

1 Like

Give it another week or so for kernels, etc. to work correctly. You can't always expect a brand new machine to work (or work well) right off the shelf. It usually takes the bits and pieces a little while to catch up. It's so common maybe others forgot to express this commonality. It could also be BIOS settings.

Remember--your new machine was built to run Windows. And it probably has a ton of security setting in the BIOS that you don't understand (MS does). Trusted Platform bullshit stuff. If your BIOS settings are anywhere close to what MS demands for Win 11, it is significant to note that those Win 11 "security" settings may not let your machine boot correctly in Linux, and maybe not at all (in Linux). MS doesn't want anyone using anything but Windows. Please also note that BIOS manufacturers may call those security settings something different than how MS references them. Mine does.


P.S. Have you tried other distributions?


Yes, and also with Manjaro, but unfortunately I had no luck :pensive:

Given my circumstances and following the last thing @c00ter said, I think the best and most optimal will be to use Kali on the laptop, for the time being.

However, I will continue to use Garuda on my desktop, so... :sunglasses:

Thanks to all of you for your help! I think I've learned a lot with the amount of information I've been looking for based on what you guys have been telling me. Hahahaha :joy:

See you around the forum! :black_heart::fire: