Accidently deleted Efi partition and reinstall do not solved issue

I had Garuda Linux in my half hard disk and rest was empty unallocated and I tried to install arch on rest half and deleted Efi partition by mistake and after that grub started giving error unknown file system and enter in to grub rescue. So I reinstalled Garuda with new grub to get boot option in newly installed grub to my old Garuda OS but it do not recognize my previously installed Garuda.

It's not possible that I deleted my old Garuda files because installing new Garuda I browsed to that old Garuda's partition and all files are there but their names start with '@' like '@root', '@home' etc.

Please help me to get back my old Garuda OS, it's really important. :pensive:

Well I hate to say it, but if the data was really important to you then you should have made backups first. This is exactly the reason we try to discourage dual boots, as data loss is always a possibility

You could try the program testdisk to recover your data.Testdisk is a terminal based data recovery software. There is plenty of documentation that is already existing for the testdisk program. As our forum is not a site dedicated to data recovery you're kind of on your own here as far as recovering data

Always remeber that every change you make to your drive lessens the possibility of data recovery.

Good luck.

Have you checked in grub menu for an entry of the old installation?

Without logs, no help is possible.

sudo inxi -Fxxxza
sudo parted -l
ls -Rl /boot/efi/*
cat /etc/fstab
lsblk -f
sudo blkid
efibootmgr -v

You may use garuda-chroot, after you gather required info of your real system status.


Thanks I successfully recovered the grub and can boot right in to Garuda. And from next time I will maintain backups :sweat_smile:. But still I'm facing a little issue. If I need to restore old snapshot from grub what I need to do? I selected last snapshot in grub's Garuda snapshots option but it takes me to a black screen with some written "You are currently in emergency mode.....".

Other wise it's working fine. But when I open konsole it just spit all errors on screen. So restoring old snapshot may solve the problem.

And sorry for late reply, Actually I was thinking I will get an Email notification for your reply.

like petsam wrote


If time :smiley: read


What is working fine?
If you can boot and use your new garuda installation, delete old snapshots and start over.
If something is not working, what is that?


No i mean I recovered my Efi partition and now my old Garuda Linux with important data is working fine but when I open terminal it gives me whole bunch of errors.

set: Variable name 'STARSHIP_SHELL=fish' is not valid. See `help identifiers`.

/tmp/.psub.FxvNDcgcqO (line 18): 
set -gx STARSHIP_SHELL="fish"
from sourcing file /tmp/.psub.FxvNDcgcqO
        called on line 16 of file ~/.config/fish/
from sourcing file ~/.config/fish/
        called during startup

(Type 'help set' for related documentation)
set: Variable name 'STARSHIP_SESSION_KEY=2337329275619183' is not valid. See `help identifiers`.

/tmp/.psub.FxvNDcgcqO (line 21): 
set -gx STARSHIP_SESSION_KEY=(random 10000000000000 9999999999999999)
from sourcing file /tmp/.psub.FxvNDcgcqO
        called on line 16 of file ~/.config/fish/
from sourcing file ~/.config/fish/
        called during startup

(Type 'help set' for related documentation)

Do it now!


OK thanks, that means I'm 100% innocent it's not because of my Efi. Thanks a lot for quick replies :sob:. You guys are really fast.
Soooo, I can take backup now. :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.