Manual intervention required: starship

Quick information about a little manual intervention required:
As starship-git (the new zsh/fish prompt) was hit by a bug its time to use the non -git version.
This will require you to press "y" to the starship-git removal prompt while running:

sudo pacman -Syu starship
10 Likes

Having customized zsh with p10k configure I get unslovable dependency conflict between starship and starship-git -- is it connected?

Since starship is included in the zsh config now itll get pulled.
Did you sudo pacman -Syu starship?

2 Likes

No, after installation of Garuda I just started p10k configure and everything went fine. Later at updating this conflict appears.

What exact error do you get? This shouldve been solved already :face_with_monocle:

2 Likes

I'm writing from my memory, but the message was something like: There is unsolvable dependency conflict between starship and starship-git. ZSH worked fine itself, but pacman -Syu ended with this message.

The problem is fixed since Yesterday. Just use

upd

Maybe not all mirror on last stand?

3 Likes

To confirm, if you haven't updated your package databases then you're not following the instructions in the announcement. :wink:

4 Likes

Yes, now it's fine.
Thanks!

What bug happened?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.