A little Help with Anbox

Now, please don't start on me that I haven't searched the Forum.
I try to follow this forum but linux-zen-anbox was taking forever to build.
I even checked with xanmod-anbox, which is in the chaotic AUR; but again Anbox won't start.

I checked the wiki: Anbox - ArchWiki
It says the 'linux-zen kernel includes the necessary modules'

And I tried this( while using linux-zen) ->

mkdir /dev/binderfs
mount -t binder binder /dev/binderfs

but again anbox won't launch, int worked flawlessly with manjaro though

I had earlier started a reddit post: https://www.reddit.com/r/GarudaLinux/comments/ly7o20/anbox_installed_from_chaoticaur_not_launching_nor/

but it didn't solve my issuse, since anbox is in chaotic-aur, It is reasonable that it should be provided with proper support and work flawlessly at Garuda. I wonder, how the package maintainer runs it.

Thank you

Are you sure you need it?
I use the zen kernel, a couple of weeks ago I tried installing ambox-git from chaotic-aur and followed exactly that guideline.
I remember that

modprobe -a binder-linux ashmem-linux

gave me an error, but I saw in another forum that it was not needed anymore (sorry I didn't take note of that site).
At least it was starting, the basic android apps started (for example I could reach google play with my account and install apps).
I gave up because the app I was interested in (Roblox, for my kids to get rid of windows for good) did not start...
Sorry I can't help you more than this, but at least for sure it was starting...

1 Like

So, you mean that Anbox at least starts somehow, but you forgot how you made it work.

Yes, following that wiki, no more no less.
No need to compile.
From installation onwards...

1 Like

Try using linux-xanmod-anbox to check if its a kernel issue, this one definitly got anbox support as I was using it myself when testing Anbox a while back.

2 Likes
sudo pacman -S linux-xanmod-anbox
[sudo] password for austin:      
error: target not found: linux-xanmod-anbox

It seams like it has been removed from chaotic-aur, and I don't want to build kernels from AUR, last time I did so, it took hours. And again I would have to wait same amount of time while updates

No, its in there. (just re-added it lol)

sudo pacman -Syu linux-xanmod-anbox linux-xanmod-anbox-headers

Your current database is not up to date, which is why -Syu is the "fix" in this case :wink:

1 Like

That really brought a smile on my face :grinning: :smile:

That was fast!

1 Like

Yeah now I have tried it again now,

  1. I install xanmod:
sudo pacman -Syu linux-xanmod-anbox linux-xanmod-anbox-headers
  1. Followed the instructions: Anbox - ArchWiki
  2. rebooted

Still Anbox is not launching

By the way, the new Plymouth is Fantastic.

Someone sent this to the Telegram group, forwarding to here.

4 Likes

It works now!,

I had simply missed these steps:

  1. Configure Networking:

sudo systemctl enable --now systemd-networkd

  1. Enable the Container Manager Service:

sudo systemctl enable --now anbox-container-manager.service

  1. Enable the Session Manager Service:

systemctl --user enable --now anbox-session-manager.service

These steps weren't explicitly given in the Arch wiki,
but RebornOS has clearly highlighted every step.

3 Likes

Works for me too, but with same results as with zen kernel: generally ok but not roblox, which was my objective.
Probably because the Android image is old, 7.1.
Never mind...

Thanks a lot!.
The case is solved

You mean it works with linux-zen.

Please, don't post like in chat groups, until nobody answered you can edit your post.

You can also change older posts if you want to add something.


Just click the heart :slight_smile:


Instead of these seven contributions, two would have sufficed. There are no prizes for frequent writers here. It just bloats the threads unnecessarily.

I really wonder what is not understandable about this sentence? :thinking:


So that it doesn't get any longer, I'll close here.

1 Like