Anbox Not Starting

Hey, I've been trying to install anbox on garuda d460nized dor a couple of days but to no luck, I've tried installing it by installing linux-zen-anbox-headers then linux-zen-anbox then "modprobe binder_linux ashmem-linux" which the first time didn't give anything but after reboot gave "modprobe: FATAL: Module binder_linux not found in directory /lib/modules/5.8.7-zen1-1-zen-anbox" then the android image and anbox-git, but to no luck. Can someone tell me what I'm doing wrong?

you dont need to install other kernels

linux-zen includes ashmen and binder modules by default

4 Likes

Anbox rarely works fir anyone.

I saw TKG has these modules as optional component listed, are they enabled by default in chaotic's builds (or linux-tkg-bmq only)?

Edit:

╰─λ sudo modprobe binder
modprobe: FATAL: Module binder not found in directory /lib/modules/5.9.12-97-tkg-bmq

So there is no support for these in TKG kernels. The anbox-modules-dkms-git also errors out dkms.

3 Likes

I tried installing it without installing linux-zen-anbox and linux-zen-headers also gave FATAL when I tried modprobe.

So I found a solution, after building zen-anbox kernel you need to do this
mkdir /dev/binderfs
mount -t binder binder /dev/binderfs
it still has some problems such as randomly crashing, and some apps not working, but thats a start

3 Likes

mkdir /dev/binderfs mount -t binder binder /dev/binderfs
mkdir: invalid option -- 't'
Try 'mkdir --help' for more information.

what to do?

mkdir and mount are different commands on two different lines.

1 Like