XWayland not (really) working

Since I updated to KDE 5.25, I can't get XWayland to work properly anymore, if I login with SDDM in a Plasma (Wayland) session, I can't start any Programs that only work with X11, Steam says I should check my DISPLAY env variable and make sure X is enabled, Spotify doesn't start at all.

When I try to launch a nested wayland session, I get this output:

$ dbus-run-session kwin_wayland
No backend specified through command line argument, trying auto resolution
unable to lock lockfile /run/user/1000/wayland-0.lock, maybe another compositor is running
kwin_core: Failed to take control of /org/freedesktop/login1/session/_32 session. Maybe another compositor is running?
kwin_wayland_drm: failed to open drm device at "/dev/dri/card0"
kwin_wayland_drm: failed to open drm device at "/dev/dri/card1"
kwin_wayland_drm: No suitable DRM devices have been found

I've searched around a bit about the "failed to open drm device" issue and found this: https://forum.garudalinux.org/t/switching-to-wayland-failed-to-open-drm-device-at-dev-dri-card0/14738, but they just reinstalled Garuda in the end.

dbus-run-session startplasma-wayland &> interesting.log:https://bin.garudalinux.org/?6300920f9e2fce99#GTZtMyjnvwJqKQ7RXM7vXNLUxyDSzLHfhkw4VSaN3pfG

Kernel: 5.18.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=ed7d29e6-cb8d-43b9-8031-6acbb474bc2d
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 amdgpu.ppfeaturemask=0xffffffff
Console: pty pts/0 (vt 2) DM: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: Z690 GAMING X DDR4 v: x.x serial: <superuser required>
UEFI: American Megatrends LLC. v: F6 date: 12/17/2021
Info: model: 12th Gen Intel Core i5-12600K bits: 64 type: MST AMCP arch: Alder Lake
gen: core 12 built: 2021 process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 2
microcode: 0x1F
Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled cache: L1: 864 KiB
desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB
L3: 20 MiB desc: 1x20 MiB
Speed (MHz): avg: 3939 high: 4500 min/max: 800/4900:3600 scaling: driver: intel_pstate
governor: performance cores: 1: 4184 2: 3847 3: 4476 4: 4479 5: 4392 6: 4499 7: 3769 8: 3832
9: 4064 10: 4418 11: 4334 12: 4500 13: 3271 14: 3107 15: 3122 16: 2732 bogomips: 117964
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel AlderLake-S GT1 vendor: Gigabyte driver: i915 v: kernel ports: active: none
empty: DP-4,HDMI-A-2,HDMI-A-3 bus-ID: 00:02.0 chip-ID: 8086:4680 class-ID: 0380
Device-2: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M] vendor: Micro-Star MSI
driver: amdgpu v: kernel arch: RDNA 2 process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 03:00.0
chip-ID: 1002:73df class-ID: 0300
Display: wayland server: X.org v: with: Xwayland v: 22.1.2 compositor: kwin_wayland
driver: X: loaded: amdgpu gpu: amdgpu tty: 119x28
Monitor-1: DP-3 model: AOC 2275W serial: <filter> built: 2016 res: 1920x1080 dpi: 102
gamma: 1.2 size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes: max: 1920x1080
min: 720x400
Monitor-2: HDMI-A-1 model: Acer ED322Q A serial: <filter> built: 2020 res: 1920x1080 dpi: 70
gamma: 1.2 size: 531x299mm (20.91x11.77") diag: 801mm (31.5") ratio: 16:9 modes: max: 1920x1080
min: 720x400
Message: Wayland GBM/EGL data currently not available.
Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte driver: snd_hda_intel bus-ID: 1-7:2
v: kernel chip-ID: 0dba:3000 alternate: snd_sof_pci_intel_tgl class-ID: 0102 bus-ID: 00:1f.3
chip-ID: 8086:7ad0 class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-3: Digidesign Mbox 2 type: USB driver: snd-usb-audio
Sound Server-1: ALSA v: k5.18.5-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: PulseAudio v: 16.0 running: no
Sound Server-4: PipeWire v: 0.3.52 running: yes
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Local Storage: total: 7.06 TiB used: 857.1 GiB (11.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA050 size: 465.76 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A7C0
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD60EZAZ-00SF3B0 size: 5.46 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0A80 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: MZ7LN256HMJP-000H1 size: 238.47 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 1H3Q scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 860 QVO 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q
scheme: GPT
ID-1: / raw-size: 191.11 GiB size: 191.11 GiB (100.00%) used: 110.79 GiB (58.0%) fs: btrfs
dev: /dev/sdc2 maj-min: 8:34
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat
dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%) used: 746.31 GiB (80.1%)
fs: btrfs dev: /dev/sdd1 maj-min: 8:49
ID-4: /var/log raw-size: 191.11 GiB size: 191.11 GiB (100.00%) used: 110.79 GiB (58.0%)
fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-5: /var/tmp raw-size: 191.11 GiB size: 191.11 GiB (100.00%) used: 110.79 GiB (58.0%)
fs: btrfs dev: /dev/sdc2 maj-min: 8:34
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.13 GiB used: 1.2 MiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 46.87 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdc3
maj-min: 8:35
System Temperatures: cpu: 27.8 C mobo: 16.8 C gpu: amdgpu temp: 48.0 C mem: 42.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Processes: 388 Uptime: 9m wakeups: 0 Memory: 31.13 GiB used: 6.33 GiB (20.3%) Init: systemd
v: 251 default: graphical tool: systemctl Compilers: gcc: 12.1.0 alt: 10 clang: 13.0.1
Packages: 2377 pacman: 2372 lib: 567 flatpak: 5 Shell: fish v: 3.4.1
running-in: pty pts/0 (vt 2) inxi: 3.3.18
Garuda (2.6.4-1):
System install date:     2021-07-26
Last full system update: 2022-06-22
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Timeshift (maybe)
Failed units:            fancontrol.service systemd-networkd-wait-online.service

Also, (probably the reason why systemd-networkd-wait-online.service failed) vmware (I think because of some vmware virtual network stuff) is broken since Kernel 5.18, works fine with 5.17 though

Having to reinstall Garuda would kinda suck because I have a lot of Programs installed, reinstalling all of them would be kind of a lot of pain

You can restore a snapshot instead of reinstalling. See the BTRFS assistant program preinstalled on Garuda.

I unfortunately don't have any snapshots left from before :frowning: (At least when I looked in timeshift)

Please post input and output from

sudo timeshift --list
Mounted '/dev/sdc2' at '/run/timeshift/121665/backup'
Device : /dev/sdc2
UUID   : ed7d29e6-cb8d-43b9-8031-6acbb474bc2d
Path   : /run/timeshift/121665/backup
Mode   : BTRFS
Status : OK
12 snapshots, 85.1 GB free

Num     Name                 Tags  Description
0    >  2022-06-20_16-25-07  O     {timeshift-autosnap} {created before upgrade}
1    >  2022-06-21_18-06-16  O     {timeshift-autosnap} {created before upgrade}
2    >  2022-06-21_20-00-01  D
3    >  2022-06-21_23-39-04  O     {timeshift-autosnap} {created before upgrade}
4    >  2022-06-22_00-04-58  O     {timeshift-autosnap} {created before upgrade}
5    >  2022-06-22_16-41-10  O     {timeshift-autosnap} {created before upgrade}
6    >  2022-06-22_17-00-02  B
7    >  2022-06-22_17-01-35  O
8    >  2022-06-22_17-01-46  O     Before restoring '2022-06-20 16:25:07'
9    >  2022-06-22_17-07-13  O     Before restoring '2022-06-22 17:01:46'
10   >  2022-06-22_17-17-56  B
11   >  2022-06-22_20-00-01  D

Found stale mount for device '/dev/sdc2' at path '/run/timeshift/121665/backup'
Unmounted successfully

There are many/one

Already tried booting into it, it has the same issue, I'll check in a bit which KWin version it has

I just started logged in from a tty, started dbus-run-session startplasma-wayland, and it seems to work mostly fine, some icons are wrong and the context menu in latte dock for spotify doesn't work, but I guess these Errors will also be resolved soon. Thanks for all the suggestions on what I could do!

To anyone reading this in the future: I'm sorry, I have no f*cking idea what exactly was wrong and what fixed it...

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.