Write on file's SSD NTFS not working

System:
Kernel: 5.16.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=65c8057b-c1c9-474d-b0a8-afea04b74f7a rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=3e097011-097f-4518-b152-15f3e632faef loglevel=3
Console: pty pts/2 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: Micro-Star product: GP75 Leopard 9SD v: REV:1.0
serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: Micro-Star model: MS-17E2 v: REV:1.0 serial: <filter>
UEFI: American Megatrends v: E17E2IMS.10E date: 03/28/2019
Battery:
ID-1: BAT1 charge: 38.0 Wh (99.0%) condition: 38.4/51.6 Wh (74.5%)
volts: 12.0 min: 10.9 model: MSI BIF0_9 type: Li-ion serial: N/A
status: N/A
CPU:
Info: model: Intel Core i7-9750H socket: BGA1440 (U3E1) note: check
bits: 64 type: MT MCP arch: Coffee Lake family: 6 model-id: 0x9E (158)
stepping: 0xA (10) microcode: 0xEA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 3048 high: 3891 min/max: 800/4500 base/boost: 3960/8300
scaling: driver: intel_pstate governor: powersave volts: 1.2 V
ext-clock: 100 MHz cores: 1: 2928 2: 2889 3: 3340 4: 2827 5: 2539 6: 3633
7: 3775 8: 3891 9: 3579 10: 3802 11: 1773 12: 1606 bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]
vendor: Micro-Star MSI driver: nouveau v: kernel bus-ID: 01:00.0
chip-ID: 10de:2191 class-ID: 0300
Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:5
chip-ID: 5986:211c class-ID: 0e02
Display: server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: intel,modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 144 dpi: 128
size: 380x210mm (15.0x8.3") diag: 434mm (17.1")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:1aeb
class-ID: 0403
Sound Server-1: ALSA v: k5.16.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel port: 3000 bus-ID: 05:00.0
chip-ID: 1969:e0a1 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.61 TiB used: 621.09 GiB (37.7%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power
model: SPCC M.2 PCIe SSD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: ECFM22.5 temp: 27.9 C scheme: GPT
SMART: yes health: PASSED on: 263d 1h cycles: 2,374
read-units: 1,818,720 [931 GB] written-units: 9,539,312 [4.88 TB]
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Kingston
model: RBUSNS8154P3256GJ size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: E8FK11.C temp: 35.9 C scheme: GPT
SMART: yes health: PASSED on: 104d 18h cycles: 2,695
read-units: 27,242,249 [13.9 TB] written-units: 33,965,336 [17.3 TB]
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
family: Barracuda Pro Compute size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: SDM1 temp: 33 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 280d 11h cycles: 2682
read: 15.45 TiB written: 10.91 TiB Pre-Fail: attribute: Spin_Retry_Count
value: 100 worst: 100 threshold: 97
Partition:
ID-1: / raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 55.27 GiB (12.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 55.27 GiB (12.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 55.27 GiB (12.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 55.27 GiB (12.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.96 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 46.0 C pch: 48.0 C mobo: N/A gpu: nouveau
temp: 31.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 0
Info:
Processes: 353 Uptime: 30m wakeups: 1 Memory: 15.42 GiB
used: 3.3 GiB (21.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1613 lib: 375
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda:
System install date:     2022-01-20
Last full system update: 2022-01-30
Is partially upgraded:   No
Using TLP:               No
Windows dual boot:       Yes
Snapshots:             Snapper

Hello every good people that want to help.
In MSI i have 3 SSD: 1 for win10, one for linux and one for files and personal data. The last one is in NTFS, don't know why i can't write on it. I would to edit my files with linux. Yes: i installed all types of "root actions" from Dolphin, and also from terminal, i used also nemo, konqueror, double commander, nautilus ecc, it seems that i have no permission. I can't change any type of permission, tried also with terminal, i have the "only read" don't know why. For 2 times in one month, when i started Garuda i could modify the SSD data files, in this two time i installed and unistalled more times the kde-rootaction-service or somethink like that. Can someone say me something?
Oh, i also tried to change mount point, this can be a solution?

Can you share the output of findmnt --real

It is probably the way device is mounted or because you haven't disabled fast startup in windows

1 Like

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

I edit your post :slight_smile:

Seems two User has the solution for you :slight_smile:

Try this ntfd-3g package. I've never used it, but it appears to include some thoughtful features like allowing the use of Linux compatible permissions and helping auto-mount with /etc/fstab.

TARGET               SOURCE                  FSTYPE     OPTIONS
/                    /dev/nvme0n1p2[/@]      btrfs      rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefr
├─/run/user/1000/doc portal                  fuse.porta rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
├─/run/media/sandiotseun/Roby
│                    /dev/sda1               fuseblk    ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_
├─/boot/efi          /dev/nvme0n1p1          vfat       rw,relatime,fmask=0077,dmask=0077,codepage=437,iochars
├─/srv               /dev/nvme0n1p2[/@srv]   btrfs      rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefr
├─/home              /dev/nvme0n1p2[/@home]  btrfs      rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefr
├─/root              /dev/nvme0n1p2[/@root]  btrfs      rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefr
├─/var/tmp           /dev/nvme0n1p2[/@tmp]   btrfs      rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefr
├─/var/cache         /dev/nvme0n1p2[/@cache] btrfs      rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefr
└─/var/log           /dev/nvme0n1p2[/@log]   btrfs      rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefr

I try now to check the fast boot, thank you, what means the way mounted? Sorry, i'm not so good in english.

Oh, okay, thank you for the editing, i will remember this in future

1 Like

I alredy installed it, some ntfd-3d commands don't work, others do nothing... :sweat_smile: i try again, thanks

That output is all cut off. You may need to run it in a bigger terminal.

In Windows, there is a setting called "Fast Startup". If you don't disable it, it leaves the disks dirty and Linux will mount them read-only. If you haven't disabled it yet, that should be your first stop.

Boot into Windows, change that setting and then shutdown and boot back into Linux.

2 Likes
TARGET                        SOURCE                  FSTYPE      OPTIONS
/                             /dev/nvme0n1p2[/@]      btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=494,subvol=/@
├─/run/user/1000/doc          portal                  fuse.portal rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
├─/run/media/sandiotseun/Roby /dev/sda1               fuseblk     ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096
├─/var/tmp                    /dev/nvme0n1p2[/@tmp]   btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=262,subvol=/@tmp
├─/var/cache                  /dev/nvme0n1p2[/@cache] btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=260,subvol=/@cache
├─/var/log                    /dev/nvme0n1p2[/@log]   btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=261,subvol=/@log
├─/home                       /dev/nvme0n1p2[/@home]  btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=257,subvol=/@home
├─/srv                        /dev/nvme0n1p2[/@srv]   btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=259,subvol=/@srv
├─/root                       /dev/nvme0n1p2[/@root]  btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,autodefrag,subvolid=258,subvol=/@root
└─/boot/efi                   /dev/nvme0n1p1          vfat        rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro

sorry for the prev messagge cutted
this setting is already off

What applies to inxi also applies to all other terminal outputs.

Is it this one?

If so, it is being mounted as root.

There are many ways to change this but my recommendation would be to add an entry in /etc/fstab to mount it permanently with the appropriate permissions.

You can use this example from the Arch wiki as a template

/dev/*NTFS-partition* /mnt/windows ntfs-3g uid=username,gid=username,dmask=022,fmask=133 0 0

Replace username with your actual username.

4 Likes

I activated this option, reboot, deactivated, boot garuda, and FOR NOW, it works, i say for now cause it happends other 2 times in past, after few days the problem come back

1 Like

Now i'll do also this change, it can be useful. THANK YOU SO MUCH.

That is probably because with "Fast Startup" enabled Windows may or may not leave the disks dirty. Turning it off should fix the issue.

2 Likes

Please, if it works after two days and more, mark the solution by dalto. :slight_smile:

2 Likes

I advise using the windows_names mount option too, it's easy to damage an NTFS filesystem with a "funny" filename (like, including a forbidden character, e.g. a :).
man mount.ntfs-3g for details.

1 Like

Very useful, i didn't know that, thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.