You are not authorized to mount this device [External HDD]

I am using Garuda dragonized gaming edition. I use an external hdd to backup my files. I have used this device in this os previously without any problem. But today I installed latest version of this os and I am facing a problem. My usb hdd is in read-only mode and the os does not let me write in it. Whenever I plug in the device to my pc the notification says, "You are not authorized to mount this device." I am new in linux and been using garuda for last three months. In my last install the device never cause any trouble but is showing the above message now and it has stopped my work process. Please provide a proper solution so that I do not have to format the device cause it contains around 900 GB of data. I have tried few of the existing solutions in this forum but no luck. The device is /sdb. Please help.

sudo fdisk -l       

Disk /dev/sda: 223.57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: TS240GSSD220S   
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: B72871DA-FE2D-9246-94AC-7EBC9D002653

Device      Start       End   Sectors   Size Type
/dev/sda1    4096    618495    614400   300M EFI System
/dev/sda2  618496 468857024 468238529 223.3G Linux filesystem

Disk /dev/sdb: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: Transcend
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xf1d12b96

Device     Boot Start        End    Sectors   Size Id Type
/dev/sdb1  *       64 1953520063 1953520000 931.5G  7 HPFS/NTFS/exFAT

Disk /dev/zram0: 15.57 GiB, 16717447168 bytes, 4081408 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Kernel: 5.16.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: Z370 HD3 v: N/A
serial: <superuser required>
Mobo: Gigabyte model: Z370 HD3-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F13 date: 08/13/2019
Info: model: Intel Core i5-8400 bits: 64 type: MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 3941 high: 3989 min/max: 800/4000 scaling:
driver: intel_pstate governor: performance cores: 1: 3943 2: 3903 3: 3976
4: 3989 5: 3894 6: 3944 bogomips: 33599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Gigabyte
driver: nouveau v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 3 speed: 8 GT/s ports: active: HDMI-A-3
empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2 bus-ID: 01:00.0
chip-ID: 10de:1c03 class-ID: 0300
Device-2: Microdia Webcam Vitade AF type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-3:3 chip-ID: 0c45:6366
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa gpu: nouveau
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-3 mapped: HDMI-A-3 model: HP 22er serial: <filter>
built: 2017 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 476x268mm (18.7x10.6") diag: 583mm (23") ratio: 15:9 or 16/10
modes: max: 1920x1080 min: 720x400
OpenGL: renderer: NV136 v: 4.3 Mesa 21.3.7 direct render: Yes
Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f1
class-ID: 0403
Device-3: Microdia Webcam Vitade AF type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-3:3 chip-ID: 0c45:6366
class-ID: 0102 serial: <filter>
Device-4: Kingston HyperX Cloud Stinger Core Wireless + 7.1 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:4 chip-ID: 0951:170b
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.16.14-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Local Storage: total: 1.13 TiB used: 670.21 GiB (58.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Transcend model: TS240GSSD220S
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 71.1 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate
model: ST1000LM024 HN-M101MBB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: MBR
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 27.8 C mobo: 16.8 C gpu: nouveau temp: 44.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 800
Processes: 265 Uptime: 3m wakeups: 0 Memory: 15.57 GiB
used: 1.61 GiB (10.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1736 lib: 511 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-15
Last full system update: 2022-03-15
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

If you are dual booting with Windows, the first thing you should do is fire up Windows and make sure that Windows fast boot (or whatever it is called) is disabled so the machine can be properly shut down. The quick boot option keeps the disks mounted somehow.

It would be helpful if you were more specific about what you have already tried and the results of those efforts.


Hi. Thanks for replying. I'm not using windows or dual boot. Even my bios has been reset to default after installing garuda. I have only one ssd drive inside my machine and I only use garuda. Well, I've tried this solution from archlinux website ( but nothing happened. Also tried a few commands which is in garuda forum like sudo parted -l but it gets stuck. Fast boot from my bios is disabled and there is no safe/secure boot option over there.

cat /etc/fstab
sudo blkid

sdb Transcend is my usb hdd.

cat /etc/fstab
File: /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=7DF3-82DA                            /boot/efi      vfat    umask=0077 0 2
UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 /              btrfs   subvol=/@,defaults,noatime,autodefrag,compres
s=zstd,discard=async,ssd 0 0
UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 /home          btrfs   subvol=/@home,defaults,noatime,autodefrag,com
press=zstd,discard=async,ssd 0 0
UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 /root          btrfs   subvol=/@root,defaults,noatime,autodefrag,com
press=zstd,discard=async,ssd 0 0
UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 /srv           btrfs   subvol=/@srv,defaults,noatime,autodefrag,comp
ress=zstd,discard=async,ssd 0 0
UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 /var/cache     btrfs   subvol=/@cache,defaults,noatime,autodefrag,co
mpress=zstd,discard=async,ssd 0 0
UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 /var/log       btrfs   subvol=/@log,defaults,noatime,autodefrag,comp
ress=zstd,discard=async,ssd 0 0
UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,autodefrag,comp
ress=zstd,discard=async,ssd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
sda      8:0    0 223.6G  0 disk
├─sda1   8:1    0   300M  0 part /boot/efi
└─sda2   8:2    0 223.3G  0 part /var/tmp
sdb      8:16   0 931.5G  0 disk
└─sdb1   8:17   0 931.5G  0 part /run/media/antik/Transcend
zram0  254:0    0  15.6G  0 disk [SWAP]
sudo blkid

/dev/sda2: UUID="22d356d9-8602-4ffa-af8f-150a79ea6337" UUID_SUB="6a5f30dd-bc7e-4ca1-b162-7f7faf327630" BLOCK_S
IZE="4096" TYPE="btrfs" PARTLABEL="root" PARTUUID="ab4710eb-8f79-4647-9438-c9bae4cd4240"
/dev/sdb1: LABEL="Transcend" BLOCK_SIZE="512" UUID="3656C74656C70619" TYPE="ntfs" PARTUUID="f1d12b96-01"
/dev/zram0: LABEL="zram0" UUID="19f47e6f-e169-42ea-848c-a5b6bae5aaf4" TYPE="swap"

NTFS filesystems need to be mounted a specific way. Often people are successful adding a special entry for it in /etc/fstab, but be mindful that often times you need to be specific about permissions while writing the entry.

Here is an example of an entry from Arch Wiki:

/dev/*NTFS-partition* /mnt/windows ntfs-3g uid=username,gid=username,dmask=022,fmask=133 0 0

Here is where you can learn more about this: NTFS-3G - ArchWiki

Here is an example of another thread where a similar solution was discussed: Write on file's SSD NTFS not working - #11 by dalto


I do not understand where to write this line. Can you please specify what and where to write? Because I am pretty much a new user in linux and it is not clear to me.

sudo micro /etc/fstab

It is important you have the entry exactly right before you save.


Maybe use kate, it's a little easier than micro, but micro is the best cli, for me.
kate ask about root password if you try to save the file, do not start with sudo!

1 Like

So I put this line

/dev/*NTFS-partition* /mnt/windows ntfs-3g uid=username,gid=username,dmask=022,fmask=133 0 0

just below this?
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

Dos not matter, use last line :slight_smile:

1 Like

So I pasted

/dev/*NTFS-partition* /mnt/windows ntfs-3g uid=username,gid=username,dmask=022,fmask=133 0 0

at the last line by replacing "username" to my os username, saved and reboot, my system broke and went to maintenance mode. I removed the line and then reboot and got back to the os.
It showed something like failed dependency /mnt/windows

You do not change to the path?

1 Like

No. My bad :grin:. So, I put lsblk above. Now, do I put /run/media/antik/Transcend or I put /dev/sdb or /dev/sdb1 ?

Try :slight_smile: :slight_smile:


I put

/dev/sdb1 /mnt/windows ntfs-3g uid=username,gid=username,dmask=022,fmask=133 0 0

Again breaks the system. I did put the real username of my os account.

setfont: KDFONTOP: Function not implemented
[FAILED] Failed to mount /mnt/windows.
[DEPEND] Dependency failed for Local File Systems.
[ OK ] Finished Create Volatile Files and Directories.

And again goes into the maintenance mode.

Did you make that directory first?

sudo mkdir /mnt/windows

1 Like

It already exists.

Can you post lsblk -f?

Maybe try without dmask and fmask too.

/dev/sdb1 /mnt/windows ntfs-3g uid=username,gid=username 0 0
lsblk -f
├─sda1 vfat   FAT32 NO_LABEL  7DF3-82DA                             298.8M     0% /boot/efi
└─sda2 btrfs                  22d356d9-8602-4ffa-af8f-150a79ea6337  191.4G    14% /var/tmp
└─sdb1 ntfs3        Transcend 3656C74656C70619
zram0                                                                             [SWAP]