Windows & Garuda dual boot borked

https://forum.garudalinux.org/t/grub-rescue-issue-cant-solve/17296

Now the problem got much more it doesn't show the garuda linux and windows 10 also

And sorry for bothering

Snapshots are empty?

We need no pictures !!!

Again.

The lost of power destroy grub, maybe more
(like fstab? You do not answer my question),
if some fixes let you boot, you never know if something more is broken. It's risky.

You can't chroot, so, you can't restore anything, sad, but we can't change it.

Best is clean, fresh installation.

3 Likes

No this after installing garuda again

And have snap shots now but i wanna boot in to the system not in the snapshot and i have windows 10 installed but it doesn't appear here

And when i open the snapshot it gave me this massage

Configuration file "var/lib/sddm/.config/sddm-greeterrc" not writable

As long as no one has replied to your post, you can edit it, this isn't chat.
All possible solutions are in the post linked above.
So a "reinstall" without Garuda and only with existing snapshots I think is unlikely.

1 Like

so some how i managed to solve all my problems but I'm stuck with that i can't mount or identify windows 10 in grub it doesn't want to show up
so what i have to do?

Could you please post

sudo fdisk -l
lsblk -f
╭─[email protected] in ~ took 49s
╰─λ sudo fdisk -l
[sudo] password for avatar_tech:
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10SPZX-00Z
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xa01d6bb2

Device     Boot      Start        End    Sectors   Size Id Type
/dev/sda1             2048  214011903  214009856   102G 83 Linux
/dev/sda2  *     214011904  648120319  434108416   207G  7 HPFS/NTFS/exFAT
/dev/sda3        648124353 1953519088 1305394736 622.5G  f W95 Ext'd (LBA)
/dev/sda5        648124416 1083183103  435058688 207.5G  7 HPFS/NTFS/exFAT
/dev/sda6       1083185152 1518348287  435163136 207.5G  7 HPFS/NTFS/exFAT
/dev/sda7       1518351408 1953519088  435167681 207.5G  7 HPFS/NTFS/exFAT

Partition 3 does not start on physical sector boundary.


Disk /dev/zram0: 3.74 GiB, 4020240384 bytes, 981504 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Which one of those partitions is your windows system partition?
Can you see (and open) them from Dolphin (or the file manager of your edition)?

1 Like

the second one

You said you already tried to mount it without success, right?
If so, maybe you could install ntfs-3g and try mounting again.
If it succeeds to mount, you can try sudo os-prober to see if now windows is listed, and if so, sudo update-grub.

1 Like

ok i will try it now

So i tried that didn't work
Or maybe i make it wrong

somehow it's still doesn't want to mount it

╭─[email protected] in ~ took 334ms
[πŸ”΄] Γ— sudo mount -t ntfs-3g -o ro /dev/sda2 /media/windows
Corrupted file $UpCase
Failed to mount '/dev/sda2': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

and when i do sudo os-prober it shows that and I don't have arch linux in the first place

╭─[email protected] in ~ took 164ms
[πŸ”΄] Γ— sudo os-prober
/dev/sda1:Arch Linux:Arch:linux:btrfs:UUID=06382bc9-688d-4cb0-bbbc-8a5bae21959f:[email protected]_124724264

i have a flash usb already burned an iso file of windows is there any commands that i can write there?

Quite frankly I've never seen that error before.
At a quick internet search some people say they solved it as suggested in the error, booting into windows (you should be able to select it from the BIOS/UEFI), running chkdsk /f and rebooting twice.
Others suggest using

sudo ntfsfix /dev/sda2

But this is only something read. Never had to do it.

you should be able to select it from the BIOS/UEFI

You can’t because Garuda Linux is installed in MBR/BIOS mode.
fdisk -l tells disklabel: dos
Try manually booting Windows from GRUB command line. When you see Garuda boot menu, hit β€œC” and type these:

chainloader (hd0,msdos2)+1
boot

If windows boots,disable hibernation , disable fast startup and reboot (don’t shutdown) .
This time, boot to Garuda and try mounting your windows partition. If it works, try probing for windows:

sudo os-prober
sudo grub-mkconfig -o /boot/grub/grub.cfg

that what i got

╭─[email protected] in ~ took 32s
╰─λ sudo ntfsfix /dev/sda2
[sudo] password for avatar_tech:
Mounting volume... Corrupted file $UpCase
FAILED
Attempting to correct errors...
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Corrupted file $UpCase
Rewriting $UpCase file
$UpCase has been set to default
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda2 was processed successfully.

╭─[email protected] in ~ took 6s
╰─λ sudo ntfsfix /dev/sda2
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda2 was processed successfully.

Can you post your

garuda-inxi

please

as most things suggested should work

2 Likes

It seems that something was corrected.
Could you also please check if the partition can be mounted and if it is seen by the os-prober?

2 Likes

that is it

─[email protected] in ~ 
╰─λ garuda-inxi
System:
Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=06382bc9-688d-4cb0-bbbc-8a5bae21959f rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.24.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: FUJITSU product: LIFEBOOK AH531 v: N/A
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: FUJITSU model: FJNBB0F serial: <superuser required>
UEFI-[Legacy]: FUJITSU // Phoenix v: 1.32 date: 10/01/2018
Battery:
ID-1: BAT1 charge: 0% condition: N/A/47.5 Wh volts: 10.8 min: 10.8
model: SIMPLO AS10B7E type: Li-ion serial: <filter> status: N/A
CPU:
Info: model: Intel Celeron B800 bits: 64 type: MCP arch: Sandy Bridge
family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 2 MiB
desc: 1x2 MiB
Speed (MHz): avg: 856 high: 900 min/max: 800/1500 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 812 2: 900
bogomips: 5986
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Fujitsu Limited. driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0106 class-ID: 0300
Device-2: Chicony Fujitsu Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-1.3:3 chip-ID: 04f2:b213 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 2726x768 s-dpi: 96 s-size: 720x203mm (28.3x8.0")
s-diag: 748mm (29.5")
Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102
size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
Monitor-2: VGA1 res: 1360x768 hz: 60 dpi: 84 size: 410x230mm (16.1x9.1")
diag: 470mm (18.5")
OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1)
v: 3.3 Mesa 21.3.6 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Fujitsu Limited. driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi
v: kernel bus-ID: 01:00.0 chip-ID: 8086:008a class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Fujitsu Limited. driver: r8169 v: kernel port: 2000 bus-ID: 07:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB
driver: btusb v: 0.8 bus-ID: 2-1.4:5 chip-ID: 8086:0189 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 42.52 GiB (4.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-00Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: MBR
Partition:
ID-1: / raw-size: 102.05 GiB size: 102.05 GiB (100.00%)
used: 42.52 GiB (41.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 102.05 GiB size: 102.05 GiB (100.00%)
used: 42.52 GiB (41.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 102.05 GiB size: 102.05 GiB (100.00%)
used: 42.52 GiB (41.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 102.05 GiB size: 102.05 GiB (100.00%)
used: 42.52 GiB (41.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.74 GiB used: 234 MiB (6.1%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 46.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 218 Uptime: 6m wakeups: 1 Memory: 3.74 GiB
used: 2.37 GiB (63.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 2177 lib: 407 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-02-09
Last full system update: 2022-02-19
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper (maybe)
Failed units:            systemd-networkd-wait-online.service

thanks man i did it but after i wrote the chainloader command and boot
it just gave me back screen and negative code thing on the top left of the screen i waited for it a little but it didn't change