Window transparency in themes not working

Hello.

when i was using opensuse with kde plasma i used desktop themes like gently which have transparent windows. (https://images.pling.com/img/00/00/49/90/47/1293160/aa68ea1bc577c068c7d25857b5b8c9601ab70fa2fbf854a2e3fecdb69464d52ce2c8.jpg)

i install those themes in garuda but there's no transparency.

whats going on? how can i enable it? i see i can change transparency on individual windows manually so i suppose the dependencies are installed.

ty.

Can you provide your inxi -Faz please?
Also your screen shoot has nothing to do with firedragon?

4 Likes

Is your compositor running?

4 Likes

Have you tried to play around with the "translucency" in the desktop effects?

3 Likes

I move it from #issues-assistance:firedragon-browser-support to #issues-assistance:kde

And, please, post your

inxi -Faz
5 Likes

@tbg @filo @SGS

thank you for answering. I labelled the topic as firedragon by accident. I'm sorry.

Here's my inxi -Faz output. I wanted to upload a pic but I can't because I'm new. Still the problem is that all the transparencies shown in the pic I loaded are absent in my computer.

Thank you.

λ inxi -Faz
System:
Kernel: 5.16.0-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7827330e-2ebc-4c54-b595-5fd702fe4502 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Server System: BESSTAR TECH LIMITED product: X400 v: N/A
serial: <superuser required>
Mobo: BESSTAR TECH model: ATB15 serial: <superuser required>
UEFI: American Megatrends v: ATB15016 date: 09/23/2021
CPU:
Info: model: AMD Ryzen 5 PRO 4650G with Radeon Graphics bits: 64
type: MT MCP arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600106
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 3141 high: 4296 min/max: 1400/3700 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2994 2: 2921
3: 3604 4: 3239 5: 2908 6: 2974 7: 4296 8: 2956 9: 2966 10: 2994 11: 2917
12: 2932 bogomips: 88633
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Renoir driver: amdgpu v: kernel bus-ID: 05:00.0
chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 96
size: 509x286mm (20.0x11.3") diag: 584mm (23")
OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.0-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.4 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Conexant Systems
driver: snd_hda_intel v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.16.0-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel port: f000 bus-ID: 02:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-1:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 0 state: down
bt-service: disabled rfk-block: hardware: no software: yes address: N/A
Drives:
Local Storage: total: 238.47 GiB used: 28 GiB (11.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3256B-A01
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: EDFK0S03
temp: 40.9 C scheme: GPT
Partition:
ID-1: / raw-size: 154.8 GiB size: 154.8 GiB (100.00%)
used: 27.98 GiB (18.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.6 MiB (26.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 154.8 GiB size: 154.8 GiB (100.00%)
used: 27.98 GiB (18.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 154.8 GiB size: 154.8 GiB (100.00%)
used: 27.98 GiB (18.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 154.8 GiB size: 154.8 GiB (100.00%)
used: 27.98 GiB (18.1%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.61 GiB used: 2.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 24.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 352 Uptime: 54m wakeups: 0 Memory: 13.61 GiB
used: 4.43 GiB (32.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1931 lib: 565 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.11

Have you tried also to disable blur background in desktop effects?

3 Likes

yes. it was disabled orginally but the system stays the same whether i disable or enable it.

i tried this, so i assume it is?


[email protected] in ~ took 93ms
λ glxinfo | grep '^direct rendering:'
direct rendering: Yes

[email protected] in ~ took 89ms
λ

You can open System Settings and search for compositor.
In general you can toggle it on and off with alt+shift+f12, but in the compositor screen you can also play with the relevant settings.
Additionally, if it crashed, it shows there an error message (e.g. "OpenGL compositing (the default) has crashed KWin in the past..."), and if so you can reset the protection / acknowledge it.

2 Likes

I have another idea, but consider that I'm not using your "gently" theme, and this stuff is theme dependent.
I never played around with transparency in the past.
With the standard "sweetified plasma" theme I think I managed to get to something similar to your expectations:

  • Removing the "inactive blur" wallpaper plugin. As far as I know this can be done only manually removing a folder like mentioned here
  • unflagging/deactivating Blur in the Desktop Effects

In addition to that, it might be necessary (again depending on what you have in your system) to find a suitable GTK Application style (in Appearence / Application Style) that foresees transparency. Tis is not the case for the standard "Sweet-Dark".

3 Likes

thank you, @filo

I have solved it.

I went into Desktop Effects and tried modifying the transparency settings in there. Transparency wasn't even actually activated. I apologize. I remember that stuff configured itself automatically when you activated a theme... but it seems that it doesn't now?

So I activated it and modified the settings in there... still feel like the themes don't look as they should somehow... but, oh well.

Thank you.

I have now moved this thread to #4xx:precondition-failed as OP should have tried this prior to posting.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.