Wifi stopped working after dual booting Ubuntu

Wifi stopped working after dual booting Ubuntu (Realtek RTL8852AE)

After installing Ubuntu 20.04 in another parition, these happened:

  1. Grub was automatically installed on Ubuntu and Garuda was not detected in grub menu (maybe bcz of btrfs)
  2. I booted into a live session and ran grub-update on Garuda by chroot. I was able to boot into Garuda (but detected as "Arch"). Grub log was displayed instead of Garuda's boot animation.
  3. Wifi stopped working from there on Garuda. But it is working in Ubuntu.
  4. I tried changing the kernel to linux-arch as well as reinstalling rtw89-dkms-git (which was the driver before 5.16 kernel) from Chaotic-aur but no changes to wifi.

The wifi is working fine in following distros which I checked

  • Ubuntu 20.04 with Linux 5.13 HWE (Dual Boot)
  • Fedora 36 with Linux 5.17 (Live Boot)

Output of garuda-inxi:

System:
  Kernel: 5.18.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=0b40ffff-2556-4233-b187-8d1002ad5f86 rw [email protected]
    loglevel=3 quiet
  Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Pavilion Laptop 14-ec0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 88F1 v: 82.34 serial: <superuser required> UEFI: AMI
    v: F.07 date: 08/18/2021
Battery:
  ID-1: BAT0 charge: 39.5 Wh (99.5%) condition: 39.7/39.7 Wh (100.0%)
    volts: 13.0 min: 11.6 model: HP Primary type: Li-ion serial: <filter>
    status: N/A cycles: 225
CPU:
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x68 (104) stepping: 1 microcode: 0x8608103
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1396 high: 1401 min/max: 1400/4056 boost: enabled
    scaling: driver: acpi-cpufreq governor: powersave cores: 1: 1397 2: 1395
    3: 1401 4: 1397 5: 1397 6: 1392 7: 1397 8: 1396 9: 1397 10: 1398 11: 1397
    12: 1397 bogomips: 50303
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lucienne vendor: Hewlett-Packard driver: amdgpu v: kernel
    arch: GCN 5.1 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:164c
    class-ID: 0300
  Device-2: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 0408:5425 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: LG Display 0x06f0 built: 2021
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.46 5.18.9-zen1-1-zen)
    v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.9-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.54 running: yes
Network:
  Device-1: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw89_8852ae v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 02:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 2-1:2 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp4s0f3u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:4 chip-ID: 0bda:2852 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 173.37 GiB (36.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: HPS1
    temp: 32.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 198.47 GiB size: 198.47 GiB (100.00%)
    used: 81.78 GiB (41.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 529.3 MiB size: 528.3 MiB (99.80%)
    used: 6.1 MiB (1.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 198.47 GiB size: 198.47 GiB (100.00%)
    used: 81.78 GiB (41.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 198.47 GiB size: 198.47 GiB (100.00%)
    used: 81.78 GiB (41.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-5: /var/tmp raw-size: 198.47 GiB size: 198.47 GiB (100.00%)
    used: 81.78 GiB (41.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 14.96 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 1.95 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
  Processes: 345 Uptime: 9m wakeups: 184 Memory: 14.96 GiB
  used: 2.91 GiB (19.4%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 2272
  lib: 477 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: kitty
  inxi: 3.3.19
Garuda (2.6.4-2):
  System install date:     2022-01-05
  Last full system update: 2022-07-08
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:         

Have you tried bringing it up from a cold boot (as opposed to a reboot)?

@BluishHumility Yes.
I am finding solution from more than a week. I have lan connection so it was not a main problem.

This is output of os-prober:

/dev/nvme0n1p3:Ubuntu 20.04.4 LTS:Ubuntu:linux:btrfs:UUID=0b40ffff-2556-4233-b187-8d1002ad5f86:[email protected]/var/lib/docker/btrfs/subvolumes/22545ad6653898866b15dd0bffd2aac5df88b69c9822080de01419ad39541eef
/dev/nvme0n1p5:Ubuntu 20.04.4 LTS (20.04):Ubuntu1:linux

Garuda is actually installed in /dev/nvme0n1p3

Could you please check in efibootmgr if the Garuda entry should be put as first?
In general you should use Garuda's grub, which should be able to detect the other OS's (give it also a sudo update-grub after you fix the grub).
If necessary, you could reinstall it (I guess in /dev/nvme0n1p1, chrooting into /dev/nvme0n1p3) following this tutorial:

1 Like

I completely reinstalled and configured Garuda again (this time removed Dual booted ubuntu) and wifi started to work again.
After some times again wifi stopped working but this time nothing was dual booted. When I checked what I did wrong this time, I found that my assumption was wrong. The dual boot didn't cause any problem but it was just a coincidence.

The Problem was with the wihotspot program which changed /etc/NetworkManager/NetworkManager.conf to make the wifi interface un-managed if your wifi adapter does not support virtual interfaces (described here).
The changes made would retain if I shutdown the laptop while the hotspot was on.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.