Wifi connection randomly cuts off and after clicking WiFi icon it just comes back

Hello,

So, I have been facing this issue for a while and cannot resolve it. As time goes on it gets even worse, because after clicking WiFi icon internet connection comes back for maybe 5-10 mins without cut offs.
I would gladly appreciate if anyone will be able to help me, since I just couldn't find the solution on the internet and it is starting to mess me up pretty badly on online calls.

I couldn't even find this kind of problem. The ones which I found was
constant disconnect problem, which is not the case for me. It is connected but there is no internet.
For more clearance on latte top bar it shows 0.0B 0.0B or sometimes WiFi icon gets yellow.

Also, I tested my internet on a windows computer I can say that it is not my routers or my internet issue, because there everything worked smoothly. tested it on my phone and same story there.

Before this I had some issues with NetworkManager and this community helped me to resolve it.
Here is the thread: Network manager cannot find any internet connections after sleep phase.

P.S During installation I had some minor(idk internet said so) firmware issues which I solved with this:
Git Clone URL: git clone https://aur.archlinux.org/mkinitcpio-firmware.git
Source: AUR (en) - mkinitcpio-firmware

System:
Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=391fdedd-2184-4168-9f2a-5bb2dcc485b9 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A17 FA706II_FA706II
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FA706II v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: FA706II.316 date: 03/12/2021
Battery:
ID-1: BAT1 charge: 40.4 Wh (100.0%) condition: 40.4/48.1 Wh (84.0%)
volts: 12.6 min: 11.7 model: ASUS A32-K55 type: Li-ion serial: N/A
status: full
Device-1: sony_controller_battery_a4:ae:12:a7:31:ef model: N/A
serial: N/A charge: N/A status: full
CPU:
Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x60 (96) stepping: 1 microcode: 0x8600104
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1627 high: 2245 min/max: 1400/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1397 2: 1469
3: 1575 4: 1397 5: 1710 6: 1397 7: 1399 8: 2112 9: 2245 10: 2027 11: 1396
12: 1403 bogomips: 71859
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK
driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
speed: 8 GT/s lanes: 16 ports: active: none empty: DP-1 bus-ID: 01:00.0
chip-ID: 10de:1f95 class-ID: 0300
Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel
arch: GCN 5.1 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1,eDP-1 empty: none
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-4:3 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
s-diag: 1052mm (41.43")
Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: right model: Samsung C27F390
serial: <filter> built: 2021 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: eDP-1 pos: primary,left model: AU Optronics 0x479d built: 2019
res: 1920x1080 hz: 120 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
diag: 438mm (17.3") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.46 5.18.3-zen1-1-zen)
v: 4.6 Mesa 22.1.1 direct render: Yes
Audio:
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel bus-ID: 3-2:6
v: kernel chip-ID: 054c:09cc pcie: gen: 1 class-ID: 0300 speed: 2.5 GT/s
lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: DekTec Digital Video B.V. driver: N/A alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
snd_sof_amd_renoir
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-5: Sony DualShock 4 [CUH-ZCT2x] type: USB
driver: snd-usb-audio,sony,usbhid
Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-1:2 chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.38 TiB used: 220.49 GiB (15.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
model: 2210 MTFDHBA512QFD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: P6MA001 temp: 36.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0001
scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 184.71 GiB (38.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 184.71 GiB (38.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 184.71 GiB (38.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 184.71 GiB (38.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.78 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 46.0 C mobo: N/A gpu: amdgpu temp: 41.0 C
Fan Speeds (RPM): cpu: 2600
Info:
Processes: 331 Uptime: 42m wakeups: 5 Memory: 30.78 GiB
used: 5.6 GiB (18.2%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1895
pacman: 1882 lib: 545 flatpak: 13 Shell: fish v: 3.4.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.17
Garuda (2.6.3-2):
System install date:     2022-06-17
Last full system update: 2022-06-17
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

).

Maybe this time you could give a chance to the rtw88-dkms-git driver from the Chaotic AUR.
See below a couple of threads from users with your same wifi card:

Or this one, same driver (above in this thread) and some additional troubleshooting:

2 Likes

Hi, thank you for your time and kindness again.
While typing sudo pacman -Syu rte88-dkms-git
turns out there are 2 conflicting files which are
icoextract and exe-thumbnailer.
It asks me to remove-exethumbnailer on which default option is to not to do it so I didn't and
then I got

error: failed to prepare transaction (conflicting dependencies)
:: icoextract and exe-thumbnailer are in conflict

Now I am trying to figure out what each of those packages are, but I don't know if exe-thumbnailer is important enough to not to remove for this. I might be wrong and that is the reason I am replying .

Already removed it.

error: command failed to execute correctly got this at the end

garuda-update should have fixed this:

3 Likes

did everything. Now I'll check for whole day and if there will be no cuts I will mark this as solution.

Thank you!

1 Like

unfortunately it still happened

Maybe you could try disabling your wifi power saving like in the first part (Network Manager) of this post:

In addition to that, it won't hurt disabling MAC address randomization, with the Garuda Network Assistant or
https://wiki.archlinux.org/title/NetworkManager#Configuring_MAC_address_randomization

is there any alternative software to network manager better? I saw on some threads people talked about netctl

Network Manager is a standard, both for Garuda Dr460nized and for KDE. I really don't think the problem lies there, and I suggest not moving in that direction.
Just FYI you could give a look at the Arch Wiki here:
https://wiki.archlinux.org/title/Network_configuration#Network_managers

1 Like

Okay I did everything person suggested from turning off power save mode on WiFi to adding kernel boot parameters. But still nothing it cuts off during me writing this reply.

Only part I didn't understood in his instructions was
" If you have already installed any other driver version then uninstall that driver before proceeding. Once the driver has been uninstalled, then install the rtw88-dkms-git Chaotic AUR driver with the following command:"

I didn't install any drivers manually so I didn't delete anything and also don't know how to delete that driver. Maybe that is the problem or else idk what to think.

Correct.
I'm sorry that it can't be figured out.
Let's wait for better suggestions.

Have you got a usb network dongle you could try? It sounds like this is a hardware fault on your internal network adapter as it is intermittent.

2 Likes

A couple of other ideas:
Disable IPv6
Try using a static IP address

1 Like

Do you still have this service running? If something is triggering the service in error, that could cause this issue.

You could test by temporarily stopping the service:

sudo systemctl stop network-restart.service

Before installing Garuda i was running windows for 1 year on this computer, but never faced simillar issues. By saying hardware problem you mean that it is not compatible with the kernel or actual hardware is messed up?

I will try it and also will stop network-restart.service as suggested below.

My Connection Preference settings are

Socket read: 15seconds
Proxy connect: 10seconds
Server connect: 20seconds
Server response: 600seconds

Global Options
Mark partially uploaded files: Checked
if cancelled, automatically delete partially uploaded files smaller than: 5120bytes

FTP Options
Enable passive mode(PASV): checked
Marke partially uploaded files: checked

I haven't changed this options at all since installing Garuda so settings are default.
During garuda-update I get this error frequently:
Custom flags should be put directly in: ~/.config/code-flags.conf
idk maybe it has nothing to do with this topic, but maybe it does so I'll include it. Either way I will at least try to resolve errors which I get during updates.
last garuda-update errors which I did 10mins ago are:

error: failed retrieving file 'linux-zen-5.18.5.zen1-1-x86_64.pkg.tar.zst' from tux.rainside.sk : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: command failed to execute correctly

alongside that flags error

I had both IPv4 and IPv6 set on Automatic by default.
I disabled IPv6 and left IPv4 on Automatic.