Network manager cannot find any internet connections after sleep phase

Hello Garuda users.

I have been facing this particular problem since the installation of Garuda linux, have read threads and tried to solve problem on my own.

I've read this thread:
[SOLVED] No network connection after suspend (Page 3) / Networking, Server, and Protection / Arch Linux Forums
and they said that solution is to delete the /etc/modprobe.d/r8169_blacklist.conf .

Since this solution is from 2018 - 2019 I am scared to not mess things up even more.
Reason behind posting this is to know whether this solution is good or is there any different way for garuda-linux OS to solve it.

PS: During Garuda installation I had some firmware issue which I resolved with
Git Clone URL: git clone https://aur.archlinux.org/mkinitcpio-firmware.git
Source:AUR (en) - mkinitcpio-firmware.

There was no firmware errors, since then but felt like it was useful information to add.

Sorry for my poor choice of words. I'll definitely try to improve and make more readable threads in the future.

System:
Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=391fdedd-2184-4168-9f2a-5bb2dcc485b9 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Console: pty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A17 FA706II_FA706II
v: 1.0 serial: <filter>
Mobo: ASUSTeK model: FA706II v: 1.0 serial: <filter>
UEFI: American Megatrends v: FA706II.316 date: 03/12/2021
Battery:
ID-1: BAT1 charge: 38.9 Wh (100.0%) condition: 38.9/48.1 Wh (80.8%)
volts: 12.7 min: 11.7 model: ASUS A32-K55 type: Li-ion serial: N/A
status: full
CPU:
Info: model: AMD Ryzen 5 4600H with Radeon Graphics socket: FP6 bits: 64
type: MT MCP arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 3000 min/max: 1400/3000 boost: enabled
base/boost: 3000/4000 scaling: driver: acpi-cpufreq governor: performance
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3000 2: 3000 3: 3000 4: 3000
5: 3000 6: 3000 7: 3000 8: 3000 9: 3000 10: 3000 11: 3000 12: 3000
bogomips: 71864
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK
driver: nvidia v: 515.43.04 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-05) arch: Turing pcie: gen: 1 speed: 2.5 GT/s
lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none
empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1,eDP-1 empty: none
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-4:3 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
s-diag: 1052mm (41.43")
Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: right model: Samsung C27F390
serial: <filter> built: 2021 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: eDP-1 pos: primary,left model: AU Optronics 0x479d built: 2019
res: 1920x1080 hz: 120 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
diag: 438mm (17.3") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.9-zen1-1-zen)
v: 4.6 Mesa 22.1.0 direct render: Yes
Audio:
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: DekTec Digital Video B.V. driver: N/A alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_sof_amd_renoir
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 3-1:2 chip-ID: 13d3:3548 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.38 TiB used: 218.37 GiB (15.5%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
model: 2210 MTFDHBA512QFD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: P6MA001 temp: 37.9 C scheme: GPT
SMART: yes health: PASSED on: 163d 4h cycles: 1,076
read-units: 14,747,212 [7.55 TB] written-units: 29,011,104 [14.8 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
family: Mobile HDD size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0001 temp: 34 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 162d 4h cycles: 1059
read: 3.97 TiB written: 7.39 TiB Old-Age: g-sense error rate: 483 Pre-Fail:
attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 193.96 GiB (40.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 193.96 GiB (40.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 193.96 GiB (40.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 193.96 GiB (40.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.84 GiB used: 768 KiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.0 C mobo: N/A gpu: amdgpu temp: 39.0 C
Fan Speeds (RPM): cpu: 2400
Info:
Processes: 306 Uptime: 56m wakeups: 1 Memory: 30.84 GiB
used: 3.97 GiB (12.9%) Init: systemd v: 251 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1813 lib: 514
Shell: Bash (sudo) v: 5.1.16 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
System install date:     2022-05-17
Last full system update: 2022-05-25
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:
1 Like

There are several interesting solutions for your WiFi card in the forum.
Some consist in changing the driver, but this one seems really fit for your issue:

5 Likes

I tried it and everything went wrong. Thank god garuda has snapper tools or I was without internet connection for some reason. I will tell step by step what i did.

  1. sudo nano /etc/systemd/system/network-restart.service
  2. copied this is nano
     # cat /etc/systemd/system/network-restart.service
     # systemctl enable --now network-restart.service
     # systemctl start network-restart.service
     # systemctl stop network-restart.service
     # systemctl disable --now network-restart.service
     # systemctl status network-restart.service
     # systemctl daemon-reload
     
     [Unit]
     Description=Network Suspend/Resume Service 
     Before=sleep.target
     StopWhenUnneeded=yes
     
     [Service]
     User=root
     Type=oneshot
     RemainAfterExit=yes
     ExecStartPre=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking off'
     ExecStart=/usr/bin/sleep 1
     ExecStart=-/usr/bin/systemctl stop NetworkManager
     ExecStart=/usr/bin/sleep 1
     ExecStart=-/usr/bin/ip link set wlp3s0 down
     ExecStart=/usr/bin/sleep 1
     ExecStart=-/usr/bin/modprobe -r rtw88_8822ce
     ExecStop=/usr/bin/sleep 5
     ExecStop=-/usr/bin/modprobe rtw88_8822ce
     ExecStop=/usr/bin/sleep 2
     ExecStop=-/usr/bin/ip link set wlp3s0 up
     ExecStop=/usr/bin/sleep 2
     ExecStop=-/usr/bin/systemctl start NetworkManager
     ExecStop=/usr/bin/sleep 2
     ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking on'
     ExecStop=/usr/bin/sleep 1
     ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi off'
     ExecStop=/usr/bin/sleep 1
     ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi on'
     
     [Install]
     WantedBy=sleep.target
    
  3. Saved and exited.
    4.systemctl enable --now network-restart.service
    5.systemctl start network-restart.service
    6.systemctl status network-restart.service
    which gave me this output:
systemctl status network-restart.service
○ network-restart.service - Network Suspend/Resume Service
Loaded: loaded (/etc/systemd/system/network-restart.service; static)
Active: inactive (dead)

after all of this internet connection died. I tried everything again even deleted file, but internet connection was still dead. As I mentioned above idk what happened or What did i do wrong but snapper tools saved me there.

1 Like

So your problem is solved? You restored a snapshot and now internet works fine?

No i was back from where i started. After i did those steps Internet completely died. Snapper tools just made me back to the point before I did all of this and internet came back .

Idk i'll try this steps again and if something goes wrongs I'll jump back with snapper

I did it again and now everything went right internet didn't die. Now I'll suspend my computer for 30mins and if it works I'll mark it as solved. Thank you!

2 Likes

Thank you very much! Appreciate you. It worked like magic.
I am using this distro for like 10days, instantly fell in love with it and now also with its community. Thank you again!

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.