Wierd and random GUI error (invisible borders)


I'm having problems with the GUI as shown in the pictures below. It happen's totally randomly and no change was made between it working and not working. Sorry for the bad quality(=
I had to put the colons in front of them as I only had 5 links to work with :upside_down_face:


Log files n stuff:

  1. inxi -Fxxxza
  2. Xorg.0.log
  3. boot.log
  4. sudo dmesg

Things I've tried and notes I've made:

  1. "latte-dock" gives "an instance is already running!" msg, but no dock is visible.
  2. "latte-dock --replace" doesn't make the dock visible.
  3. It doesn't happen during boot time, but in log in.
  4. Sometimes it gets stuck in the log in process.
  5. The desktop doesn't update (if I add a file to $home/Desktop, it doesn't show up on the desktop)

Possible fixes:

  1. When I log out and log back in sometimes it kinda fixes itself.
    When I mean fixes, it get's rid of the "invisible borders", but latte-dock doesn't still show up and the desktop won't update.
  2. I've gone over the log files and "fixed" the warnings, but it doesn't help and they still show up.

Any help would be highly appreciated.
Thank you in advance!

Three initial questions:

  1. Has this ever worked correctly?
  2. When did it start happening, and what changed?
  3. Does it happen in a live installer environment?


  1. It worked correctly at the start (like for a couple of months).
  2. It started happening in the last 2-3 days out of nowhere. It gave me an invisible bar on the top and bottom, latte-dock wouldn't show up and the desktop files/folders wouldn't update.
    The cause might have been an upgrade? I also remember working a little with systemctl, but nothing major was changed.
  3. I'm going to try that right now, but I'm assuming the issue wouldn't rise there.

The questions are also intended as something to make you go away and look, not just answer directly. If it started happening after an update then go and see which packages were recently updated.

killall latte-dock

Then start latte from kRunner (Alt+F2).

The symptoms are from a compositor/kwin crash.
Do a KDE cleanup

This is irrelevant. Set your desktop to a Folder type.



I didn't think the problem would actually be that easy(=
I was a little worried that dual-booting windows and gnu/linux might have had a cause.
And yes, I'm aware of the risks of dual-booting.

Thank you so much!

1 Like

Thanks, petsam. I've been experiencing this latte crash quite often lately, and your suggestion of killing and restarting latte-dock works reliably to resolve the issue.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.