Latte Dock panels/docks cannot be moved to other displays - KDE Dra460ized

Just an additional update:
I tried booting with free drivers on the live iso and still could not copy panels.

I'm trying to see if I can find a way to view lattedock logs to see what is going on when it has the error when trying to copy panels.

I'm curious if anyone else is also having this issue with the new update.

Final edit: I'm going to bed for now. I've luckily got a weekend to get this sorted.

Woke up this morning and did a system update. It did have an update for latte dock, but upon reboot the inability to move panels to displays other than "Primary Screen" persists.

I also tried switchig to the linux-lts kernel, but that also yielded no dice.

Unfortunately, my current understanding of lattedock only allows very rudimentary debugging as I described above.

I need to find some way to view a log.
My current theory is it could be some sort of issue with configuration.qml. I don't really have a good idea, latte dock also seems a little more sluggish recently.

Alright, I tried one last thing just to confirm my computer doesn't have some new hardware issue.

I booted an old iso I had of kde dr460ized(01/07/21) and I confirmed that docks/panels can be moved to different displays.

Something about the configuration changes made between 01/07/21 and the 02/25/21 build is causing the issue.

I wanted to try a previous iso that was newer(perhaps one from early February), but it looks like those builds builds have been removed from and all other sources.

1 Like

Try a fresh new template panel

Thank you for the reply!

I tried using the template "Unity" and the new template "Default."
When I tried to move a panel or dock to the other screen, this is what I got:

The blurry patches cover the lattedock edit menu, the dock itself, and the switcher for changing dock/panel.

After a while it disappears, and the dock/panel just disappears.

Unfortunately, I think the root of the issue has to do with some other configuration besides the template.

You can reset your latte configuration, by renaming (backup) related file/folder (better to kill latte-dock instances first).

$HOME/.config/latte  # folder
$HOME/.config/lattedockrc  # file

Then start latte from kRunner.

1 Like

Alright, I did exactly as you said. I renamed the latte folder latte.old and renamed the lattedockrc file lattedockrc.old

After doing so, I reset latte dock.
However, the issue still seemed to persist. I was unable to move panels/docks to other displays.

I did one experiment that may be telling
I ran sudo pacman -Rdd latte-dock-git && sudo pacman -S latte-dock

While the package off the main Arch repository was kind of borked with Garuda configurations in many ways, I was able to move docks/panels to my other display.

Unfortunately, I don't think the solution is to uninstall latte-dock-git and just use latte-dock, given the multiple issues.

But, this is telling. It seems that the problem is with latte-dock-git itself.
I don't know if anyone else is having this issue or I am seeing it in isolation.
Perhaps, if it is isolated, it could be due to my monitors being different resolutions(1920 x 1080 vs 1920 x 1200)

The difference between the 2 versions is that -git is the latest master version (hence unstable), while the other one is the latest stable (hence stable :wink: ).

You should look at latte-dock bugs and contribute to fix this for all users.

Yep, I guess I'll report as an issue on their end.
I don't see any other similar issues currently on the git page.
Luckily, the team over there seems pretty active

1 Like

Ok, the issue is reported:


Here is a temporary fix:
sudo downgrade latte-dock

I personally downgraded to r4985.ea214c52
I'm not sure exactly when the cut off is before it stops working. I could test it later, but I am just glad to have things up and running temporarily.
It may take a few days to have this problem solved in the git repository

For anyone having this issue, the only way I was able to fix it was by manually building latte from its repo and i haven't ran into an issue since. it's working perfect for me

Thanks for the feedback! All helps pushing forward :slightly_smiling_face:

When I reinstalled Gaurda Linux I had the issue again.
It looks like psifidotos pushed an additional commit to fix the problem two days ago.

After updating the latte-dock-git package and rebooting, the problem is resolved once again!


With kde updates issues, first clear cache and second reset config (keeping backup).
Creating a clean new latte-dock/panel is a matter of seconds.
You may also use configSaver applet to keep backup of all local/user plasma settings.

how do I clean the cache of latte-dock ? Can I do I thought pamac or the garuda assistant?

Like how you clean plasma
Plasma clean cache
You may also use latte-dock in terminal (latte-dock -h)

latte-dock --cc

latte config is in $HOME/.config/

1 Like

Nice, Thanks for the info I'll be doing it right now. I had this problem and I was looking for some solutions

1 Like

So I tried cleaning the KDE cache and used this latte-dock command to clean it's cache but I restarted the computer to see and only where the dock resides it doesn't composite correctly like shown

but If I kill the latte instance on ksysguard it composites right Any tips ? should I change the init command for latte-dock to the one with --cc args?

I had 2 latte things, One was a panel at the top right and the other in the bottom middle. I deleted the top right one and substituted it by a KDE panel and the top side is not getting the compositing error anymore one where the latte dock resides

I'll try to change the latte command to init it on kde to see if using the --cc args will change anything

So It Looks like using latte-dock --cc on the init command works on not getting the problem of compositing

I will restart the computer some more times to see if it is consistent
Edit: Right on the next restart it had the same issues as previously. So, the latte-dock --cc is not a solution to this problem