Why my browser shows out of space for whatsapp?

Hi So when I am using WhatsApp on firefox, it gives me the below error always after some time like 4 or 5 minutes, and then logout from WhatsApp.

pic-selected-221219-1349-03

I didn't define any limit for the browser and I think I have enough amount of RAM and hard disk space. I first didn't have this issue on my arch Linux but after installing garuda I face this always with WhatsApp and some other websites which may use high memory.

Please let me know if I have to configure anything related to the browser or if you faced the same issue then how did you resolve that?

System:
  Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c2ecfa1b-97f7-4ab5-b58c-5f7e4829f677 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: dwm v: 6.2 vt: 1 dm: startx Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 5593 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0HP5Y9 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.24.0 date: 09/12/2022
Battery:
  ID-1: BAT0 charge: 20.5 Wh (89.9%) condition: 22.8/42.0 Wh (54.3%)
    volts: 12.9 min: 11.4 model: BYD DELL 1VX1H99 type: Li-ion serial: <filter>
    status: charging
CPU:
  Info: model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xB6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1186 high: 1301 min/max: 400/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1002 2: 1200 3: 1300
    4: 1301 5: 1004 6: 1221 7: 1200 8: 1264 bogomips: 19046
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
    empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX230] vendor: Dell driver: nvidia
    v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d11
    class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-6:3 chip-ID: 0c45:671e class-ID: 0e02
  Display: server: X.Org v: 21.1.5 with: Xwayland v: 22.1.6
    compositor: xcompmgr driver: X: loaded: modesetting,nvidia unloaded: nouveau
    alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x05f2 built: 2018 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
  Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Dell driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-10:4
    chip-ID: 0cf3:e009 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 1.38 TiB used: 23.22 GiB (1.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 11001101 temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: SDM2 scheme: GPT
Partition:
  ID-1: / raw-size: 194.57 GiB size: 194.57 GiB (100.00%)
    used: 23.22 GiB (11.9%) fs: btrfs dev: /dev/nvme0n1p9 maj-min: 259:9
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
    used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-3: /home raw-size: 194.57 GiB size: 194.57 GiB (100.00%)
    used: 23.22 GiB (11.9%) fs: btrfs dev: /dev/nvme0n1p9 maj-min: 259:9
  ID-4: /var/log raw-size: 194.57 GiB size: 194.57 GiB (100.00%)
    used: 23.22 GiB (11.9%) fs: btrfs dev: /dev/nvme0n1p9 maj-min: 259:9
  ID-5: /var/tmp raw-size: 194.57 GiB size: 194.57 GiB (100.00%)
    used: 23.22 GiB (11.9%) fs: btrfs dev: /dev/nvme0n1p9 maj-min: 259:9
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.53 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 61.0 C mobo: 51.0 C
  Fan Speeds (RPM): cpu: 4494
Info:
  Processes: 251 Uptime: 1h 3m wakeups: 1 Memory: 7.53 GiB
  used: 4.07 GiB (54.1%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1337
  libs: 336 tools: pamac,paru,yay Shell: Zsh v: 5.9 running-in: alacritty
  inxi: 3.3.24
Garuda (2.6.10-1):
  System install date:     2022-11-19
  Last full system update: 2022-12-19
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

We have no control over proprietary software, and neither does Firefox.
Have you already searched in their forums or in general with Whoogle?

That's not so much, modern Browser uses a lot of RAM, btw.

1 Like

@SGS oh ok, it could be the issue actually I sometimes kept open 10 to 12 tabs, but it wasn't an issue for me when I was using Arch Linux with dwm.

I use the same environment actually, I use garuda with X and dwm. I also used Wayland (sway edition), but I got the same issue there.

It could be the problem of WhatsApp demanding more memory maybe.

Use WU and check with htop


Sort Mem%

1 Like

My guess from reading the error message would be disk space is the problem, not RAM. You may have plenty of disk space, but if the temp directory the app is using is full that could cause something like this. Post to the thread:

df -H
4 Likes
psd clean
systemctl --user disable psd

Then reboot.
No sudo.

4 Likes

@TNE what is pad? Is this any particular command? I have tried to install it with pacman, pacman -Ss pad but there are so many results. how do I install it?

Oh yes, I can see one directory called /tmp it has a file system called tmpfs`.

tmpfs           4.1G  9.5M  4.1G   1% /tmp
/dev/nvme0n1p9  209G   26G  182G  13% /srv
/dev/nvme0n1p9  209G   26G  182G  13% /var/cache
/dev/nvme0n1p9  209G   26G  182G  13% /var/log
/dev/nvme0n1p9  209G   26G  182G  13% /var/tmp
/dev/nvme0n1p5  524M  623k  523M   1% /boot/efi

So should I increase the space for this one? there is also /var/tmp don't know what is stands for.

I edited it, sorry I made a typo :stuck_out_tongue:

1 Like

Hi,
I had same issue in past, and clearing the cookies and data for the whatsapp fixed it.

Note that this would log out your account, which you can simply log in again.

Whatsapp actually downloads recent chats, videos and photos automatically on whatsapp web, which causes this issue, especially in older versions of whatsapp web.

I hope this fixes your issue.

3 Likes

Are you using Firefox or Firedragon?

The reason I ask is I've found this when looking at the cache of Firedragon...

To clear cookies and site data, simply click on lock-like ( image ) icon on search bar and select clear cookies and site data and then select remove

1 Like

Hi @Colin thanks for your reply, yes I use both firefox and firedragon and I got this problem in these kinds of browsers only maybe.

I don't use whatsapp, but I notice in your second screenshot that your cache seems to be full.

Have a look at How to Set RAM Cache in Firefox | Small Business - Chron.com

Have a look at the guide, and try setting "browser.cache.memory.capacity" to -1. Maybe this might do the trick.

If this doesn't work maybe you should try a change...

2 Likes

@Colin thanks, I think for memory it is -1 but I can change it to disk as well and see if this work or not.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.