Whoogle Throwing Up Google's Warning Page In Results

Oh how I hate Google with a passion. I noticed Whoogle has had a couple of recent updates from the repos, so not sure if this is related. Here is my issue(s);

When I install Whoogle from the repos (chaotic-aur,) and configure it to use localhost, it always throws up Google's ..."detected unusual traffic from your computer network." warning page from the results using a VPN (tried different VPN servers.)

Now, since the last few updates, configure Whoogle to use instead 'Whoogle Search' is throwing up the same page with a VPN, basically making it un-usable, and me :rage: :face_with_symbols_over_mouth:

Any suggestions?

edit: just an update on this. Whoogle sitting on Garuda's servers started accepting search requests using a VPN again. I have no idea what sort of dark arts happened. You still can't use a VPN with the localhost option though, plenty of internetting post on it.


It sounds kind of similar to this,


Yeah, I came across that earlier today, thanks. Seems kind of hopeless. There are a few posts with people trying to create scripts running to get around it, although not sure if successful, but it was too much of a complicated order for me.

I suspect we will see more of this VPN blocking with the major corporate closed-source players ramp up. Make it annoying enough for the users to not use protection/privacy features.

And this is me giving Google a :fu:


Huh. For me it works using the garuda search main page but throws that error when searching from whoogle sdf org, even after configuring it to the garuda search address. This is regardless of vpn use.


I don't know why, but whoogle and whoogle-git is throwing error my side.

 ╰─λ systemctl status whoogle.service   
● whoogle.service - Whoogle
     Loaded: loaded (/usr/lib/systemd/system/whoogle.service; enabled; vendor preset: disabled)
     Active: activating (auto-restart) (Result: exit-code) since Sun 2021-10-17 00:33:09 IST; 176ms ago
    Process: 8599 ExecStart=/opt/whoogle-search/venv/bin/python3 -um app --host --port 5000 (code=exited, status=1/FAILURE)
   Main PID: 8599 (code=exited, status=1/FAILURE)
        CPU: 422ms

Maybe some bug is there in latest version.

Also, as already mentioned in above posts, search.garudalinux.org is up and running perfectly fine.

1 Like
systemctl status whoogle.service
● whoogle.service - Whoogle
     Loaded: loaded (/usr/lib/systemd/system/whoogle.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2021-10-16 20:17:04 CEST; 1h 7min ago
   Main PID: 994 (python3)
      Tasks: 5 (limit: 154405)
     Memory: 65.4M
        CPU: 450ms
     CGroup: /system.slice/whoogle.service
             └─994 /opt/whoogle-search/venv/bin/python3 -um app --host --port 5000

Okt 16 20:17:04 i3 systemd[1]: Started Whoogle.
Okt 16 20:17:04 i3 whoogle[994]: Serving on

I update with --ignore sorry, not on this PC.

1 Like

I didn't have whoogle earlier on this machine

I installed to see what's the issue. I installed from Chaotic-AUR and also started and enabled whoogle.service . But got an error in status.

1 Like

I started the service and the localhost searches works, but when I turn on my VPN, no show.

g00gle block VPN ?

Yes, it throws up Google's block page of torture.

edit to add: Using localhost without a VPN is most likely throwing Google your IP address. If you look on their git page, it states it doesn't give Google your IP address ...IF...you use a remote server setup, else it is an open candy store.

1 Like

I think there might be a packaging issue which I need to look at. Recently changing the service to use the whoogle instead of the root user was suggested :eyes:


Happy to report that after the latest Whoogle update today, localhost search with a VPN now works. Praise Garuda :raised_hands: .

With that said, and this is Whoogle's witchcraft, not Garuda's, is that it only works with http://, so no encryption. I think you have to mod the script and use your own domain in order for encryption (https://) to work. Just an fyi.


I updated packaging today which fixed a permission error, dunno if it's related somehow :joy:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.