What's up with updates?

launched Pamav and it says no updates, but run Topgrade and I get the below. Not sure what to do with it.

 -> olivia: local (r825.a19ce37-1) is newer than AUR (r815.2235bab-1)
 -> performance-tweaks: local (0.0.1.r1.gf821d08-1) is newer than AUR (0.0.1.r0.ge9d8ab2-1)
 -> virt-manager-meta: local (1-2) is newer than AUR (1-1)
 -> vivaldi-snapshot: local (3.6.2137.3-1) is newer than AUR (3.5.2131.8-1)
 -> Missing AUR Packages:  alsa-support  bluetooth-support  firefox-extension-localcdn  garuda-assistant-git  garuda-boot-options-git  garuda-browser-settings  garuda-common-settings  garuda-firefox  garuda-gamer-git  garuda-hooks  garuda-icons  garuda-kde-settings  garuda-modem  garuda-network-assistant-git  garuda-vaapi  garuda-wallpapers  garuda-welcome-git  garuda-zsh-config  grub-garuda  grub-theme-garuda  input-devices-support  jack-support  libretro-pcsx2  networkmanager-support  os-prober-garuda  plymouth-theme-garuda  printer-support  proton-tkg-git  pulseaudio-support  reflector-simple  samba-support  scanner-support
 -> Orphaned AUR Packages:  asian-fonts  gstreamer-meta  lib32-gmp4  steamos-xpad-dkms  virt-manager-meta
 -> Flagged Out Of Date AUR Packages:  angrysearch  python-pynput
:: 10 Packages to upgrade.
10  aur/balena-etcher                  2:1.5.112-1 -> 2:1.5.113-1
 9  aur/bauh-staging                   0.9.11.RC-3 -> 0.9.11.RC-7
 8  aur/freefilesync                   11.0-1      -> 11.4-1
 7  aur/joplin                         1.4.19-1    -> 1.4.19-13
 6  aur/pamac-all                      9.5.12-2    -> 10.0.2-1
 5  aur/plasma5-applets-eventcalendar  71-1        -> 72-1
 4  aur/replay-sorcery                 0.3.1-1     -> 0.4.2-1
 3  aur/steamtinkerlaunch              3.1.335-2   -> 3.5-1
 2  aur/streamlink-twitch-gui          1.10.0-1    -> 1.11.0-1
 1  aur/topgrade                       6.1.0-1     -> 6.1.1-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==>
1 Like

The Banner post has more information:

The package files aren't in the ChaoticAUR database so topgrade is checking the AUR instead. Pamac uses its own weird database thing (I don't use Pamac).

They're mainly the same packages so you can either wait for ChaoticAUR to be fixed, or update from the AUR in the meantime (but keeping in mind that local package compilation might take a while).

6 Likes

I thought as much, but wasn't sure. THat explains the below then?

:: PKGBUILD up to date, Skipping (1/10): topgrade
:: PKGBUILD up to date, Skipping (2/10): balena-etcher
:: PKGBUILD up to date, Skipping (3/10): replay-sorcery
:: PKGBUILD up to date, Skipping (4/10): freefilesync
:: PKGBUILD up to date, Skipping (5/10): pamac-all
:: PKGBUILD up to date, Skipping (6/10): plasma5-applets-eventcalendar
:: PKGBUILD up to date, Skipping (7/10): joplin
:: PKGBUILD up to date, Skipping (8/10): streamlink-twitch-gui
:: PKGBUILD up to date, Skipping (9/10): steamtinkerlaunch
1 Like

I don't know how Pamac resolves differences between package versions if they are present in both a local repo and in the AUR. However, I suspect it won't cope well.

1 Like

AUR is build and Chaotic is install, right? if so I can see what you're saying about it not coping well.

1 Like

OK cool, so for now I assume I can use that list as a guide for those 10 programs and just uninstall the Chaotic and build and install the AUR, right?

OK that's not going to work. All 10 are AUR not Chaotic.

Something like yay should just pick up the updates and build and install the package for you.

If it doesn't then post output. :stuck_out_tongue_winking_eye:

4 Likes

yay does the same thing. So it looks like it's stuck till we get Chaotic back. I'll just have to avoid any updates till then. Thanks for the help and input, much appreciated.

1 Like

Would I be right in assuming as items get added back to Chaotic or added to the AUR instead that list of 10 programs will slowly whittle down like the list of so called missing AUR apps?

Yeah we will add back packages as we can and as the cluster can handle.

3 Likes

OK thanks cause as it stands now it looks like the below list can't be updated till at least some of the items in the second list are reuploaded.

:: 7 Packages to upgrade.
7  aur/joplin          1.4.19-1     -> 1.4.19-13
6  aur/lidarr-nightly  0.8.0.1968-1 -> 0.8.0.1974-1
5  aur/pamac-all       9.5.12-2     -> 10.0.2-1
4  aur/radarr-nightly  3.0.1.4302-1 -> 3.0.1.4320-1
3  aur/replay-sorcery  0.3.1-1      -> 0.4.2-1
2  aur/sonarr-phantom  3.0.4.1033-1 -> 3.0.4.1035-1
1  aur/topgrade        6.1.0-1      -> 6.1.1-1

-> Missing AUR Packages: bluetooth-support garuda-assistant-git garuda-hooks garuda-modem garuda-network-assistant-git garuda-vaapi garuda-zsh-config grub-garuda input-devices-support libretro-pcsx2 networkmanager-support printer-support proton-tkg-git reflector-simple scanner-support

A lot of our packges need other AUR packages as dependencies, so they need to be build before we can build the other ones :slight_smile:
They will be treated with priority though instead of compiling stuff like Google Chrome which takes ages :joy:

4 Likes

OT

If you're in a hurry, build it yourself.

Here you can see how grateful the users were in the past for a free service.

It is time to accept donations.

4 Likes

Let's not assume someone is in a hurry. The assumption should be that I'm curious until proven otherwise.

1 Like

I love Garuda and the wonderful team that does all of this work. If a good portion of us would support Garuda with a monthly or yearly donation, we can get past this problem. Our donations may be small but there is true power in coming together to insure that Garuda can continue to be a great distro. Support for Garuda will be my New Years goal.

And a special THANK YOU to the Garuda Team for their work in making such a great distro.

Please everyone stay safe, the vaccines are on the way...

gary

9 Likes

Would like a bit of insight. I didn't think of it yesterday but all the below are AUR not Chaotic, but it looks as if they are waiting for all the remaining files to be uploaded to the new server before their new versions will be built. Is this because Chaotic is handled before anything that needs to be built? Thanks

On a side note from what I'm seeing from an occasional run of Topgrade looks like everything is being put on the new server extremely fast. Simply great job by all involved.

4  aur/lidarr-nightly  0.8.0.1968-1 -> 0.8.0.1974-1
3  aur/radarr-nightly  3.0.1.4302-1 -> 3.0.1.4323-1
2  aur/sonarr-phantom  3.0.4.1033-1 -> 3.0.4.1039-1
1  aur/topgrade        6.1.0-1      -> 6.1.1-1
2 Likes

im also willing to support with a monthly donation :+1:

4 Likes

First confirm this

If they were not in that order, you may change to that and then run

sudo pacman Syy
pacman -Qqm

Of course run update after checking.

3 Likes

All's good, but thanks for that. After some more searching I was just going to continue to wait for the Garuda files to be finished being added back to Chaotic, but then decided to simply try yay -S (program name) and was offered to rebuild each of the apps with the newer files. So other than 3 or 4 files that still have yet to be added back to Chaotic all looks good.

2 Likes