What is the best way to install Virtualbox? garuda-virtualbox does not install it

Hello and sorry to bother with this, I have left to install only 3 programs, one is Virtualbox. What is the best way to install Virtualbox? garuda-virtualbox does not install it.

Is there an easy way to install Virtualbox?, I tried with garuda-virtualbox, it ask me to choose from one of two host kernel options and no matter what I choose it gives me dependencies conflicts. If I have to do it via command line I appreciate the exact command, thanks.

Can you show the exact details from terminal

He install KDE lite and now some packages are missing :wink:

1 Like

Hello, the error was in pamac, now I tried with pacman via command line and no error on that point, I copy the output from the terminal, but this time I get:
"Unable to install module vboxhost/6.1.14_OSE for kernel 5.4.64-1-lts: Missing kernel modules tree."

After running garuda-virtualbox I lost all the system information that appeared at the right hand of the screen.

$ LANG=C sudo pacman -Syu garuda-virtualbox                                                                
[sudo] password for jose:                  
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
error: failed retrieving file 'chaotic-aur.db' from lonewolf-builder.duckdns.org : Resolving timed out after 10000 milliseconds
 chaotic-aur                                   1248,0 KiB   129 KiB/s 00:10 [-------------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
:: There are 2 providers available for VIRTUALBOX-HOST-MODULES:
:: Repository community
   1) virtualbox-host-dkms  2) virtualbox-host-modules-arch

Enter a number (default=1): 1
looking for conflicting packages...

Packages (7) virtualbox-6.1.14-1  virtualbox-ext-oracle-6.1.14-1  virtualbox-ext-vnc-6.1.14-1  virtualbox-guest-iso-6.1.14-1
             virtualbox-host-dkms-6.1.14-1  virtualbox-sdk-6.1.14-1  garuda-virtualbox-20200912-1

Total Installed Size:  249,73 MiB

:: Proceed with installation? [Y/n] Y
(7/7) checking keys in keyring                                              [-------------------------------------------] 100%
(7/7) checking package integrity                                            [-------------------------------------------] 100%
(7/7) loading package files                                                 [-------------------------------------------] 100%
(7/7) checking for file conflicts                                           [-------------------------------------------] 100%
(7/7) checking available disk space                                         [-------------------------------------------] 100%
:: Processing package changes...
(1/7) installing virtualbox-host-dkms                                       [-------------------------------------------] 100%
Optional dependencies for virtualbox-host-dkms
    linux-headers: build modules against Arch kernel [installed]
    linux-lts-headers: build modules against LTS kernel [installed]
    linux-zen-headers: build modules against ZEN kernel [installed]
(2/7) installing virtualbox                                                 [-------------------------------------------] 100%
Optional dependencies for virtualbox
    vde2: Virtual Distributed Ethernet support [installed]
    virtualbox-guest-iso: Guest Additions CD image [pending]
    virtualbox-ext-vnc: VNC server support [pending]
    virtualbox-sdk: Developer kit [pending]
(3/7) installing virtualbox-ext-vnc                                         [-------------------------------------------] 100%
Optional dependencies for virtualbox-ext-vnc
    tigervnc: vnc client [installed]
(4/7) installing virtualbox-guest-iso                                       [-------------------------------------------] 100%

===> virtualbox-guest-iso post install message:
===> Redistribution of VBoxGuestAdditions.iso from the binary packages
===> on www.virtualbox.org with Arch Linux has been granted by
===> InnoTek Systemberatung GmbH.
===> By using this package you accept
===> the VirtualBox Personal Use and Evaluation License (PUEL)
===> which can be found here: http://virtualbox.org/wiki/VirtualBox_PUEL
===> If you do not accept this license, you must remove the package immediately.

(5/7) installing virtualbox-sdk                                             [-------------------------------------------] 100%
(6/7) installing virtualbox-ext-oracle                                      [-------------------------------------------] 100%
Optional dependencies for virtualbox-ext-oracle
    rdesktop: client to connect vm via RDP
(7/7) installing garuda-virtualbox                                          [-------------------------------------------] 100%
Optional dependencies for garuda-virtualbox
    tigervnc [installed]
:: Running post-transaction hooks...
( 1/12) Creating system user accounts...
( 2/12) Reloading system manager configuration...
( 3/12) Reloading device manager configuration...
( 4/12) Arming ConditionNeedsUpdate...
( 5/12) Install DKMS modules
==> dkms install --no-depmod -m vboxhost -v 6.1.14_OSE -k 5.8.8-zen1-1-zen
==> dkms install --no-depmod -m vboxhost -v 6.1.14_OSE -k 5.8.8-arch1-1
==> depmod 5.8.8-zen1-1-zen
==> depmod 5.8.8-arch1-1
==> Unable to install module vboxhost/6.1.14_OSE for kernel 5.4.64-1-lts: Missing kernel modules tree.
( 6/12) Cleaning pacman cache...
==> no candidate packages found for pruning
( 7/12) Foreign/AUR package notification
lib32-libva1 1.8.3-3
lib32-libva1-intel-driver 1.8.3-1
libva1 1.8.3-3
libva1-intel-driver 1.8.3-2
( 8/12) Updating icon theme caches...
( 9/12) Orphaned package notification
autoconf 2.69-7
automake 1.16.2-3
bison 3.6.4-1
flex 2.6.4-3
lib32-libva1-intel-driver 1.8.3-1
linux 5.8.8.arch1-1
pkgconf 1.7.3-1
(10/12) Checking for .pacnew and .pacsave files...
.pac* files found:
Please check and merge
(11/12) Updating the desktop file MIME type cache...
(12/12) Updating the MIME type database...

You need linux-lts-headers installed

sudo pacman -S linux-lts-headers

As for the system info widget

You can run


And it will show


On taking another look it seems you have headers installed

So perhaps the virtualbox-host-dkms

Does not work with lts kernel


Hello I rebooted and Virtualbox and the system information worked. Now I am battling with KDE to copy files from my backup in a secondary disk, to the Garuda SSD, permissions in Dolphin are a problem. Thanks.

Time to start some reading :wink:

1 Like

Thanks, is working now, for some reason Dophin showed guest, but root terminal showed jose I rebooted and it worked, now I have VirtualBox with my originals VDIs. Thanks for your help and sorry for the inconveniences.