WARNING: community/qtermwidget 0.17.0-2 -> 1.0.0-1 Breaks Octopi

If you are on Dragonized or any other editions and use Octopi, and found that it broke, you should update again from a terminal:

sudo pacman -Syu

Octopi has been rebuilt and will work again.

Original warning

If you are on Dragonized and or any other editions and use Octopi, you should update with pacman -Syu --ignore qtermwidget for the meanwhile.

Hopefully the dev takes care of the issue prtomptly and releases an update. He's pretty damn good at it :sunglasses: Oh and if you're not on octopi-dev you should be

The good news is, I just did my first successful snapper restore! No problems whatsoever :clap:


i just broke octopi few mins ago kept googling lol. thxf this showed up on my notifications


What is the exact issue? A library mismatch? :eyes:


Yeah, probably only requires changing the version of the dependency since it's the 1. release

/usr/bin/octopi: error while loading shared libraries: libqtermwidget5.so.0: cannot open shared object file: No such file or directory

I rebuilt the package, sudo pacman -Syu octopi should help. Couldn't test as I'm not using my laptop right now :blush:


Perfect! Probably should've just waited or asked you before notifying everybody, oops

1 Like

I thought it was not a good idea to use -dev packages?

Confirmed, it is fixed! thanks. :grinning:

Generally, but Garuda was just not fully supported up until now. However, now that the stable is at 12.0.0, you should be fine!


I already updated with sudo pacman -Syu, what should I do?

Update again:


I've updated the OP so this thread still works as a warning. :slight_smile:


Just an fyi, when I did a 'sudo pacman -Syu' nothing happened/updated. When I added octopi at the end of it, it updated and fixed the broken package.

1 Like

What was the output of the command? If the package was bumped then it should happen automatically...

@dr460nf1r3 Did you increment the pkgrel to denote there was a rebuild? It can be a decimal increment if it's otherwise taken from the AUR and you want to keep the base pkgrel in sync (e.g. nnn-1, -> nnn-1.0).

1 Like

We don't control pkgrel for most packages, which is why reinstalling needs to be done :eyes:


This isn't ideal - a rebuilt package should ideally have a pkgrel bump of some sort, otherwise it's not going to get reinstalled, e.g. when happens if the package archive is already in the pacman cache?


Actually I could do this, just can't push the needed change to git right now.

This is partly caused by how Chaotic-AUR works - building most things from AUR. So pkgrel would of course be increased when we maintain the PKGBUILD, in this case won't don't however. Manual workarounds would be possible using interfere, it just needs to be remembered to be removed once the maintainer increases pkgrel :thinking:


Just updated regularly through octopi in the top notification bar and everything seems to be smoothed out. Thanks for the work everyone puts in.
Also, I wanted to say I switched to Linux as my daily driver after long amount of research and I'm so glad I chose to install Garuda because both times an update (thanks Timeshift) caused some weird nonsense there was something posted very soon after for a fix. Haven't been worried about my switch before but this community is awesome and is gonna keep me here a very long time.


I had an issue where I was unable to update because of octopi. I manually removed it, and I am not sure if this is related to my issue, but I guess I can reinstall and see if the problem returns.

go to terminal and update the system, Octopi I guess had a weird update of sorts. It works properly after an update.

Thats because I got to push pkgrel, which means the whole situation is no longer an issue :slight_smile: