Want to switch, had some issues in USB boot

So after I used Etcher to thingy the .iso to my 16GB usb, I rebooted with it as my first choice.
After the loading I play about on the live environment, happy with it, I go to install.

But, on the first section of the installer with the drop-down menu to select a language at the bottom, it was stuck loading forever, saying something like "waiting for 1 module".
Connecting to the internet didn't change anything.

If I have a faulty install, would the checksum help? I tried figuring out how to use it but failed on a comedic level.

Thanks for your replies in advance!

I would suggest first try something you know you can do:

  • You could try re-d/ling the ISO and rebooting from it.
  • You could try using something different than Etcher, like dd (apparently don't use Rufus, if I recall, can someone confirm that).
  • You could try connecting to Internet before you boot from USB, just in case.

The command line for dd is sudo dd bs=4M if=/path/to/GARUDA.iso of=/dev/sdX status=progress && sync

The /dev/sdX is the drive of the USB, be very very very sure you got the right letter replacing "X" (a, b, c, etc...)

1 Like

You may try this method

1 Like

godda love disk-destroyer...
Thanks tho. Ill give dd a go. About to try on another system too, just to be sure.

Yes, that gives excellent data when comes the time to troubleshoot an issue.

Ill have a look at this method, thanks

You could also try being connected to the internet before running the installer.

okay, on the other pc it worked less bad. In both cases its a very hoppy and glitch-y start up before the live boots up. But on the other pc it let me install it.
Is there a way of checking, once installed, that its installed perfectly and has no issues? i went for KDE Dr460nized gaming edition.

The Live USB takes time to boot if you choose the nonfree video driver, that is normal.

At the end of the installation if everything went fine it pops-up a msg saying "Installation successful" or something like that.
If there were errors, they are normally picked-up by the installer and you would have known there.

After the installation once you boot into the system and before doing anything else, if you open a terminal it will tell you how many packages are installed. For gaming edition I don't have the number, though.

I can't install garuda linux waiting for 1 module

New problem, new thread please.

Network is ok?
Search need "normal" ~ 1min.


I am facing same issue...Have you found any solution ?

Open new topic, please.


and post

inxi -Fza

as text!

Even if you personally think it is unnecessary.