Virtual monitor with custom edid file not working

Hello everyone,

I am trying to setup my computer as headless server with cinnamon GUI
(sometimes I am unable to achieve what I need with just SSH connection, still new to linux).
I am using NoMachine to connect to the server via my pc or smartphone.
Only problem is that NoMachine headless connection will give me only 640x480 resolution with no way to change it.
That is why I grabbed edid.bin file from nvidia X server app and tried to apply it.
So far went with this thread without any luck.
Also I read the official Arch wiki page on kernel mode setting - section Forcing modes and EDID
and searched for any error in the parameters I wrote.. also with no luck.
I did basically the same thing in debian 11 so I know it can be done.

Can anyone help me with this problem or have any tips how to do it correctly?
Thanx for any answers in advance.

System info:

System:
  Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6d28826f-49cf-4936-a543-f386235f0801 rw [email protected]
    quiet splash drm.edid_firmware rd.udev.log_priority=3
    vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
    drm.edid_firmware=edid/edid.bin
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.31 wm: muffin vt: 7
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: H410M S2H v: x.x
    serial: <superuser required> BIOS: American Megatrends v: F5
    date: 04/19/2021
CPU:
  Info: model: Intel Core i3-10100F bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 3 microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 4039 high: 4275 min/max: 800/4300 scaling:
    driver: intel_pstate governor: performance cores: 1: 3530 2: 4275 3: 4202
    4: 4201 5: 4196 6: 3456 7: 4209 8: 4247 bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: ASUSTeK driver: nvidia
    v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:1402 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: nvidia
    unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 640x480 s-dpi: 75 s-size: 217x163mm (8.5x6.4")
    s-diag: 271mm (10.7")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Comet Lake PCH-V cAVS vendor: Gigabyte
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a3f0 class-ID: 0403
  Device-2: NVIDIA GM206 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fba
    class-ID: 0403
  Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.04 TiB used: 32.13 GiB (1.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX001-1NS164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC41
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Patriot model: Burst
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: KB.3 scheme: MBR
Partition:
  ID-1: / raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
    used: 10.21 GiB (4.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
    used: 10.21 GiB (4.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
    used: 10.21 GiB (4.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/tmp raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
    used: 10.21 GiB (4.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.56 GiB used: 1.8 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 16.8 C mobo: 16.8 C gpu: nvidia temp: 40 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 31%
Info:
  Processes: 285 Uptime: 9m wakeups: 0 Memory: 15.56 GiB
  used: 2.04 GiB (13.1%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1341 lib: 293 Shell: Zsh
  v: 5.8 running-in: gnome-terminal inxi: 3.3.12
Garuda (2.5.3-1):
  System install date:     2022-01-31
  Last full system update: 2022-02-01
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper (maybe)
  Failed units: 

Don't you also notice the error in commandline? Delete the wrong param (with no value).

Have you added the Edid file in mkinitcpio FILES()?
Also, remove non-nvidia modules from mkinitcpio MODULES().

Rebuild kernels and grub.

3 Likes

I am sorry, not gonna lie, I am not sure which parameter is without value.
This was the default command line and I just added the command:

drm.edid_firmware=edid/edid.bin

First one I already did without anything happening

FILES=(/usr/lib//firmware/edid/edid.bin)

I'll try the second one

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

nothing happend

tried this post but I think this will just update the kernel.
also I tried to find some tutorial or post on how to rebuild kernel or grub but I didn't.

Is there any good tutorial or post on Garuda forum that could help me do this without me breaking the entire system? Because it sounds like something I wouldn't be confident enough to do by myself.

oh this is the parameter without value.. jeez I am stupid
I deleted it but unfortunately it didnt change anything..

I went to Linux4Noobs with this and I resolved the problem:

I went to this article on kodi and I went by section 3 Configure xorg to read custom EDID file

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.