Videos wont play, no sound?

Last night I did an update to my workstation, and after the update I lost all sound, and YouTube videos no longer load... I tried using Timeshift to go back before the update, but that didn't resolve the issue. My hardware isn't showing to be having any issues at all, Garuda recognizes my built in audio/speakers (I'm on an iMac) and everything looks and seems normal. But no sound at all what so ever, and no videos will play.

I even get an error within Spotify saying that it can't play the current song... Help?

Also not sure if this is related, but when I use the link to the forum from the Welcome Garuda app, it doesn't take me to the forum, but to a page that say:

Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to
Commercial support is available at

Thank you for using nginx.

This may be related to the recent pipewire/wireplumber changes - if everything seems to be working but there's no sound then possibly the media session service isn't running.

If you have pipewire-media-session installed, try systemctl --user start pipewire-media-session and see if that helps. If wireplumber, then systemctl --user start wireplumber.

Also check [Manual intervention required] Package conflict between pipewire-media-session & wireplumber


Thanks for the response, I tried everything you suggested and still no dice.

Okay, got it fixed.

I manually removed pipewire and installed wireplumber, that did the trick. Thanks for the help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.