Very slow USB transfer speeds

I’ve been using Garuda linux KDE lite for about 2 months and, it runs amazing. The only real issue I have run into has been, very slow USB transfer speeds. I have tried 6 different devices ranging from USB-C / USB and regular USB hard drives. I basically just tried to transfer a downloaded ISO file to the external drive.

Another time I tried a regular MKV movie file. (Files were under 5 GB each) It is either extremely slow to where it stops about mid transfer or the file is corrupted after it finishes. (Takes a loonnngg time). I’ve tried formatting them with exfat, NTFS, FAT32 and, they all dont work correctly. (I have 1 new USB-C drive and 1 new regular USB thumbdrive and 4 ‘used’ ones.)

I’ve researched it and all I can find out is that, it seems to be an issue with linux in general. Reading different forums, I have found people were able to fix it though. Someone had posted and said this fixed the issue with Arch:

sudo sysctl -w vm.dirty_bytes=50331648

sudo sysctl -w vm.dirty_background_bytes=16777216

Unfortunately, it didn’t work for me. someone else mentioned messing with the rc.local file but, I couldn’t locate it, to try it. I do have Btrfs running on my install so, idk if anyone has problems with that. Crazy thing is, I have no issues with these drives on my other Windows 11 pro laptop for work. Does anyone have similar issues and, figured out a way to fix it? I searched for hours and, I just don’t know what else to try.

My laptop runs 100 times better with Garuda than when I had Windows installed on it so, I hope to stick with it. I know my way around linux for the most part, and had Ubuntu on this as well. (Ran horribly). A regular install of Arch also had that issue. My laptop is a thinkpad X1Carbon Gen 6 / 16GB ram / Samsung 980 SSD drive. Garuda functions great, when I’m just using it in general.

Movies play fine / music etc etc. No clue if this is a kernel problem or what. A week ago I did install Windows 11 on this and, it also has no problems with transferring files via the external HD or USB sticks. It’s frustrating because, things work so good besides what’s going on with my USB / USB-C ports / drives. Forgot to mention that I do have swap / hibernate enabled, when I installed Garuda. Also, I tried the different options with the script ‘maxperfwiz’ and that didn’t work.


Garuda Linux KDE lite

Garuda Linux KDE lite is made for users who do not want extra software and functionalities and complain about bloat. It contains only the bare minimum of packages needed to get started. (You are on your own, we do not provide any support for KDE lite editions!)

and missing garuda-inxi.


Try ext4 and check if it works without issues.


I forgot to mention, that I had originally installed the ‘KDE Dragonized Edition’ and had the same issue. Maybe it’s an Arch / KDE problem or, it’s an issue with compatibility of my laptop. I’ve tried every fix I can think of. If I can’t figure it out, I might just try out Garuda GNOME or Cinnamon. (No clue if that will fix it). If that doesn’t work then maybe OpenSUSE. I feel if I keep screwing with things, I’m just going to make it worse.

I tried 2 of my new USB drives formatted to ext4 but, ran into a new issue. I formatted it then remounted the drive and tried to copy a file over but, I get the red circle with a line through it. Looking online It said I didn’t have some type of permission for the new drive. Tried a few things to fix it but, it doesn’t work. This is just too much of a headache and, way beyond what I know how to fix anymore.

I’m going to try to install Garuda GNOME and if that doesn’t work, I’ll try Cinnamon and see if that will fix it. This is just too frustrating as I need a working laptop. Everything is updated on Garuda and no clue where else to turn besides trying a new distro. Idk how to delete this post so, I’ll mark it as solved. I appreciate the suggestion/help anyways in trying to fix it. thanks

You need to take ownership of a newly formatted drive.



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.