USB flash no longer working

I installed BalenaEtcher thinking I could help you troubleshoot, but I'm afraid it worked perfectly fine for me.

The flash drive I used is very old and has many writes. I did not prepare it in any special way before hand, it still had an old ISO on it which I left as-is.

The flashing process took a few minutes, but it worked just fine. I booted the live environment afterward also, and again everything was working as expected.

I'm back to wondering how you installed this program.

It is unclear what this means. Are you using the GUI software center?

It looks like there is an AUR version, and a chaotic AUR version. I just installed the AUR version and it worked fine; if you have the chaotic AUR version maybe try to uninstall it and switch. What are you using for a helper?

3 Likes

Just checked again, it seems like the chaotic AUR version.

Searched pamac for etcher and installed the first in the row that was marked with 'repository'. Is chaotic AUR instable or uses untested versions? Thx for your active testing to get to the bottom of that issue.

Puh, quite a strong requesting, while I thought I had answered all of your questions before in my answers toward others. But I try to answer them as you asked me. And yes, my appologies for possible misunderstandings due to unclear phrases, I try my best to translate into English, but sometimes I might not be that clear in words than expected.

As written above, I did right-click on the USB device and checked settings to read about the permissions.
Yes, I'm logged in as the first and only user.
It is physically the same computer with a SSD-switcher rack, as described above. I simply change SSD's to switch between different Linux OS and Windows 7.

I only had to reclaim partitions a few years ago, when I used dual-boot. When accessing built-in HD's right after installation only root PW is required to get access until I was able to write them into my /etc/fstab. I was never confronted with claiming USB drives, but @BluishHumility pointed me on the chaotic AUR installation, which I will change to AUR version next.

Yes, also described in my answers above that other distributions did not show the issue. Still have to test if the AUR version of balena-etcher does not produce the issue.

Yes, I agree that the language barrier may have supported misunderstanding. I had my experiences of toxic forum comments on one other Linux distribution already, so I probably got @tbg comment in the wrong throat. I can't know if it was ment as a funny linguistic joke or if he really wanted me to leave Garuda for Manjaro because I posted two requests in a week and stated that my test writing an USB on Manjaro worked without an issue. Is there any rivality about different Linux distributions going on, that I should take into consideration when openly posting the steps I've done to testing so far?

Look, I also do not plan or intend holding a grudge over a simple misunderstanding. Probably both of us have only met in the worst scenario ever and he is still helping, what I welcome very much. I'm not a pro, as you might already have found out and I learned that if you can't find answers by using the searching tool, asking for assistance in a forum is the best way to get results. I do know that the Garuda team is a small one, so I do not expect them to have answers for all of my questions. My first post about deleted links on Chromium was only ment to give a report for R&D, while this one (second) was beyond what I was able to find out myself, so I asked for assistance.

Thanks for answering in detail, it helps to exclude hypotheses.
And yes, people is quite tongue-in-cheek around here, including me. No grudges whatsoever.
But what were those permissions in the end? Read write for all or not?

1 Like

Not exactly. The way I understand it, the chaotic AUR packages are pre-built, which often is perfectly fine and very convenient. Every once in a while, however, one of these pre-built packages doesn't work right. It can be a very system-specific issue, and sometimes using the regular AUR (and building the package yourself) can be a fix.

If I can add another suggestion to the pile you have already received, I've been using the paru AUR helper for a while now and I think it is just great. If you would rather not resort to using the terminal you will not like it, but if you are feeling up to it you can check it out here: https://github.com/morganamilo/paru

1 Like

Thx a lot for pointing in the right direction. Changing the chaotic AUR balena-etcher version into the pure AUR version solved the issue. I marked your above post as solution. Formatting and flashing an USB drive with the AUR version worked without an issue. Another time, thank you very much @BluishHumility and also to all others that looked into it.

I did not know chaotic AUR before using Garuda and assumed it would be a somewhat guided version of AUR as it is marked as 'repository'. Good to get your response so I will avoid that trap next.

Well, the 'paru' AUR helper is only terminal based, so far I can see on first view. When I did my first steps into Arch distributions, I installed and compiled every AUR paket with the terminal. It is very convenient for me to have Pamac doing that part for me now and I don't want to miss that. Just too much convenient GUI and Windows based routines I guess. Nevertheless I think it is necessary to understand how things are running underneath. I can make use of the terminal, but except doing manual updates it is not the native way for me.

The issue is solved, but it seems I can't edit my first post to mark it as [solved]. Any help in changing the topic would be very kind.

Thx to all for finding a solution, especially to @BluishHumility who helped testing and pointed me toward the solution.

There's yup too, still work in progress but isn't too bad.
It's a text user interface over pacman and an AUR helper like paru.
Biggest complaint I have about it is that it confirms installing dependencies instead of asking.
But it's very convenient to find package names/versions/descriptions from the terminal.
And, handles calling makepkg after reviewing the pkgbuild file.

1 Like

That's not how Discourse works. See the "..." menu at the bottom of posts? Check the box that indicates the correct user's post.

2 Likes

I'm not sure what you mean by ''...'' when I get this view:

But in the 'Issues & Assistance' thread, I can see this topic marked with a green checkbox, what might mark it as solved.

It is not as important as breathing therefore ...

image

a little initiative would sometimes be helpful, we can't always help you.

The first post in a help forum can never be the solution, so you can't mark it as a solution.

1 Like

I think he is referring to what is somewhat of a tradition in other styles of forum, where a person who had their issue solved would go back and edit the title of their post so it would say something like:

[SOLVED] Dropped to emergency shell--help!

It helps people searching after a fix find similar posts that might have a solution.

Thanks to our excellent green check mark boxes we don't need to bother with that here!

2 Likes

I know this is fixed which is great, but just as an aside, I've had the same a couple of times over the years (Suse and Deb) where a previously bootable stick just doesn't want to play ball - so rather than try additional software, i always found that just creating a new partition table on the stick with the likes of gparted (after a couple of clicks), zaps it and then it's fine to use whatever to create another bootable image on it. btw, i use Cinnamon and its working fine on this machine, so it doesn't look like a "bug" as such, but rather a "quirk", a combo of factors and not Garuda (or suse or deb for me before) specific.

3 Likes

I do not want to invent the wheel again, but when I hit the '...' I do get the look as I have posted above:

Here I am struggling to find the correct translation for:

So, we either got another language barrier here or by not reading my previous posts it came to a misunderstanding.

The reason for the misunderstanding is that @c00ter simply cuttet out the meaning of my text in his quote:

1 Like

Exactly, what I wanted to do. Thank you @BluishHumility

1 Like

@Kepos,

Oh my goodness, I apologize. The last thing I wish to be is misleading.

This is exactly the correct method [SOLVED] of prepending a post as solved in the Arch Linux Forum(s), and you will not be respected there if you do not do so in this manner. There are reasons. However, they do not use something as modern as Discourse (if you've followed them for a while, you probably understand this). :wink:

But this is a Discourse-based forum and things work a bit differently. Here's a good primer from a local user; How to write a nicely formatted post in Discourse/Forum

But you know something? You persisted. You commented the solving post, and the fact you then marked it in the correct manner speaks louder than words.

So, hey, thanks!
:smiley:

1 Like

This is only in the first post. Check other posts.

1 Like

Well, I do differentiate in English between [solved] and 'solution'. Besides that, you still seem not willing to recognize the meaning of my second sentence for your flamboyant comment.

On the other side, everybody should have the right to ignore, what he doesn't want to recognize. :wink:

Well you can keep it as you like but if someone has found a solution for you, the topic can be marked as solved.

Before this gets too philosophical, I'll close here.

6 Likes