USB flash no longer working

Hello,

just recognized, that all attempts to format or flash an USB-drive fail with Garuda Cinnamon Edition.

Garuda-inxi output:

Garuda-inxi summary

```
System:
  Kernel: 5.16.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=3acd578e-46d5-4b3e-b159-d07795e6e296 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.31 info: plank wm: muffin
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2501
    date: 04/07/2014
CPU:
  Info: model: AMD FX-8350 bits: 64 type: MT MCP arch: Piledriver
    family: 0x15 (21) model-id: 2 stepping: 0 microcode: 0x6000852
  Topology: cpus: 1x cores: 8 smt: enabled cache: L1: 384 KiB
    desc: d-8x16 KiB; i-4x64 KiB L2: 8 MiB desc: 4x2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 2090 high: 2993 min/max: 1400/4000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2515 2: 2993
    3: 1392 4: 1403 5: 1404 6: 1402 7: 2809 8: 2808 bogomips: 64214
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67df
    class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: amdgpu,ati
    unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x285mm (34.2x11.2")
    s-diag: 915mm (36")
  Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.5x13.2") diag: 686mm (27")
  Monitor-2: DVI-D-0 res: 1366x768 hz: 60 dpi: 85
    size: 410x230mm (16.1x9.1") diag: 470mm (18.5")
  OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.44.0
    5.16.3-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.3-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel port: c000
    bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 4.21 TiB used: 1.57 TiB (37.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 120GB
    size: 111.8 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 00RL scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DX001-1CM162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC44
    scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD5000AACS-00G8B0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 4C05
    scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital
    model: WD10EZEX-60WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: MBR
  ID-5: /dev/sde maj-min: 8:64 vendor: Western Digital
    model: WD20EARS-00MVWB0 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: AB51
    scheme: GPT
  ID-6: /dev/sdf maj-min: 8:80 type: USB vendor: Transcend
    model: JetFlash Transcend 8GB size: 7.48 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: 8.07 scheme: MBR
Partition:
  ID-1: / raw-size: 107.59 GiB size: 107.59 GiB (100.00%)
    used: 31.19 GiB (29.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 489 MiB size: 488 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 931.51 GiB size: 915.89 GiB (98.32%)
    used: 81.26 GiB (8.9%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/log raw-size: 107.59 GiB size: 107.59 GiB (100.00%)
    used: 31.19 GiB (29.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-5: /var/tmp raw-size: 107.59 GiB size: 107.59 GiB (100.00%)
    used: 31.19 GiB (29.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 3.73 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
  ID-2: swap-2 type: zram size: 15.53 GiB used: 1.5 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 26.5 C mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1169
Info:
  Processes: 397 Uptime: 2h 1m wakeups: 0 Memory: 15.53 GiB
  used: 5.59 GiB (36.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1939 lib: 526 Shell: Zsh v: 5.8
  running-in: tilix inxi: 3.3.12
Garuda:
  System install date:     2021-12-06
  Last full system update: 2022-01-30
  Is partially upgraded:   No
  Using TLP:               No
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
```

Tried several times on Garuda Cinnamon Edition to format an USB-drive with built-in tool for formatting USB-drives. That failed.

Downloaded the newest Garuda distribution from several sources and tried to flash it on my USB-drive several times. All failed at the end with a warning, that 'something has gone wrong', pretty much the same issue as when simply formatting the USB.

Could it be, that under Garuda I do no longer have the rights to format an USB drive? That would be a bug in my eyes, as it is obviously working on other Linux distributions. I also read about similar issues regarding missing rights, so I point in this direction on first place.

Next is to switch to another Linux distribution to verify the assumption.

Thank you for the help.

Try from terminal

sudo dd if=/dev/zero of=/dev/sdX bs=1m

Before that, check carefully what your USB is, instead of /dev/sdX.

4 Likes

Thank you @filo I will take that order into consideration if nothing other might work.

Short update:

As described above, flashing the very same USB-drive with balenaEtcher on another distribution (Manjaro) was perfectly successful, so my suspicion on failed rights to flash USB-drives might be right.

Careful here.
You should update because I think you're still affected by the sudo issue solved a few days ago.
I'm not sure this can really play a role with applications requiring sudo access, anyway it is important to rule this out.

1 Like

I'm doing every update the system mentions to me. Is there anything I have to do additionally? No idea how to do that. Any help would be appreciated.

Open a terminal and enter update (or use relevant button in the Garuda Assistant).

1 Like

I am a little confused, as your thread from 4 days ago was complaining that Garuda wiped your chromium bookmarks. Now you complain you are unable to install Garuda. Which way is it? You can't install Garuda, or Garuda is buggy?

Have you double checked your downloaded ISO's integrity via its checksum?

If Garuda is this much trouble for you, perhaps Manjaro is more up your alley.

3 Likes
  • Update your system, then reboot.
  • Install a different kernel, say the LTS, then reboot.

Problems arising with a BIOS and machine this dated can be expected. The world moves on, especially kernels. Are there any newer BIOS updates for your machine than 2014?

Also, why the mix of MBR vs. GPT drives? That can also be problematic.

Considering all the above, I'd wager this isn't the first time or first distribution this machine may have had problems with, at least with this type configuration.

3 Likes

@tbg , I'm sorry, but requesting assistance for whiped Chromium bookmarks is a different case than flashing/formatting an USB drive. To your knowledge, I downloaded the new ISO for my laptop, but was not able to flash the USB drive under my home computer with Garuda.

Yes, I have double downloaded the ISO from different sources, as I allready described.

Sorry m8, I ask for help and you try to bully me to switch over to Manjaro. That is rude! Just to be clear, I'm quite hyped in favor for Garuda. So let's calm down a bit and talk over the issue.

@c00ter thx the notice and the hints.
Well, I'm using a SSD-switch to be able to use different Linux distributions and one old Windows installation on the very same computer. As it is more comfortable for me to simply exchange SSD's, I do not use the mainboard UEFI system and better use a boot section on every Linux SSD. Tried it the other way around, but that didn't work as desired.

I do have leftover HD's reserved for my Windows 7 data and keep them for some reasons. Several graphical tools, old Windows only games and for easy access on old paperwork.

And no, I never had the issue to be not able to flash or format my USB drive. Garuda shows up to be the first.

Checked another time, 2014 is the latest BIOS for my mainboard. Asus Link

1 Like

Thank you, done that right now. That reminds me on how ArcoLinux has done it that way. I thought doing the usual Pamac updates is sufficient. I'll check that.

Ok, after reboot, I tried to do another 'Garuda-inxi', which failed as the terminal output is following:

Garuda-inxi summary
Garuda-inxi
find-the-command: "Garuda-inxi" is not found locally, searching in repositories...
find-the-command: command not found: Garuda-inxi

Any idea?

A new 'inxi -b' output is following:

inxi -b summary
inxi -b
System:
  Host: Garuda-Arch Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64
    Desktop: Cinnamon 5.2.7 Distro: Garuda Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2501
    date: 04/07/2014
CPU:
  Info: 8-core AMD FX-8350 [MT MCP] speed (MHz): avg: 1470 min/max: 1400/4000
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    driver: amdgpu v: kernel
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: amdgpu,ati
    unloaded: modesetting,radeon resolution: 1: 1920x1080~60Hz 2: 1366x768~60Hz
  OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.44.0
    5.16.5-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.5
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
Drives:
  Local Storage: total: 4.2 TiB used: 1.56 TiB (37.2%)
Info:
  Processes: 368 Uptime: 7m Memory: 15.53 GiB used: 3.61 GiB (23.2%)
  Shell: Zsh inxi: 3.3.12

Short update:

Did some more testings. After update, the issue still exists.
So I did a fresh new 2nd Garuda install with KDE dragonized edition, BTRFS, /home on root on pretty much the same computer. Used balenaEtcher for the flash with a before tested ISO on another distribution. Didn't work. Still the same error right after verifying the flash about 'something has gone wrong'.

It is garuda-inxi not Garuda-inxi

1 Like

What tool is this?

A couple common reasons people get this error message would be trying to flash a compressed image (without decompressing it first), or trying to flash an image without properly elevating your permissions.

A very easy-to-use piece of software that people have been having a lot of success installing Garuda with is Ventoy. Please check it out: ventoy.net

It is easier to use than Etcher (just save the ISO to the flash drive--done), and you can also keep multiple ISOs on there if you want to.

2 Likes

[quote="BluishHumility, post:15, topic:17179"]
What tool is this?

Just searched the menu for 'format' and got the USB-stick-formatter shown, so it is a built-in tool as I didn't install an additional one.

Ok, thx to offer me alternative flashing tools. However, why does BalenaEtcher nor the built-in USB-formatter not work, while it does without any issue on any other Linux distribution but not on Garuda?

I'm pretty sure all this points toward a kind of rights issue from Garuda that is not automatically given on USB drives. I simply installed Garuda Cinnamon DE and additionally installed the tools I usually use from the Garuda repository. I did not change anything myself, so I can't reconstruct that USB issue from any before used Linux distribution. As I couldn't find any according notes with the forum search I posted the request for help. I do not use anything else than the usual offered distribution and tools from its very own sources.

So far I did:

  • check different USB formatting and flash tools
  • check Garuda ISO's from different sources
  • installed and tested with Garuda Cinnamon BTRFS + EXT4
  • installed and tested with Garuda Dragonized edition
  • installed and tested with included /home as well as with outsorced /home on an additional HD
  • tried to view the rights by right-click/setup I do have on that USB drive, which only shows me viewing rights on Garuda

So, why I do not have automatic rights to format or flash an USB drive on Garuda? That's totally unusual to me. Which steps I have to do, to get the rights to flash or format any of my USB sticks?

I see Etcher is an AUR package. How did you install it?

Etcher depends on a polkit authentication agent to elevate your permissions so it can run properly. What is supposed to happen is when you get to a certain point a popup window will ask you to authenticate by entering sudo credentials. If you are not getting that window, that is likely why this program is not working correctly.

Here is a snippet of explanation from the Etcher website:

Keep in mind that, when you download Etcher on a Linux OS, you will most likely have to install some kind of authentication software, since Linux doesn’t have its own built-in ‘run as administrator’ option like Windows does; polkit is the name of the software. Some distributions of Linux will also require downloading a program that allows the execution of GTK dialog boxes; zenity is a good example of such a piece of software, and it comes built-in into some of the more popular distros’ repositories, such as Debian, Ubuntu, and Linux Mint.

If you have a compelling reason to use Etcher as opposed to the other options that have been suggested in this thread, my advice would be to inspect the rather specific polkit setup that Etcher requires and make sure your system is fulfilling the requirements properly.

5 Likes

Use dd as suggested on the very first response.

3 Likes

Thank you @BluishHumility for pointing on the Etcher authentication background. I also asked a friend (also Garuda newbie) to test BalenaEtcher and he got the very same critical error notice after flashing and verifying as I got. I installed the tool from the Garuda repository, so I thought additional authentication is not the case.

So this all pretty much points on the authentication issue with BalenaEtcher on Garuda. Can't say why I did not encounter the same error with different other Linux distributions. Also I had the issue with the built-in USB-formatting tool which brought the error with formatting, so i got the idea that it is a general issue with USB drives.

Ok, that is a path to follow. Thank you all very much for the assistance!

Thank you @tbg I will try that next. It seems we now have found concrete evidence that points on BalenaEtcher, which I installed from Garuda repository, to have overshaded the issue. Still no idea, why the built-in USB formatting tool also brought an error warning...probably because i tried to format an USB stick that was flashed with BalenaEtcher, but that is only a guess from my side.

I'll report back when I checked.
Thank's to all that have helped!

You mentioned permissions in your first post, but did you check the device owner and permissions, and if you did, how?
And what user are you logged in as when trying to format?
Is it the first user created by the installer or another one?
What do you mean by "pretty much the same computer"?
The same one or not? The same model? A similar one?
It shouldn't make a difference but who knows.

I recall when using USB keys I would sometimes have to chown them before being able to write on them. Also a partition on my laptop where I stored boot ISOs while distro hopping, I had to do that to "reclaim" it afterwards. Because the user and group IDs were different or something.
Not sure that's the best to do it but that I did and got my partition writable.

Note that whether a device supports/requires permissions depends on the filesystem, that is the reason writing a corrupted disk image can cause troubles and may require a full wipe.

I can't know if this is what's going on there, but in that case, it's not a bug, just the way things work.

By the way, can that particular device still be formatted with another operating system?

Also, note that different operating systems (not just distributions) have different conventions and different points of view on the safety&security vs convenience tradeoff.
To compare apples with eagles, MacOS users start at 501 (it's 1000 on Linux), executables can be drag-dropped into /Applications, but some operations require rebooting in recovery mode and locating files in obscure locations named with a long hex string, and good luck finding the relevant information. But I digressed.


I don't want to stimulate controversy, on the contrary, but since you mentioned rudeness, I have to admit that at first I thought "here's another one" and perhaps I wasn't alone.
With hindsight, I ascribe that to the language barrier, and probably you were just well meaning in reporting "a bug" -- misunderstanding happens, and it's easy to come across as whining when the first post includes "x doesn't work" "because the distro" "it's a bug of yours" and no actionable technical information. It tickles the mental spam filters. Just my two cents and don't take a fence.

5 Likes