Updating Error. error: failed to commit transaction (conflicting files)

Hello Garuda users.

Kernel: 5.18.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=26dbe17b-c245-43ba-95e4-300eaa30b288 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Portable System: Alienware product: M17xR4 v: A15
serial: <superuser required>
Mobo: Alienware model: M17xR4 v: A15 serial: <superuser required>
UEFI: Alienware v: A15 date: 05/28/2018
ID-1: BAT1 charge: 44.3 Wh (100.0%) condition: 44.3/93.2 Wh (47.5%)
volts: 12.5 min: 11.1 model: SIMPLO PABAS0241231 type: Li-ion
serial: <filter> status: full
Info: model: Intel Core i7-3630QM bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2565 high: 3335 min/max: 1200/3400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2088 2: 3292 3: 3198
4: 3335 5: 1321 6: 1350 7: 2685 8: 3252 bogomips: 38311
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
v: kernel arch: Gen7 process: Intel 22nm built: 2012-13 ports:
active: VGA-1 off: LVDS-1
empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: NVIDIA GF114M [GeForce GTX 675M] vendor: Dell driver: nouveau
v: kernel non-free: 390.xx+ status: legacy-active (EOL~late 2022)
arch: Fermi process: 40/28nm built: 2010-16 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 ports: active: none empty: DP-4 bus-ID: 01:00.0
chip-ID: 10de:1212 class-ID: 0300
Device-3: Suyin Laptop_Integrated_Webcam_FHD type: USB driver: uvcvideo
bus-ID: 1-1.5:4 chip-ID: 064e:8127 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: intel,nouveau unloaded: modesetting
alternate: fbdev,nv,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: LVDS-1 mapped: LVDS1 note: disabled model: LG Display 0x0357
built: 2011 res: N/A dpi: 106 gamma: 1.2 size: 382x215mm (15.04x8.46")
diag: 438mm (17.3") ratio: 16:9 modes: 1600x900
Monitor-2: VGA-1 mapped: VGA1 pos: primary model: Dell P2719H
serial: <filter> built: 2019 res: 1920x1080 hz: 60 dpi: 81 gamma: 1.2
size: 600x340mm (23.62x13.39") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
v: 4.2 Mesa 22.1.3 direct render: Yes
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Device-2: NVIDIA GF114 HDMI Audio vendor: Dell driver: snd_hda_intel
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e0c class-ID: 0403
Sound Server-1: ALSA v: k5.18.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Device-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Dell
driver: atl1c v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000
bus-ID: 07:00.0 chip-ID: 1969:1083 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 08:00.0 chip-ID: 8086:0887
class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB
driver: btusb v: 0.8 bus-ID: 2-1.5:3 chip-ID: 8087:07da class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 4060 bus-ID: 00:1f.2 chip-ID: 8086:282a rev: N/A
class-ID: 0104
Local Storage: total: 465.76 GiB used: 59.71 GiB (12.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9500423AS
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: DEM1
scheme: GPT
ID-1: / raw-size: 465.5 GiB size: 465.5 GiB (100.00%)
used: 59.71 GiB (12.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.5 GiB size: 465.5 GiB (100.00%)
used: 59.71 GiB (12.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.5 GiB size: 465.5 GiB (100.00%)
used: 59.71 GiB (12.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.5 GiB size: 465.5 GiB (100.00%)
used: 59.71 GiB (12.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.51 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 70.0 C mobo: N/A gpu: nouveau temp: 46.0 C
Fan Speeds (RPM): N/A
Processes: 262 Uptime: 7h 4m wakeups: 2 Memory: 15.51 GiB
used: 2.95 GiB (19.0%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1815
lib: 526 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.5-1):
System install date:     2021-08-08
Last full system update: 2022-07-21
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift (maybe)
Failed units:

Every time I try to update I keep getting this error:

error: failed to commit transaction (conflicting files)
thunderbird-appmenu: /usr/lib/thunderbird/distribution/distribution.ini exists in filesystem
Errors occurred, no packages were upgraded.

I got this error. I am sure someone here will post a CLI command to force override it, but I used Bauh package manager and it was the only one that showed this error and asked me if I wanted to proceed. I said yes! It worked....on both my systems.


I am assuming the OP hasn't updated Thunderbird to the new UI changes put forth in TB recently? The only way around it is forcing the upgrade or removing TB and that .ini file and reinstalling everything, else it will block you from doing any upgrades....or just use Bauh to upgrade. :thinking:

This has come up a few times in the past couple weeks for this exact Thunderbird package, for example here: Garuda-update fails due to "conflicting files" and here: Error updating system.

The link Kayo posted not only fixes the problem, it also briefly explains why this error sometimes comes up in the first place. It's good information if you are interested in learning more about the mechanics behind your system.

It also has the benefit of being a solution that will work every time; I do not know if the same is true for Bauh, or any other package manager, because I do not know specifically how they are resolving the issue.


I still rather new to Linux, how do I what you suggested?

I tried to upgrade just Thunderbird and still getting the same error.

Just follow


Thanks you all for your time and patience, system is now fully updating.

1 Like

The solution goes to @Kayo , I'm only the reminder of the post :slight_smile:
I just change it :smiley:


Thanks @Kayo



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.