Update today broke boot

Garuda will not boot, freezes after grub with flashing curser.
Can’t boot, tried boot repair from Live USB but would not CH root into it I guess.
Not sure how to do that.

Garud-inxi

garuda-inxi
System:
  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda root=miso:LABEL=GARUDA_CINNAMON_RAPTOR quiet
    systemd.show_status=1 ibt=off systemd.unified_cgroup_hierarchy=1
    driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
    rdinit=/vtoy/vtoy
  Desktop: Cinnamon v: 5.8.4 tk: GTK v: 3.24.38 wm: muffin vt: 7 dm: LightDM
    v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: CM5571 v: Rev X.0x
    serial: <superuser required> BIOS: American Megatrends v: 0221
    date: 11/03/2009
CPU:
  Info: model: Pentium E5400 bits: 64 type: MCP arch: Penryn level: v1
    built: 2008 process: Intel 45nm family: 6 model-id: 0x17 (23)
    stepping: 0xA (10) microcode: 0xA0B
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 2 MiB desc: 1x2 MiB
  Speed (MHz): avg: 2700 min/max: 1203/2700 scaling: driver: acpi-cpufreq
    governor: schedutil cores: 1: 2700 2: 2700 bogomips: 10800
  Flags: ht lm nx pae sse sse2 sse3 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GF106 [GeForce GTS 450] driver: nouveau v: kernel non-free:
    series: 390.xx+ status: legacy-active (EOL~late 2022) arch: Fermi
    code: GF1xx process: 40/28nm built: 2010-16 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 ports: active: VGA-1 empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:0dc4 class-ID: 0300 temp: 36.0 C
  Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: nouveau
    unloaded: modesetting alternate: fbdev,nv,vesa dri: nouveau gpu: nouveau
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: VGA-1 model: HannSpree/HannStar iH253D serial: <filter>
    built: 2011 res: 1920x1080 hz: 60 dpi: 89 gamma: 1.2
    size: 550x340mm (21.65x13.39") diag: 647mm (25.5") ratio: 16:10 modes:
    max: 1920x1080 min: 720x400
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: cpu name: llvmpipe (LLVM
    16.0.6 128 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: Intel 82801JI HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3a3e class-ID: 0403
  Device-2: NVIDIA GF106 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0be9 class-ID: 0403
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Ethernet I225-V driver: igc v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 link-max: gen: 2 speed: 5 GT/s port: N/A
    bus-ID: 02:00.0 chip-ID: 8086:15f3 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.38 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: SSD serial: <filter> fw-rev: DB6Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: A-Data model: SU650 size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 1c55 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST31000524AS
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: <unknown>
    tech: HDD rpm: 7200 serial: <filter> fw-rev: JC4B scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: PNY model: USB 2.0 FD size: 28.91 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s
    lanes: 1 mode: 2.0 speed: 3.0 Gb/s tech: N/A serial: <filter> fw-rev: PMAP
    scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  Message: No partition data found.
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 14.94 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 2 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 32.0 C mobo: 28.0 C gpu: nouveau temp: 36.0 C
  Fan Speeds (rpm): cpu: 788 psu: 0 case-1: 3534 gpu: nouveau fan: 1170
  Power: 12v: 12.41 5v: N/A 3.3v: 3.38 vbat: N/A gpu: nouveau mV: 962.00
Info:
  Processes: 181 Uptime: 2m wakeups: 0 Memory: total: 16 GiB note: est.
  available: 14.94 GiB used: 1.28 GiB (8.6%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1269 libs: 366 tools: paru Shell: fish v: 3.6.1
  running-in: gnome-terminal inxi: 3.3.30
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.17-1):
  System install date:     2024-05-22
  Last full system update: 2024-05-22 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            

When you try booting into the system that freezes, have you tried changing ttys? It’s likely that gnome failed to start.
If possible, run garuda-inxi from the system that isn’t working.

Try swapping ttys like this
https://wiki.archlinux.org/title/Getty#Add_additional_virtual_consoles

Agetty manages virtual consoles and six of these virtual consoles are provided by default in Arch Linux. They are usually accessible by pressing Ctrl+Alt+F1 through Ctrl+Alt+F6. 

This should allow you access to a shell even if the desktop hasn’t loaded.

Ignore this, the guide linked below by Duke187 is better.

To chroot into the system with a live usb, you need to mount the main drive then chroot into it like this:

arch-chroot /path/to/new/root

chroot - ArchWiki

there is way in a post =)

If it’s blinking then it’s not a freeze. Can you load a snapshot?

Yeah, broke my boot also, I run KDE version. After the update when rebooting it goes through the initial setup but I guess when the login screen is about to load screen goes black and keyboard freezes. Have to do a cold reboot and use snapshot to before the update.
This is the first problem I have had with Garuda since I started using it 2 years ago. Hopefully a future update will fix it.

Just posting to tell you you are not alone.

Well I decided to wipe and reinstall, only thing now is the nvidia driver does not work, when I install with open source do updates and it asks if you want to install nvidia extra drivers, it breaks the resolution and will not go off 480x 600 or something.
tried a couple different things but by the inxi it looks like the old NVIDIA GF106 [GeForce GTS 450] is only using the nouveau driver. It usually runs on the 390.xx driver and has in the past with Mint and other Linux distros.
The nouveau looks fine and has full 1920x1080, just some things will not use it as in Boinc can’t fine nvidia card.

I have AMD 7800XT , but a (done 3 now) reinstall doesnt help me. Still freezes after the update. But lucklily I chose to install the LTS-kernel , and it works even after the update. So I’ll runt that for a while to see if future updates will fix the problem.