Update Failing "breaks dependency"

Don't know exactly how to solve this, I read this post

But as the problem was that the person had uncommented "both lines in pacman.conf for 32bit multilib" and I have no idea how to do this, I guess it's not of much help
Unless I did something wrong while merging my files since I'm yet pretty noobie at it hehe

Anyways, here is my version of the problem:

upd
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
# When:       2021-06-19 13:24:49 UTC
# From:       https://www.archlinux.org/mirrors/status/json/
# Retrieved:  2021-06-19 13:24:32 UTC
# Last Check: 2021-06-19 12:18:10 UTC

Server = https://america.mirror.pkgbuild.com/$repo/os/$arch
Server = https://archmirror.it/repos/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
Server = https://mirror.telepoint.bg/archlinux/$repo/os/$arch
Server = https://asia.mirror.pkgbuild.com/$repo/os/$arch
:: Synchronizing package databases...
 core
 extra                                                                     134,3 KiB   131 KiB/s 00:01 [------------------------------------------------------------] 100%
 community                                                                1565,8 KiB  1507 KiB/s 00:01 [------------------------------------------------------------] 100%
 chaotic-aur                                                                 5,6 MiB  5,40 MiB/s 00:01 [------------------------------------------------------------] 100%
:: Starting full system upgrade...                                        1119,0 KiB   459 KiB/s 00:02 [------------------------------------------------------------] 100%
warning: balena-etcher: local (2:1.5.119-1) is newer than chaotic-aur (2:1.5.116-1)
warning: rare-git: local (1.5_beta.r5.gbe25abe-1) is newer than chaotic-aur (1.5_beta2.r17.g9fb63e4-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing alsa-lib (1.2.5.1-3) breaks dependency 'alsa-lib=1.2.5' required by lib32-alsa-lib
:: installing libpcap (1.10.1-1) breaks dependency 'libpcap=1.10.0' required by lib32-libpcap

Thanks in advance : 3

sudo micro /etc/pacman.conf
[multilib]
Include = /etc/pacman.d/mirrorlist
6 Likes

SGS you're like a guardian angel of the forum, did you know that?

Thank you so much \o/

3 Likes

I know :wink: , but not everyone is convinced. :smiley:

5 Likes

AoriOjin is so lucky, that this thread is still not in #4xx

4 Likes

Next time it will be :wink:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.