Installing libelf (0.185-1) breaks dependency 'libelf=0.184'

Do we really need this multilib stuff, which seems to be for 32bit applications compatibility?
https://www.linuxsecrets.com/archlinux-wiki/wiki.archlinux.org/index.php/Multilib.html
There are also instructions to completely remove It, but I wouldn't dare, of course, just for info...
Edit:
I see e.g. wine and steam might need It
https://wiki.archlinux.org/title/Official_repositories#multilib

4 Likes

Its not required unless you want to install applications which depend on it - WINE for example is such a case. The Garuda settings manager also depends on lib32 stuff so a default installation has it enabled :slight_smile:

4 Likes

Glad you, asked for confirmation on the uncommenting of the multilib, I had the same mistake @SGS had lol :rofl: :rofl: :rofl:

I do want to recommend Garuda to friends and family but it ain't maintenance free. Why 32 bit repo was disabled if 32bit apps are in use? I didn't tweak anything, all is out of the box. Such stupid errors are a deal breakers.

Probably the pacman 6 update introduced a new pacman.conf which hasnt been processed properly :eyes:

1 Like

Never recommend arch unless you really know the person LOVES diy.

1 Like

It seems it was commented in the new conf.
So it was a matter of proper merging.
At least we'll know what to do next time :blush:

2 Likes

Linux isn't. Give them iOS or macOS instead.

You removed it from your pacman.conf.

No comment.

3 Likes

new pacman.conf came with it disabled. I did remove it in only in a sense that I said "YES" to a question if I want to overwrite the old one. I did not manually edit it out. but it is the easiest blame the user

In the announcement about this update was a quite precise instruction on how to properly find and migrate the settings. Reading those doesnt hurt :wink:

4 Likes

:man_shrugging:

3 Likes
sudo pacman -Syu
[sudo] password for yoda:
warning: config file /etc/pacman.d/mirrorlist, line 11: directive 'Server' in section 'options' not recognized
.
warning: config file /etc/pacman.d/mirrorlist, line 14: directive 'Server' in section 'options' not recognized
.
warning: config file /etc/pacman.d/mirrorlist, line 17: directive 'Server' in section 'options' not recognized
.
warning: config file /etc/pacman.d/mirrorlist, line 20: directive 'Server' in section 'options' not recognized
.
warning: config file /etc/pacman.conf, line 88: directive 'enable the multilib repositories as required here.'
in section 'community' not recognized.
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
:: Starting full system upgrade...
warning: electron9: local (9.4.4-2) is newer than community (9.4.4-1)
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n]

I t tries to follow some advices by commenting or uncommenting stuff and the result is now :


# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#Color
#NoProgressBar
CheckSpace
#VerbosePkgLists
#ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
# Include = /etc/pacman.d/mirrorlist

[core]
# Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

#[multilib]
#Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

[multilib]
Include = /etc/pacman.d/mirrorlist
1 Like

Look more closely at what you've done one the sixth line here.

2 Likes

Also uncomment

to read
[core]
Include = /etc/pacman.d/mirrorlist

4 Likes

So I removed the # in front of the multilip in pacman.conf. Did another pacman -Syyu. I get the same dependency error still. I have read through the pacman 6 thread as well and have already followed that guide.

Any other suggestions?

Post the conf as text, please.

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
#NoProgressBar
CheckSpace
ILoveCandy
#VerbosePkgLists
#ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

#[multilib]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

[chaotic-aur]
Include = /etc/pacman.d/chaotic-mirrorlist

Delete # in front of [multilib] too.

[multilib]
Include = /etc/pacman.d/mirrorlist

Holy hell. I was going too fast. Thanks for correcting my PEBCAK

1 Like