Unpacking the image file "/run/miso/bootmnt/garuda/x86_64/rootfs_sfs" failed

After installing a larger HD for the distro, I wanted to install the Mate version this time. It aborted with an error message. Then I tried the XFCE version, same problem. When unpacking the second installation archive, I get an abort at the end with the following error message:
Unpacking the image file "/run/miso/bootmnt/garuda/x86_64/rootfs_sfs" failed.
rsync failed with error code 11

Please help me!


First, welcome to Garuda Linux. :slight_smile:

Second, please tell us what application you used to write the ISO to USB.


1 Like

BalenaEtcher under Ubuntu-Mate20.04.1

I have written all distros with it so far without any problems.

OK, then assuming the ISO is valid, please tell us more about your hardware. First, boot into the LiveISO, then please post the terminal output of inxi -Fxxxza

I also checked the sha256 after downloading!

1 Like

ok, will do!

We'll get you up and running, but I'm AFK for a few hours. Persevere! :smiley:

rsync code 11 means not enough disk space to install
maybe wrong diskinstall settings

sorry for a stupid question is it a new installation or 2 or 3 installs on same hdd

1 Like
inxi -Fxxxza                                                               ─╯
  Kernel: 5.9.12-97-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: intel_pstate=passive BOOT_IMAGE=/boot/vmlinuz-x86_64 
  lang=de_DE keytable=fr tz=UTC driver=nonfree nouveau.modeset=0 
  i915.modeset=1 radeon.modeset=1 misobasedir=garuda 
  misolabel=GARUDA_XFCE_ROLLING_ quiet systemd.show_status=1 splash 
  rd.udev.log_priority=3 vt.global_cursor_default=0 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Garuda Linux 
  Type: Desktop Mobo: BIOSTAR model: A68MDE serial: <filter> 
  UEFI: American Megatrends v: 4.6.5 date: 10/05/2018 
  Info: Quad Core model: AMD A8-7680 Radeon R7 10 Compute Cores 4C+6G 
  bits: 64 type: MCP arch: Excavator family: 15 (21) model-id: 60 (96) 
  stepping: 1 microcode: 600611A L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 27974 
  Speed: 3716 MHz min/max: 1400/3500 MHz boost: enabled Core speeds (MHz): 
  1: 3716 2: 3664 3: 3693 4: 3682 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 02:00.0 
  chip ID: 1002:67df 
  Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 38 
  size: 1280x720mm (50.4x28.3") diag: 1469mm (57.8") 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.39.0 
  5.9.12-97-tkg-bmq LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD FCH Azalia vendor: Biostar Microtech Intl Corp 
  driver: snd_hda_intel v: kernel bus ID: 00:14.2 chip ID: 1022:780d 
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: Sapphire Limited driver: snd_hda_intel v: kernel bus ID: 02:00.1 
  chip ID: 1002:aaf0 
  Sound Server: ALSA v: k5.9.12-97-tkg-bmq 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Biostar Microtech Intl Corp driver: r8169 v: kernel port: e000 
  bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 3.51 TiB used: 1.08 GiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: SanDisk model: SDSSDHP128G size: 119.24 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 6RL scheme: GPT 
  ID-2: /dev/sdb vendor: TCSunBow model: X3 1TB size: 931.51 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1A 
  scheme: GPT 
  ID-3: /dev/sdc model: SSD 480GB size: 447.13 GiB block size: 
  physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 6A0 
  scheme: MBR 
  ID-4: /dev/sdd vendor: SanDisk model: SDSSDA240G size: 223.57 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 00RL scheme: GPT 
  ID-5: /dev/sde vendor: Toshiba model: DT01ACA200 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: ABB0 scheme: GPT 
  ID-6: /dev/sdf type: USB model: USB DISK 3.0 size: 7.21 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 11.67 GiB used: 1.08 GiB (9.2%) fs: overlay 
  source: ERR-102 
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 3.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  System Temperatures: cpu: 48.4 C mobo: N/A gpu: amdgpu temp: 34.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1333 
  Processes: 232 Uptime: 4m wakeups: 0 Memory: 15.56 GiB 
  used: 3.72 GiB (23.9%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: pacman: 1316 lib: 309 Shell: Zsh v: 5.8 
  running in: xfce4-terminal inxi: 3.1.09

ModEdit: Please, use proper format for terminal output. Look for Discourse markdown syntax.

Its a new installation on a SSD Sandisc 240GB. Exclusivly!

I will burn the distro again and use the discimagewriter of Ubuntu.

funfact i'm always use making isos for installing under windows sooo i'm not a specialist
i know balea etcher under windows
and know that etcher only write one to one the iso to usb and have no boot settings intern

i don't know if it helps but you can try a other iso to usb program if it is etchers fault
for example yumi it's an multiboot program under windows it works fine

Thanks, but I only use WIN10 for gaming, everything else I do with LINUX!

There's always dd
Using dd to create usb boot stick from iso file

At least 40 gb for root with btrfs as filesystem is recommended

Do you mean the installer application?

okay i prove it on my own
first install etcher and download the iso mate
then write it on stick
and it start when reboot into installer live version

klick on install and choose hdd option delete everthing newinstall

then wait when finished and it starts with uefi boot from new installed mate version

i have no problems on my system to install


install everthing from an hp-envy-convertible with intel-i5 gen 7 with enough ram
and used a new 128gb hdd over usb controller

maybe your hdd has an boot partition from win 10 or other systems that this make it the installer to install it not correctly

1 Like

This means one or more of the following:

  1. You have run out of space
  2. The installer image was corrupt
  3. The image was not written correctly to the installation medium
  4. The installation medium has an issue (e.g. a broken or corrupted USB flash drive)

So, the system is running.
Thanks to all for your suggestions.
What was the problem?
I had installed the AMDGPUPRO driver from AMD. When I looked for another USB stitch software and installed it, I got the error that the DKMS could not be updated.
So I uninstalled the AMD driver, deleted the USB stick and rewrote it with Etcher. To be on the safe side, I also completely deleted the target HD.
Then I specified the whole disk as a partition and that worked!
So once again THANK YOU to all of you!