Unknown Error Code 100

I have had this issue with different programs with them all coming from "Error - Plasma" and from "Error - KIOExec" Both referencing a "Unknown error code 100". I'll give a few examples.

With creating a .py file and setting it as an executable, I get specifically;

Unknown error code 100
execvp: Exec format error
Please send a full bug report at https://bugs.kde.org.

With downloading "Mod Organizer 2" from Lutris, I get;

Unknown error code 100
Could not find the program 'modorganizer2-nxm-broker.sh'
Please send a full bug report at https://bugs.kde.org.

What should I do about fixing these errors? What am I missing?

System:    Kernel: 5.14.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=dd33517c-611b-45b8-add1-7a2ea3218b75
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84) v: 1.0 serial: <filter>
UEFI: American Megatrends LLC. v: 1.60 date: 05/28/2021
CPU:       Info: 12-Core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25)
model-id: 21 (33) stepping: 0 microcode: A201009 cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 177612
Speed: 3699 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 3699 2: 3728
3: 4002 4: 4679 5: 3598 6: 3599 7: 3595 8: 3593 9: 3589 10: 4211 11: 3598 12: 3586 13: 3599
14: 3594 15: 3613 16: 3762 17: 3597 18: 3588 19: 3591 20: 3594 21: 3600 22: 3594 23: 3599
24: 3599
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GA102 [GeForce RTX 3080] vendor: eVga.com. driver: nvidia v: 470.74
alternate: nouveau,nvidia_drm bus-ID: 2d:00.0 chip-ID: 10de:2206 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 81 s-size: 1204x343mm (47.4x13.5") s-diag: 1252mm (49.3")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4")
diag: 690mm (27.2")
Monitor-2: DP-0 res: 1920x1080 dpi: 82 size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL: renderer: NVIDIA GeForce RTX 3080/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes
Audio:     Device-1: NVIDIA GA102 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel
bus-ID: 2d:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.14.13-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 v: kernel port: f000
bus-ID: 26:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.73 TiB used: 232.51 GiB (8.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXE7 temp: 35.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXE7 temp: 31.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 4B6Q
Partition: ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 37.48 GiB (75.0%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:4
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 881.01 GiB size: 881.01 GiB (100.00%) used: 195.03 GiB (22.1%) fs: btrfs
dev: /dev/nvme0n1p3 maj-min: 259:5
ID-4: /var/log raw-size: 50 GiB size: 50 GiB (100.00%) used: 37.48 GiB (75.0%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:4
ID-5: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%) used: 37.48 GiB (75.0%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:4
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 45.5 C mobo: 34.0 C gpu: nvidia temp: 26 C
Fan Speeds (RPM): fan-1: 1040 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0 fan-7: 0 gpu: nvidia
fan: 0%
Info:      Processes: 506 Uptime: 6h 33m wakeups: 0 Memory: 31.27 GiB used: 10.06 GiB (32.2%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
pacman: 1866 lib: 544 flatpak: 0 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: konsole inxi: 3.3.07
Please send a full bug report at https://bugs.kde.org.

We are not KDE :wink:

Welcome to Garuda Linux Forum :slight_smile:

echo -e {$PATH\n}
find -iname '*modorganizer2-nxm-broker.sh*'  <-- or something like that, check if executable
2 Likes

Did you reboot after your last update?

2 Likes
/home/user/.local/bin
/usr/local/sbin
/usr/local/bin
/usr/bin
/opt/cuda/bin
/opt/cuda/nsight_compute
/opt/cuda/nsight_systems/bin
/usr/lib/jvm/default/bin
/usr/bin/site_perl
/usr/bin/vendor_perl
/usr/bin/core_perl

./.local/share/applications/modorganizer2-nxm-broker.sh.desktop
./.local/bin/modorganizer2-nxm-broker.sh
./Desktop/modorganizer2-nxm-broker.sh
./Desktop/modorganizer2-nxm-broker.sh.desktop

Yes, I have.

1 Like

Just thought I'd check as many times this is forgotten by users new to a rolling distro.

4 Likes

Had Garuda for about a month now. Ever since I tried to create a Python file, thought I should check this in since I got the same error code more than once.

Executable?
Try to post the bug to KDE.

I cant help about, sorry.

Will do, just thought I should ask, but thanks.

One question though. Which product should I enter as a bug? Should it be the lattedock since the version of Garuda I use uses that? Which is it for the error the Python file made?

Oh, I thought it is a python problem.

I have no problems with latte-dock may be the developer @psifidotos can help?

1 Like

The problem is something about executables and I've had the problem a few times ever since beginning Garuda. I just don't know where in this "Pick a product on which to enter a bug" in bugs.kde.org I should address it to?

It seems the qt5-base is broken, or as far as I read. How would I go about downgrading it to make it work as it should or is there a way I can download something else to fix it?

Info gotten from: Qt5-base 5.15.2+kde+r203-1 severely breaks .desktop files - #17 by UltraBlack
and 439185 – qt5-base breaks desktop files

Lets bump +1

We don't do that here. It is considered rude behavior.

2 Likes

So, am I supposed to let it die after a 2 day time period without an answer? I'm now looking for a way to downgrade the qt5-base.

If you have been continuing troubleshooting efforts, then keep very detailed records of everything you have tested as well as any related search information you have uncovered. If no one has posted any further advice regarding your issue, then post the detailed list of troubleshooting procedures you have recently performed. Also post any new info you have uncovered online since your last post, (be sure to post links).

This demonstrates that you are being proactive by continuing to research and troubleshoot on your own (even if others aren't currently offering suggestions). Posting a detailed synopsis shows forum helpers that you are motivated and are attempting to work through your issues yourself. This goes a long ways to getting some good will towards yourself, as this shows initiative. This is actually a very important factor, because helpers on the forum are far more likely to respond to users who demonstrate they are not lazy and don't require being spoon fed every answer.

Most forum helpers find empty bumps a turn off. Empty bumps mostly tend to just get you a bad reputation and even less assistance on the forum. Our forum does not look favorably upon empty bumps and they are strongly discouraged.

3 Likes

Alright, I understand. Then here's an update. Updating the qt5-base to the version that was released today did not fix anything. Planning to downgrade to
qt5-base-5.15.2+kde+r200-1-x86_64.pkg.tar.zst
from Index of /packages/q/qt5-base/ and all other qt5 packages to match versions of the qt5_base now that I have.
P.S. I should also add I am following the guide from How to Downgrade a Package in Arch Linux (Manjaro) - YouTube

Reverted and... that did not work. @UltraBlack, What versions did you downgrade to when you rolled back and was there anything else?

You updated the entire system, right, not just qt5-base? You're familiar with partial update scenarios?

3 Likes

Yes, I did as I updated the entire system from the "add/remove software, and double checked with sudo Pacman -Syu and then restarted, Although I am not familiar with partial update scenarios. When I tried to both start a created python file and tried the same issue with mod organizer 2, both still had the same problems they had before.